aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/custominput/custominput_1.1.0.bb
diff options
context:
space:
mode:
authorDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
committerDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
commit709c4d66e0b107ca606941b988bad717c0b45d9b (patch)
tree37ee08b1eb308f3b2b6426d5793545c38396b838 /recipes/custominput/custominput_1.1.0.bb
parentfa6cd5a3b993f16c27de4ff82b42684516d433ba (diff)
downloadopenembedded-709c4d66e0b107ca606941b988bad717c0b45d9b.tar.gz
rename packages/ to recipes/ per earlier agreement
See links below for more details: http://thread.gmane.org/gmane.comp.handhelds.openembedded/21326 http://thread.gmane.org/gmane.comp.handhelds.openembedded/21816 Signed-off-by: Denys Dmytriyenko <denis@denix.org> Acked-by: Mike Westerhof <mwester@dls.net> Acked-by: Philip Balister <philip@balister.org> Acked-by: Khem Raj <raj.khem@gmail.com> Acked-by: Marcin Juszkiewicz <hrw@openembedded.org> Acked-by: Koen Kooi <koen@openembedded.org> Acked-by: Frans Meulenbroeks <fransmeulenbroeks@gmail.com>
Diffstat (limited to 'recipes/custominput/custominput_1.1.0.bb')
-rw-r--r--recipes/custominput/custominput_1.1.0.bb36
1 files changed, 36 insertions, 0 deletions
diff --git a/recipes/custominput/custominput_1.1.0.bb b/recipes/custominput/custominput_1.1.0.bb
new file mode 100644
index 0000000000..3becdc2df1
--- /dev/null
+++ b/recipes/custominput/custominput_1.1.0.bb
@@ -0,0 +1,36 @@
+DESCRIPTION = "Custom Keyboard \
+Keyboard that can be customized to include exactly the characters that the user uses, but which is not available on his physical keyboard."
+SECTION = "opie/inputmethods"
+PRIORITY = "optional"
+LICENSE = "GPL"
+HOMEPAGE = "http://www.blackie.dk/Zaurus/custominput/"
+AUTHOR = "Jesper Kjaer Pedersen <blackie@blackie.dk>"
+
+SRC_URI = "http://www.blackie.dk/Zaurus/custominput/custominput-1.1.0.tgz"
+
+inherit palmtop
+
+QMAKE_PROFILES = "custominput.pro"
+
+EXTRA_QMAKEVARS_POST += "DESTDIR=${S}"
+
+do_configure_prepend() {
+ find ${S} -name Makefile|xargs rm
+}
+
+do_install() {
+
+ install -d ${D}${palmtopdir}/plugins/inputmethods/ \
+ ${D}${palmtopdir}/pics/ \
+ ${D}${palmtopdir}/bin/ \
+ ${D}${palmtopdir}/apps/ \
+ ${D}${palmtopdir}/apps/Settings/ \
+ ${D}${palmtopdir}/help/html/
+
+ install -m 0755 ${S}/customInputConfig ${D}${palmtopdir}/bin/
+ install -m 0644 ${S}/custominput.desktop ${D}${palmtopdir}/apps/Settings/
+ install -m 0644 ${S}/customInputConfig.html ${D}${palmtopdir}/help/html/
+ install -m 0644 ${S}/custominput.png ${D}${palmtopdir}/pics/
+ oe_libinstall -so -C ${S}/ libcustominput ${D}${palmtopdir}/plugins/inputmethods/
+
+}