summaryrefslogtreecommitdiffstats
path: root/recipes/cvs
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2010-06-02 19:45:13 -0700
committerKhem Raj <raj.khem@gmail.com>2010-06-05 06:52:42 -0700
commit55b15cba4bb1615ff195a0c7332319de953802f2 (patch)
treef57fc4735701eccc68ee1536e39ecae640d6bdba /recipes/cvs
parent31e6b45738b43e34923c2006e8522fe3ce0fa1b9 (diff)
downloadopenembedded-55b15cba4bb1615ff195a0c7332319de953802f2.tar.gz
cvs-1.12.9: uclibc does not export __mempcpy so use mempcpy
Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'recipes/cvs')
-rw-r--r--recipes/cvs/cvs-1.12.9/fix-__mempcpy.patch16
-rw-r--r--recipes/cvs/cvs_1.12.9.bb5
2 files changed, 20 insertions, 1 deletions
diff --git a/recipes/cvs/cvs-1.12.9/fix-__mempcpy.patch b/recipes/cvs/cvs-1.12.9/fix-__mempcpy.patch
new file mode 100644
index 0000000000..83a6915b50
--- /dev/null
+++ b/recipes/cvs/cvs-1.12.9/fix-__mempcpy.patch
@@ -0,0 +1,16 @@
+Index: cvs-1.12.9/lib/regex.c
+===================================================================
+--- cvs-1.12.9.orig/lib/regex.c 2010-06-02 17:40:24.350340585 -0700
++++ cvs-1.12.9/lib/regex.c 2010-06-02 17:42:54.460370216 -0700
+@@ -8182,7 +8182,11 @@ regerror (int errcode, const regex_t *pr
+ if (msg_size > errbuf_size)
+ {
+ #if defined HAVE_MEMPCPY || defined _LIBC
++#if defined __UCLIBC__
++ *((char *) mempcpy (errbuf, msg, errbuf_size - 1)) = '\0';
++#else
+ *((char *) __mempcpy (errbuf, msg, errbuf_size - 1)) = '\0';
++#endif
+ #else
+ memcpy (errbuf, msg, errbuf_size - 1);
+ errbuf[errbuf_size - 1] = 0;
diff --git a/recipes/cvs/cvs_1.12.9.bb b/recipes/cvs/cvs_1.12.9.bb
index b345a9c73a..5ce3ecf794 100644
--- a/recipes/cvs/cvs_1.12.9.bb
+++ b/recipes/cvs/cvs_1.12.9.bb
@@ -3,9 +3,12 @@ SECTION = "console/network"
PRIORITY = "optional"
DEPENDS = ""
LICENSE = "GPL"
+PR = "r1"
SRC_URI = "http://musthave.sunbase.org/progs/ccvs/cvs-${PV}/cvs-${PV}.tar.bz2 \
- file://m4.patch"
+ file://m4.patch \
+ file://fix-__mempcpy.patch \
+ "
inherit autotools gettext