aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/cwiid/cwiid_0.6.00.bb
diff options
context:
space:
mode:
authorDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
committerDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
commit709c4d66e0b107ca606941b988bad717c0b45d9b (patch)
tree37ee08b1eb308f3b2b6426d5793545c38396b838 /recipes/cwiid/cwiid_0.6.00.bb
parentfa6cd5a3b993f16c27de4ff82b42684516d433ba (diff)
downloadopenembedded-709c4d66e0b107ca606941b988bad717c0b45d9b.tar.gz
rename packages/ to recipes/ per earlier agreement
See links below for more details: http://thread.gmane.org/gmane.comp.handhelds.openembedded/21326 http://thread.gmane.org/gmane.comp.handhelds.openembedded/21816 Signed-off-by: Denys Dmytriyenko <denis@denix.org> Acked-by: Mike Westerhof <mwester@dls.net> Acked-by: Philip Balister <philip@balister.org> Acked-by: Khem Raj <raj.khem@gmail.com> Acked-by: Marcin Juszkiewicz <hrw@openembedded.org> Acked-by: Koen Kooi <koen@openembedded.org> Acked-by: Frans Meulenbroeks <fransmeulenbroeks@gmail.com>
Diffstat (limited to 'recipes/cwiid/cwiid_0.6.00.bb')
-rw-r--r--recipes/cwiid/cwiid_0.6.00.bb38
1 files changed, 38 insertions, 0 deletions
diff --git a/recipes/cwiid/cwiid_0.6.00.bb b/recipes/cwiid/cwiid_0.6.00.bb
new file mode 100644
index 0000000000..2f7f93d062
--- /dev/null
+++ b/recipes/cwiid/cwiid_0.6.00.bb
@@ -0,0 +1,38 @@
+DESCRIPTION = "wiimote library + tools"
+LICENSE = "GPLv2"
+HOMEPAGE = "http://abstrakraft.org/cwiid/"
+
+PR = "r0"
+
+inherit autotools
+inherit distutils-base
+
+export BUILD_SYS
+export HOST_SYS
+
+PARALLEL_MAKE = ""
+
+SRC_URI = "http://abstrakraft.org/cwiid/downloads/cwiid-${PV}.tgz"
+
+EXTRA_OECONF = "--disable-ldconfig"
+
+FILES_${PN} += "\
+ /etc/cwiid/wminput/buttons \
+ /etc/cwiid/wminput/acc_ptr \
+ /etc/cwiid/wminput/ir_ptr \
+ /etc/cwiid/wminput/default \
+ /etc/cwiid/wminput/nunchuk_acc_ptr \
+ /etc/cwiid/wminput/neverball \
+ /etc/cwiid/wminput/gamepad \
+"
+
+FILES_${PN}-dbg += "\
+ ${libdir}/cwiid/plugins/.debug \
+"
+
+do_configure_append() {
+ find ${S} -name Makefile | xargs sed -i s:'-I$(includedir)':'-I.':g
+ find ${S} -name Makefile | xargs sed -i s:'-I/usr/include':'-I${STAGING_INCDIR}':g
+}
+
+