aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/cxcrypt
diff options
context:
space:
mode:
authorDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
committerDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
commit709c4d66e0b107ca606941b988bad717c0b45d9b (patch)
tree37ee08b1eb308f3b2b6426d5793545c38396b838 /recipes/cxcrypt
parentfa6cd5a3b993f16c27de4ff82b42684516d433ba (diff)
downloadopenembedded-709c4d66e0b107ca606941b988bad717c0b45d9b.tar.gz
rename packages/ to recipes/ per earlier agreement
See links below for more details: http://thread.gmane.org/gmane.comp.handhelds.openembedded/21326 http://thread.gmane.org/gmane.comp.handhelds.openembedded/21816 Signed-off-by: Denys Dmytriyenko <denis@denix.org> Acked-by: Mike Westerhof <mwester@dls.net> Acked-by: Philip Balister <philip@balister.org> Acked-by: Khem Raj <raj.khem@gmail.com> Acked-by: Marcin Juszkiewicz <hrw@openembedded.org> Acked-by: Koen Kooi <koen@openembedded.org> Acked-by: Frans Meulenbroeks <fransmeulenbroeks@gmail.com>
Diffstat (limited to 'recipes/cxcrypt')
-rw-r--r--recipes/cxcrypt/cxcrypt_1.0.bb34
1 files changed, 34 insertions, 0 deletions
diff --git a/recipes/cxcrypt/cxcrypt_1.0.bb b/recipes/cxcrypt/cxcrypt_1.0.bb
new file mode 100644
index 0000000000..705859319b
--- /dev/null
+++ b/recipes/cxcrypt/cxcrypt_1.0.bb
@@ -0,0 +1,34 @@
+DESCRIPTION = "A simple, xor-based encryption tool"
+SECTION = "base"
+PRIORITY = "optional"
+LICENSE = "LGPL"
+
+SRC_URI = "http://www.fh-wedel.de/pub/fh-wedel/staff/herbert/misc/${PN}-${PV}.tar.gz"
+S = "${WORKDIR}/cxcrypt"
+
+CFLAGS_prepend = "-g -Wall -ansi -pedantic "
+LDFLAGS_prepend = "-L. -lcxio "
+
+do_compile() {
+ oe_runmake
+}
+
+do_install() {
+ install -d -m 755 ${D}/usr/bin
+ install -d -m 755 ${D}/usr/lib
+ install -d -m 755 ${D}/usr/include
+ install -m 755 cxcrypt ${D}/usr/bin
+ install -m 755 libcxio.a ${D}/usr/lib
+ install -m 755 cxio.h ${D}/usr/include
+}
+
+do_stage() {
+ install -d -m 755 ${STAGING_INCDIR}
+ install -d -m 755 ${STAGING_LIBDIR}
+ install -m 644 cxio.h ${STAGING_INCDIR}
+ install -m 644 libcxio.a ${STAGING_LIBDIR}
+}
+
+FILES_${PN} = "/usr/bin/${PN}"
+FILES_${PN}-dev = "/usr/lib/libcxio.a /usr/include"
+