aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/cyrus-sasl/cyrus-sasl_2.1.18.bb
diff options
context:
space:
mode:
authorDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
committerDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
commit709c4d66e0b107ca606941b988bad717c0b45d9b (patch)
tree37ee08b1eb308f3b2b6426d5793545c38396b838 /recipes/cyrus-sasl/cyrus-sasl_2.1.18.bb
parentfa6cd5a3b993f16c27de4ff82b42684516d433ba (diff)
downloadopenembedded-709c4d66e0b107ca606941b988bad717c0b45d9b.tar.gz
rename packages/ to recipes/ per earlier agreement
See links below for more details: http://thread.gmane.org/gmane.comp.handhelds.openembedded/21326 http://thread.gmane.org/gmane.comp.handhelds.openembedded/21816 Signed-off-by: Denys Dmytriyenko <denis@denix.org> Acked-by: Mike Westerhof <mwester@dls.net> Acked-by: Philip Balister <philip@balister.org> Acked-by: Khem Raj <raj.khem@gmail.com> Acked-by: Marcin Juszkiewicz <hrw@openembedded.org> Acked-by: Koen Kooi <koen@openembedded.org> Acked-by: Frans Meulenbroeks <fransmeulenbroeks@gmail.com>
Diffstat (limited to 'recipes/cyrus-sasl/cyrus-sasl_2.1.18.bb')
-rw-r--r--recipes/cyrus-sasl/cyrus-sasl_2.1.18.bb41
1 files changed, 41 insertions, 0 deletions
diff --git a/recipes/cyrus-sasl/cyrus-sasl_2.1.18.bb b/recipes/cyrus-sasl/cyrus-sasl_2.1.18.bb
new file mode 100644
index 0000000000..a863d3e5ad
--- /dev/null
+++ b/recipes/cyrus-sasl/cyrus-sasl_2.1.18.bb
@@ -0,0 +1,41 @@
+SECTION = "console/network"
+DEPENDS = "virtual/db"
+DESCRIPTION = "Generic client/server library for SASL authentication."
+LICENSE = "BSD"
+
+PR = "r1"
+
+SRC_URI = "ftp://ftp.andrew.cmu.edu/pub/cyrus-mail/OLD-VERSIONS/sasl/cyrus-sasl-${PV}.tar.gz"
+
+inherit autotools
+
+acpaths = "-I ${S}/cmulocal -I ${S}/config -I ."
+CFLAGS_append = " -I${S}/include -I${S}/saslauthd/include"
+EXTRA_OECONF = "--enable-shared --enable-static --with-dblib=berkeley \
+ --with-bdb-libdir=${STAGING_LIBDIR} \
+ --with-bdb-incdir=${STAGING_INCDIR} \
+ --without-opie --without-des"
+
+do_configure_prepend () {
+ rm -f acinclude.m4 config/libtool.m4
+}
+
+do_compile_prepend () {
+ cd include
+ ${BUILD_CC} ${BUILD_CFLAGS} ${BUILD_LDFLAGS} makemd5.c -o makemd5
+ touch makemd5.o makemd5.lo makemd5
+ cd ..
+}
+
+do_stage () {
+ oe_libinstall -so -a -C lib libsasl2 ${STAGING_LIBDIR}
+ install -d ${STAGING_LIBDIR}/sasl
+ install -d ${STAGING_INCDIR}/sasl
+ install -m 0644 ${S}/include/hmac-md5.h ${STAGING_INCDIR}/sasl/
+ install -m 0644 ${S}/include/md5.h ${STAGING_INCDIR}/sasl/
+ install -m 0644 ${S}/include/md5global.h ${STAGING_INCDIR}/sasl/
+ install -m 0644 ${S}/include/sasl.h ${STAGING_INCDIR}/sasl/
+ install -m 0644 ${S}/include/saslplug.h ${STAGING_INCDIR}/sasl/
+ install -m 0644 ${S}/include/saslutil.h ${STAGING_INCDIR}/sasl/
+ install -m 0644 ${S}/include/prop.h ${STAGING_INCDIR}/sasl/
+}