summaryrefslogtreecommitdiffstats
path: root/recipes/dash
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2009-08-27 00:01:45 -0700
committerKhem Raj <raj.khem@gmail.com>2009-08-27 00:01:45 -0700
commit628d887f5cf5c32c2d3f23c981f35c3cb84a4d49 (patch)
treef56e0cfb1ea2c53dac71c9308902137d421bbf3f /recipes/dash
parent865ed19cd318a8ca35b3dff2db8518851e00b8e2 (diff)
downloadopenembedded-628d887f5cf5c32c2d3f23c981f35c3cb84a4d49.tar.gz
dash_0.5.2.bb: Add recipe for latest dash.
Remove unbuildable dash_0.5.2 recipe. Add checksums for new dash and diffstat Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'recipes/dash')
-rw-r--r--recipes/dash/dash_0.5.5.1.bb (renamed from recipes/dash/dash_0.5.2.bb)3
-rw-r--r--recipes/dash/files/makefile-build-cc.diff28
2 files changed, 12 insertions, 19 deletions
diff --git a/recipes/dash/dash_0.5.2.bb b/recipes/dash/dash_0.5.5.1.bb
index ee4e8c1bd6..7a88407925 100644
--- a/recipes/dash/dash_0.5.2.bb
+++ b/recipes/dash/dash_0.5.5.1.bb
@@ -1,10 +1,9 @@
DESCRIPTION = "The Debian Almquist Shell is a POSIX compliant shell that is much smaller than 'bash'."
PROVIDES = "virtual/sh"
LICENSE = "BSD GPL"
-PR = "r1"
SRC_URI = "http://ftp.debian.org/debian/pool/main/d/dash/dash_${PV}.orig.tar.gz \
- http://snapshot.debian.net/archive/2005/07/11/debian/pool/main/d/dash/dash_0.5.2-6.diff.gz;patch=1 \
+ http://ftp.debian.org/debian/pool/main/d/dash/dash_${PV}-2.3.diff.gz;patch=1 \
file://makefile-build-cc.diff;patch=1"
inherit autotools
diff --git a/recipes/dash/files/makefile-build-cc.diff b/recipes/dash/files/makefile-build-cc.diff
index 8ffd6c2c37..a980a83324 100644
--- a/recipes/dash/files/makefile-build-cc.diff
+++ b/recipes/dash/files/makefile-build-cc.diff
@@ -1,29 +1,23 @@
---- dash-0.5.1/src/Makefile.am.orig 2004-07-03 05:13:27.000000000 +0200
-+++ dash-0.5.1/src/Makefile.am 2005-01-11 11:14:11.896299544 +0100
-@@ -3,6 +3,7 @@
- AM_CPPFLAGS = -include $(top_builddir)/config.h
- AM_YFLAGS = -d
-
-+BUILD_CC ?= gcc
- CFLAGS = -g -O2 -Wall
- DEFS = \
- -DBSD=1 -DSMALL -DSHELL \
-@@ -35,6 +36,18 @@
- mktokens mkbuiltins builtins.def mkinit.c \
+Index: dash-0.5.5.1/src/Makefile.am
+===================================================================
+--- dash-0.5.5.1.orig/src/Makefile.am 2009-01-13 15:37:13.000000000 -0800
++++ dash-0.5.5.1/src/Makefile.am 2009-08-26 23:56:58.879275498 -0700
+@@ -44,6 +44,18 @@
+ mktokens mkbuiltins builtins.def.in mkinit.c \
mknodes.c nodetypes nodes.c.pat mksyntax.c mksignames.c
+mknodes:
-+ $(BUILD_CC) mknodes.c -o mknodes
++ $(COMPILE_FOR_BUILD) mknodes.c -o mknodes
+
+mksyntax:
-+ $(BUILD_CC) mksyntax.c -o mksyntax
++ $(COMPILE_FOR_BUILD) mksyntax.c -o mksyntax
+
+mkinit:
-+ $(BUILD_CC) mkinit.c -o mkinit
++ $(COMPILE_FOR_BUILD) mkinit.c -o mkinit
+
+mksignames:
-+ $(BUILD_CC) mksignames.c -o mksignames
-+
++ $(COMPILE_FOR_BUILD) mksignames.c -o mksignames
++
token.h: mktokens
sh $^