aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/dasher
diff options
context:
space:
mode:
authorDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
committerDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
commit709c4d66e0b107ca606941b988bad717c0b45d9b (patch)
tree37ee08b1eb308f3b2b6426d5793545c38396b838 /recipes/dasher
parentfa6cd5a3b993f16c27de4ff82b42684516d433ba (diff)
downloadopenembedded-709c4d66e0b107ca606941b988bad717c0b45d9b.tar.gz
rename packages/ to recipes/ per earlier agreement
See links below for more details: http://thread.gmane.org/gmane.comp.handhelds.openembedded/21326 http://thread.gmane.org/gmane.comp.handhelds.openembedded/21816 Signed-off-by: Denys Dmytriyenko <denis@denix.org> Acked-by: Mike Westerhof <mwester@dls.net> Acked-by: Philip Balister <philip@balister.org> Acked-by: Khem Raj <raj.khem@gmail.com> Acked-by: Marcin Juszkiewicz <hrw@openembedded.org> Acked-by: Koen Kooi <koen@openembedded.org> Acked-by: Frans Meulenbroeks <fransmeulenbroeks@gmail.com>
Diffstat (limited to 'recipes/dasher')
-rw-r--r--recipes/dasher/dasher-gpe/configure-lossage.patch21
-rw-r--r--recipes/dasher/dasher-gpe_0.0-svn.bb31
2 files changed, 52 insertions, 0 deletions
diff --git a/recipes/dasher/dasher-gpe/configure-lossage.patch b/recipes/dasher/dasher-gpe/configure-lossage.patch
new file mode 100644
index 0000000000..e5a6896266
--- /dev/null
+++ b/recipes/dasher/dasher-gpe/configure-lossage.patch
@@ -0,0 +1,21 @@
+--- dasher/configure.in.old 2004-08-29 23:50:19.000000000 +0100
++++ dasher/configure.in 2004-08-29 23:50:23.000000000 +0100
+@@ -89,12 +89,12 @@
+ LIBS="$save_LIBS"
+ break],[AC_MSG_RESULT(no)])
+ done
+- if test "x$XTST_LIBS" = x; then
+- AC_MSG_ERROR(Couldn't find the Xtst library. Check config.log for details)
+- else
+- X_LIBS="$X_LIBS $XTST_LIBS"
+- AC_DEFINE(HAVE_XTST, 1, [The XTest extension is present])
+- fi
++ fi
++ if test "x$XTST_LIBS" = x; then
++ AC_MSG_ERROR(Couldn't find the Xtst library. Check config.log for details)
++ else
++ X_LIBS="$X_LIBS $XTST_LIBS"
++ AC_DEFINE(HAVE_XTST, 1, [The XTest extension is present])
+ fi
+
+ AC_SUBST(X_LIBS)
diff --git a/recipes/dasher/dasher-gpe_0.0-svn.bb b/recipes/dasher/dasher-gpe_0.0-svn.bb
new file mode 100644
index 0000000000..297aa9ac4f
--- /dev/null
+++ b/recipes/dasher/dasher-gpe_0.0-svn.bb
@@ -0,0 +1,31 @@
+LICENSE="GPL"
+PV = "0.0+svnr${SRCREV}"
+PR = "r1"
+DEPENDS = "libxsettings-client libglade libxtst gconf gtk+"
+SECTION = "gpe"
+SRC_URI = "svn://svn.gnome.org/svn/dasher;module=trunk \
+ file://configure-lossage.patch;patch=1"
+
+S = "${WORKDIR}/trunk"
+FILES_${PN} += "${datadir}/dasher"
+
+inherit autotools
+
+
+EXTRA_OECONF = "--with-gpe --without-gnome --without-speech --without-a11y"
+LDFLAGS_append = '-Wl,--export-dynamic'
+
+do_configure_prepend() {
+ rm -f m4/libtool.m4
+ intltoolize --force
+}
+
+do_install_append () {
+ install -d ${D}${datadir}/pixmaps/
+ mv ${D}${datadir}/icons/dasher.png ${D}${datadir}/pixmaps/
+}
+
+python populate_packages_prepend () {
+ do_split_packages(d, bb.data.expand("${datadir}/dasher", d), "training_(.*).txt", "dasher-training-data-%s", "Dasher training data for %s", prepend=True)
+}
+