aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/dbh
diff options
context:
space:
mode:
authorDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
committerDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
commit709c4d66e0b107ca606941b988bad717c0b45d9b (patch)
tree37ee08b1eb308f3b2b6426d5793545c38396b838 /recipes/dbh
parentfa6cd5a3b993f16c27de4ff82b42684516d433ba (diff)
downloadopenembedded-709c4d66e0b107ca606941b988bad717c0b45d9b.tar.gz
rename packages/ to recipes/ per earlier agreement
See links below for more details: http://thread.gmane.org/gmane.comp.handhelds.openembedded/21326 http://thread.gmane.org/gmane.comp.handhelds.openembedded/21816 Signed-off-by: Denys Dmytriyenko <denis@denix.org> Acked-by: Mike Westerhof <mwester@dls.net> Acked-by: Philip Balister <philip@balister.org> Acked-by: Khem Raj <raj.khem@gmail.com> Acked-by: Marcin Juszkiewicz <hrw@openembedded.org> Acked-by: Koen Kooi <koen@openembedded.org> Acked-by: Frans Meulenbroeks <fransmeulenbroeks@gmail.com>
Diffstat (limited to 'recipes/dbh')
-rw-r--r--recipes/dbh/dbh-1.0-18/configure.patch42
-rw-r--r--recipes/dbh/dbh_1.0-18.bb18
2 files changed, 60 insertions, 0 deletions
diff --git a/recipes/dbh/dbh-1.0-18/configure.patch b/recipes/dbh/dbh-1.0-18/configure.patch
new file mode 100644
index 0000000000..50cc7403a5
--- /dev/null
+++ b/recipes/dbh/dbh-1.0-18/configure.patch
@@ -0,0 +1,42 @@
+Index: dbh_1.0-18/configure.ac
+===================================================================
+--- dbh_1.0-18.orig/configure.ac 2004-03-16 16:02:20.000000000 -0700
++++ dbh_1.0-18/configure.ac 2005-04-06 12:30:01.900159452 -0700
+@@ -34,6 +34,8 @@
+
+ dnl Initialize libtool
+ AC_CANONICAL_HOST
++AC_CANONICAL_TARGET
++
+ # libtool.m4 is a bit outof sync.
+ AC_PROG_LIBTOOL
+
+@@ -122,17 +124,17 @@
+
+
+ dnl echo "dbg:target $target"
+-case "$target" in
+-"")
+-;;
+-"no")
+-;;
+-"NONE")
+-;;
+-*)
+- CFLAGS="$CFLAGS -march=$target"
+- ;;
+-esac
++dnl case "$target" in
++dnl "")
++dnl ;;
++dnl "no")
++dnl ;;
++dnl "NONE")
++dnl ;;
++dnl *)
++dnl CFLAGS="$CFLAGS -march=$target_cpu"
++dnl ;;
++dnl esac
+
+ # At present, only 32 bit system.
+
diff --git a/recipes/dbh/dbh_1.0-18.bb b/recipes/dbh/dbh_1.0-18.bb
new file mode 100644
index 0000000000..c15349f6fd
--- /dev/null
+++ b/recipes/dbh/dbh_1.0-18.bb
@@ -0,0 +1,18 @@
+# Copyright (C) 2004, Advanced Micro Devices, Inc. All Rights Reserved
+# Released under the MIT license (see packages/COPYING)
+DESCRIPTION ="Disk based hashes is a method to create multidimensional binary trees on disk."
+HOMEPAGE = "http://dbh.sourceforge.net"
+LICENSE = "GPL"
+SECTION = "libs"
+PR = "r2"
+
+SRC_URI = "${SOURCEFORGE_MIRROR}/dbh/dbh_${PV}.tar.bz2 \
+ file://${FILESDIR}/configure.patch;patch=1"
+
+S="${WORKDIR}/dbh_${PV}"
+
+inherit autotools pkgconfig
+
+do_stage() {
+autotools_stage_all
+}