aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/dbus/dbus.inc
diff options
context:
space:
mode:
authorGraham Gower <graham.gower@gmail.com>2009-08-06 15:26:21 +0000
committerHolger Hans Peter Freyther <zecke@selfish.org>2009-08-12 05:24:29 +0200
commitdd72daef5fd9b6660e8b9093607b4aea09ec643f (patch)
tree71099312f86ed0ac55cd9af3a80664591ad4e970 /recipes/dbus/dbus.inc
parent3c987350ba0eeeefd08e0da677bdd0f5f62130b4 (diff)
downloadopenembedded-dd72daef5fd9b6660e8b9093607b4aea09ec643f.tar.gz
dbus: fix dbus-daemon segfault on mipsel with recent toolchain
dbus-daemon segfaults on mipsel when built with -fPIE/-pie, as outlined in http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=532821 Removes PIE compilation from the dbus-daemon Makefile as a workaround. Signed-off-by: Graham Gower <graham.gower@gmail.com> Acked-by: Khem Raj <raj.khem@gmail.com> Signed-off-by: Holger Freyther <zecke@selfish.org>
Diffstat (limited to 'recipes/dbus/dbus.inc')
-rw-r--r--recipes/dbus/dbus.inc6
1 files changed, 6 insertions, 0 deletions
diff --git a/recipes/dbus/dbus.inc b/recipes/dbus/dbus.inc
index 0302cfe776..b5eeb08629 100644
--- a/recipes/dbus/dbus.inc
+++ b/recipes/dbus/dbus.inc
@@ -4,6 +4,8 @@ SECTION = "base"
LICENSE = "GPL"
DEPENDS = "expat glib-2.0 virtual/libintl libsm libice virtual/libx11"
+INC_PR = "r16"
+
SRC_URI = "\
http://dbus.freedesktop.org/releases/dbus/dbus-${PV}.tar.gz \
file://cross.patch;patch=1 \
@@ -30,6 +32,10 @@ EXTRA_OECONF = "\
--with-dbus-default-reply-timeout=200000 \
"
+do_compile_prepend_mipsel() {
+ sed -i -e 's/\-fPIE//' -e 's/\-pie\ \-Wl\,\-z\,relro//' bus/Makefile
+}
+
do_install_append() {
install -d ${D}${sysconfdir}/init.d
install -m 0755 ${WORKDIR}/dbus-1.init ${D}${sysconfdir}/init.d/dbus-1