aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/dbus
diff options
context:
space:
mode:
authorRichard Purdie <rpurdie@linux.intel.com>2009-11-13 09:38:04 +0000
committerRichard Purdie <rpurdie@linux.intel.com>2009-11-13 09:38:04 +0000
commit8e39848b2a3a55440a5557ca9e5ae10de412acc9 (patch)
treee93b3f6d2619536271c4902e4d389dcc9943a08a /recipes/dbus
parentedf2a4ca8339d705a35f6fd158b52b486d3a9378 (diff)
downloadopenembedded-8e39848b2a3a55440a5557ca9e5ae10de412acc9.tar.gz
dbus-1.2.1: Update fix-daemon-install patch to use automake magic to avoid the wrapper scripts
Signed-off-by: Richard Purdie <rpurdie@linux.intel.com>
Diffstat (limited to 'recipes/dbus')
-rw-r--r--recipes/dbus/dbus-1.2.1/fix-install-daemon.patch42
-rw-r--r--recipes/dbus/dbus-native_1.2.1.bb2
-rw-r--r--recipes/dbus/dbus_1.2.1.bb2
3 files changed, 35 insertions, 11 deletions
diff --git a/recipes/dbus/dbus-1.2.1/fix-install-daemon.patch b/recipes/dbus/dbus-1.2.1/fix-install-daemon.patch
index c31786357d..8d3bfd07e1 100644
--- a/recipes/dbus/dbus-1.2.1/fix-install-daemon.patch
+++ b/recipes/dbus/dbus-1.2.1/fix-install-daemon.patch
@@ -1,13 +1,37 @@
-Index: dbus-0.94/bus/Makefile.am
+Index: dbus-1.2.1/bus/Makefile.am
===================================================================
---- dbus-0.94.orig/bus/Makefile.am 2006-10-01 17:36:18.000000000 +0200
-+++ dbus-0.94/bus/Makefile.am 2006-10-14 21:40:05.000000000 +0200
-@@ -110,7 +110,7 @@
- $(mkinstalldirs) $(DESTDIR)$(DBUS_DAEMONDIR); \
- chmod 755 $(DESTDIR)$(DBUS_DAEMONDIR); \
- fi
+--- dbus-1.2.1.orig/bus/Makefile.am 2008-04-04 16:24:08.000000000 +0100
++++ dbus-1.2.1/bus/Makefile.am 2009-11-13 09:30:57.000000000 +0000
+@@ -149,7 +149,7 @@
+
+ ## we use noinst_PROGRAMS not check_PROGRAMS so that we build
+ ## even when not doing "make check"
+-noinst_PROGRAMS=$(TESTS) dbus-daemon dbus-daemon-launch-helper-test dbus-daemon-launch-helper
++noinst_PROGRAMS=$(TESTS) dbus-daemon-launch-helper-test dbus-daemon-launch-helper
+
+ bus_test_system_SOURCES= \
+ $(XML_SOURCES) \
+@@ -171,20 +171,17 @@
+ bus_test_LDADD=$(top_builddir)/dbus/libdbus-convenience.la $(DBUS_BUS_LIBS)
+ bus_test_LDFLAGS=@R_DYNAMIC_LDFLAG@
+
++dbusdaemondir = $(DBUS_DAEMONDIR)
++dbusdaemon_PROGRAMS = dbus-daemon
++
+ ## mop up the gcov files
+ clean-local:
+ /bin/rm *.bb *.bbg *.da *.gcov || true
+
+ uninstall-hook:
+- rm -f $(DESTDIR)$(DBUS_DAEMONDIR)/dbus-daemon
+ rm -f $(DESTDIR)$(libexecdir)/dbus-daemon-launch-helper
+
+ install-data-hook:
+- if test '!' -d $(DESTDIR)$(DBUS_DAEMONDIR); then \
+- $(mkinstalldirs) $(DESTDIR)$(DBUS_DAEMONDIR); \
+- chmod 755 $(DESTDIR)$(DBUS_DAEMONDIR); \
+- fi
- $(INSTALL_PROGRAM) dbus-daemon $(DESTDIR)$(DBUS_DAEMONDIR)
-+ $(INSTALL_PROGRAM) .libs/dbus-daemon $(DESTDIR)$(DBUS_DAEMONDIR)
$(mkinstalldirs) $(DESTDIR)$(localstatedir)/run/dbus
$(mkinstalldirs) $(DESTDIR)$(configdir)/system.d
- $(mkinstalldirs) $(DESTDIR)$(datadir)/dbus-1/services
+ $(mkinstalldirs) $(DESTDIR)$(configdir)/session.d
diff --git a/recipes/dbus/dbus-native_1.2.1.bb b/recipes/dbus/dbus-native_1.2.1.bb
index 472b7e8154..ffdddf2b97 100644
--- a/recipes/dbus/dbus-native_1.2.1.bb
+++ b/recipes/dbus/dbus-native_1.2.1.bb
@@ -1,5 +1,5 @@
require dbus.inc
-PR = "${INC_PR}.1"
+PR = "${INC_PR}.2"
RRECOMMENDS_${PN} = ""
RDEPENDS_${PN} = ""
inherit native
diff --git a/recipes/dbus/dbus_1.2.1.bb b/recipes/dbus/dbus_1.2.1.bb
index 72db1daa9c..d4e5811451 100644
--- a/recipes/dbus/dbus_1.2.1.bb
+++ b/recipes/dbus/dbus_1.2.1.bb
@@ -1,3 +1,3 @@
include dbus.inc
-PR = "${INC_PR}.0"
+PR = "${INC_PR}.1"