aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/dbus
diff options
context:
space:
mode:
authorSteffen Sledz <sledz@dresearch.de>2010-10-07 19:42:13 +0200
committerSteffen Sledz <sledz@dresearch.de>2010-10-07 19:42:13 +0200
commitd1008e24d30635bb489b363722ae2666f22eae09 (patch)
tree8e3ea8caf49dc9185371eed713b7c02e968bc122 /recipes/dbus
parent65bd13c8c9e1779b99bf926688fb2d50a037c63d (diff)
downloadopenembedded-d1008e24d30635bb489b363722ae2666f22eae09.tar.gz
dbus: allow anon dbus connections at hipox machine
Signed-off-by: Steffen Sledz <sledz@dresearch.de>
Diffstat (limited to 'recipes/dbus')
-rw-r--r--recipes/dbus/dbus/anon.patch13
-rw-r--r--recipes/dbus/dbus_1.2.24.bb2
-rw-r--r--recipes/dbus/dbus_1.3.1.bb2
3 files changed, 17 insertions, 0 deletions
diff --git a/recipes/dbus/dbus/anon.patch b/recipes/dbus/dbus/anon.patch
new file mode 100644
index 0000000000..c9bf7bfa63
--- /dev/null
+++ b/recipes/dbus/dbus/anon.patch
@@ -0,0 +1,13 @@
+diff -Naur dbus-1.2.1.orig/dbus/dbus-transport.c dbus-1.2.1/dbus/dbus-transport.c
+--- dbus-1.2.1.orig/dbus/dbus-transport.c 2008-09-16 15:10:02.000000000 +0000
++++ dbus-1.2.1/dbus/dbus-transport.c 2008-09-16 15:10:10.000000000 +0000
+@@ -747,6 +747,9 @@
+ dbus_bool_t allow;
+ DBusCredentials *auth_identity;
+
++ // allow anonymous connections
++ _dbus_transport_set_allow_anonymous(transport, TRUE);
++
+ auth_identity = _dbus_auth_get_identity (transport->auth);
+ _dbus_assert (auth_identity != NULL);
+
diff --git a/recipes/dbus/dbus_1.2.24.bb b/recipes/dbus/dbus_1.2.24.bb
index 5ef1fef891..75825514b8 100644
--- a/recipes/dbus/dbus_1.2.24.bb
+++ b/recipes/dbus/dbus_1.2.24.bb
@@ -12,6 +12,8 @@ SRC_URI = "\
file://reuseaddr02.patch \
"
+SRC_URI_append_hipox = "file://anon.patch"
+
SRC_URI[dbus.md5sum] = "565346cecd9cfecf1463540c6086cc2c"
SRC_URI[dbus.sha256sum] = "f12c748f4a703655e3d4c3db94cdf5a752a0cd0b36958c715804373bd3595c48"
diff --git a/recipes/dbus/dbus_1.3.1.bb b/recipes/dbus/dbus_1.3.1.bb
index b30bdab3c3..735fde35dc 100644
--- a/recipes/dbus/dbus_1.3.1.bb
+++ b/recipes/dbus/dbus_1.3.1.bb
@@ -13,6 +13,8 @@ SRC_URI = "\
file://reuseaddr02.patch \
"
+SRC_URI_append_hipox = "file://anon.patch"
+
# This is a development version of dbus that will lead to 1.4.0
DEFAULT_PREFERENCE = "-1"