aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/dbus
diff options
context:
space:
mode:
authorGraham Gower <graham.gower@gmail.com>2009-08-06 15:26:21 +0000
committerHolger Hans Peter Freyther <zecke@selfish.org>2009-08-12 05:24:29 +0200
commitdd72daef5fd9b6660e8b9093607b4aea09ec643f (patch)
tree71099312f86ed0ac55cd9af3a80664591ad4e970 /recipes/dbus
parent3c987350ba0eeeefd08e0da677bdd0f5f62130b4 (diff)
downloadopenembedded-dd72daef5fd9b6660e8b9093607b4aea09ec643f.tar.gz
dbus: fix dbus-daemon segfault on mipsel with recent toolchain
dbus-daemon segfaults on mipsel when built with -fPIE/-pie, as outlined in http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=532821 Removes PIE compilation from the dbus-daemon Makefile as a workaround. Signed-off-by: Graham Gower <graham.gower@gmail.com> Acked-by: Khem Raj <raj.khem@gmail.com> Signed-off-by: Holger Freyther <zecke@selfish.org>
Diffstat (limited to 'recipes/dbus')
-rw-r--r--recipes/dbus/dbus-native_1.0.3.bb2
-rw-r--r--recipes/dbus/dbus-native_1.2.1.bb1
-rw-r--r--recipes/dbus/dbus.inc6
-rw-r--r--recipes/dbus/dbus_1.0.3.bb2
-rw-r--r--recipes/dbus/dbus_1.2.1.bb2
5 files changed, 10 insertions, 3 deletions
diff --git a/recipes/dbus/dbus-native_1.0.3.bb b/recipes/dbus/dbus-native_1.0.3.bb
index 8a4c6fee7d..6ec0fc870d 100644
--- a/recipes/dbus/dbus-native_1.0.3.bb
+++ b/recipes/dbus/dbus-native_1.0.3.bb
@@ -1,6 +1,6 @@
require dbus.inc
-PR = "r1"
+PR = "${INC_PR}.0"
DEFAULT_PREFERENCE = "-1"
inherit native
diff --git a/recipes/dbus/dbus-native_1.2.1.bb b/recipes/dbus/dbus-native_1.2.1.bb
index 566c7bc32f..2b1610ee49 100644
--- a/recipes/dbus/dbus-native_1.2.1.bb
+++ b/recipes/dbus/dbus-native_1.2.1.bb
@@ -1,4 +1,5 @@
require dbus.inc
+PR = "${INC_PR}.0"
RRECOMMENDS_${PN} = ""
RDEPENDS_${PN} = ""
inherit native
diff --git a/recipes/dbus/dbus.inc b/recipes/dbus/dbus.inc
index 0302cfe776..b5eeb08629 100644
--- a/recipes/dbus/dbus.inc
+++ b/recipes/dbus/dbus.inc
@@ -4,6 +4,8 @@ SECTION = "base"
LICENSE = "GPL"
DEPENDS = "expat glib-2.0 virtual/libintl libsm libice virtual/libx11"
+INC_PR = "r16"
+
SRC_URI = "\
http://dbus.freedesktop.org/releases/dbus/dbus-${PV}.tar.gz \
file://cross.patch;patch=1 \
@@ -30,6 +32,10 @@ EXTRA_OECONF = "\
--with-dbus-default-reply-timeout=200000 \
"
+do_compile_prepend_mipsel() {
+ sed -i -e 's/\-fPIE//' -e 's/\-pie\ \-Wl\,\-z\,relro//' bus/Makefile
+}
+
do_install_append() {
install -d ${D}${sysconfdir}/init.d
install -m 0755 ${WORKDIR}/dbus-1.init ${D}${sysconfdir}/init.d/dbus-1
diff --git a/recipes/dbus/dbus_1.0.3.bb b/recipes/dbus/dbus_1.0.3.bb
index 2589cfef53..7001bb90e9 100644
--- a/recipes/dbus/dbus_1.0.3.bb
+++ b/recipes/dbus/dbus_1.0.3.bb
@@ -1,4 +1,4 @@
require dbus.inc
-PR = "r16"
+PR = "${INC_PR}.0"
DEFAULT_PREFERENCE = "-1"
diff --git a/recipes/dbus/dbus_1.2.1.bb b/recipes/dbus/dbus_1.2.1.bb
index 9d6c4c1fe2..72db1daa9c 100644
--- a/recipes/dbus/dbus_1.2.1.bb
+++ b/recipes/dbus/dbus_1.2.1.bb
@@ -1,3 +1,3 @@
include dbus.inc
-PR = "r12"
+PR = "${INC_PR}.0"