aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/dbus
diff options
context:
space:
mode:
authorKoen Kooi <koen@openembedded.org>2009-05-10 13:55:31 +0200
committerKoen Kooi <koen@openembedded.org>2009-05-10 13:55:31 +0200
commit1f9093d95cb44179d171d337b63f2c5ecaf94086 (patch)
tree0b8b8349b5304e565cc28d69e23623333316f85a /recipes/dbus
parent28bac40e6c1bde11de63deda391624ed6dfff3f1 (diff)
downloadopenembedded-1f9093d95cb44179d171d337b63f2c5ecaf94086.tar.gz
telepathy: update empathy and telepathy bits
Diffstat (limited to 'recipes/dbus')
-rw-r--r--recipes/dbus/dbus-glib-0.78/no-examples.patch8
-rw-r--r--recipes/dbus/dbus-glib-0.78/no-introspect.patch14
-rw-r--r--recipes/dbus/dbus-glib_0.78.bb22
3 files changed, 44 insertions, 0 deletions
diff --git a/recipes/dbus/dbus-glib-0.78/no-examples.patch b/recipes/dbus/dbus-glib-0.78/no-examples.patch
new file mode 100644
index 0000000000..483153db74
--- /dev/null
+++ b/recipes/dbus/dbus-glib-0.78/no-examples.patch
@@ -0,0 +1,8 @@
+--- dbus-glib-0.70/dbus/Makefile.am.orig 2006-07-23 16:04:43.000000000 +0200
++++ dbus-glib-0.70/dbus/Makefile.am 2006-07-23 16:04:52.000000000 +0200
+@@ -1,4 +1,4 @@
+-SUBDIRS = . examples
++SUBDIRS = .
+
+ INCLUDES=-I$(top_srcdir) $(DBUS_CFLAGS) $(DBUS_GLIB_CFLAGS) $(DBUS_GLIB_TOOL_CFLAGS) -DDBUS_COMPILATION=1 -DDBUS_LOCALEDIR=\"$(prefix)/@DATADIRNAME@/locale\"
+
diff --git a/recipes/dbus/dbus-glib-0.78/no-introspect.patch b/recipes/dbus/dbus-glib-0.78/no-introspect.patch
new file mode 100644
index 0000000000..9115801f71
--- /dev/null
+++ b/recipes/dbus/dbus-glib-0.78/no-introspect.patch
@@ -0,0 +1,14 @@
+Index: dbus-glib-0.73/tools/Makefile.am
+===================================================================
+--- dbus-glib-0.73.orig/tools/Makefile.am 2006-10-25 21:10:36.000000000 +0200
++++ dbus-glib-0.73/tools/Makefile.am 2006-10-27 10:07:35.000000000 +0200
+@@ -3,9 +3,6 @@
+ nodist_libdbus_glib_HEADERS = dbus-glib-bindings.h
+ libdbus_glibdir = $(includedir)/dbus-1.0/dbus
+
+-dbus-glib-bindings.h: dbus-bus-introspect.xml $(top_builddir)/dbus/dbus-binding-tool$(EXEEXT)
+- $(top_builddir)/dbus/dbus-binding-tool --mode=glib-client --prefix=dbus_bus --output=dbus-glib-bindings.h dbus-bus-introspect.xml
+-
+ BUILT_SOURCES = dbus-glib-bindings.h dbus-bus-introspect.xml
+
+ if USE_INTROSPECT_XML
diff --git a/recipes/dbus/dbus-glib_0.78.bb b/recipes/dbus/dbus-glib_0.78.bb
new file mode 100644
index 0000000000..398314bdff
--- /dev/null
+++ b/recipes/dbus/dbus-glib_0.78.bb
@@ -0,0 +1,22 @@
+SECTION = "base"
+HOMEPAGE = "http://www.freedesktop.org/Software/dbus"
+DESCRIPTION = "message bus system for applications to talk to one another"
+LICENSE = "GPL"
+DEPENDS = "expat glib-2.0 virtual/libintl dbus-glib-native dbus"
+
+SRC_URI = "http://dbus.freedesktop.org/releases/dbus-glib/dbus-glib-${PV}.tar.gz \
+ file://no-examples.patch;patch=1 \
+ file://no-introspect.patch;patch=1"
+
+inherit autotools_stage gettext
+AUTOTOOLS_STAGE_PKGCONFIG = "1"
+
+FILES_${PN} = "${libdir}/lib*.so.* ${libexecdir}/dbus* ${sysconfdir}/profile.d"
+FILES_${PN}-dev += "${libdir}/dbus-1.0/include ${bindir}/dbus-glib-tool"
+
+do_configure_prepend() {
+ install -m 0644 ${STAGING_DATADIR_NATIVE}/dbus/dbus-bus-introspect.xml ${S}/tools/
+ install -m 0644 ${STAGING_DATADIR_NATIVE}/dbus/dbus-glib-bindings.h ${S}/tools/
+}
+
+FILES_${PN}-dev += "${bindir}/dbus-binding-tool"