aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/dbus
diff options
context:
space:
mode:
authorMichael 'Mickey' Lauer <mickey@vanille-media.de>2010-04-29 14:59:04 +0200
committerMichael 'Mickey' Lauer <mickey@vanille-media.de>2010-04-29 16:19:00 +0200
commit4275a8734f31f3bc433cbe299ef2a027bc44a8d8 (patch)
treec5ce7f26ab073112079b2fb089921f4401d7bede /recipes/dbus
parent58fa34bf8aa9719f4dddfaf7d4f03614c1c6bc65 (diff)
downloadopenembedded-4275a8734f31f3bc433cbe299ef2a027bc44a8d8.tar.gz
dbus-daemon-proxy: new recipe; dbus-forwarder
Diffstat (limited to 'recipes/dbus')
-rw-r--r--recipes/dbus/dbus-daemon-proxy_git.bb18
1 files changed, 18 insertions, 0 deletions
diff --git a/recipes/dbus/dbus-daemon-proxy_git.bb b/recipes/dbus/dbus-daemon-proxy_git.bb
new file mode 100644
index 0000000000..99f4372b72
--- /dev/null
+++ b/recipes/dbus/dbus-daemon-proxy_git.bb
@@ -0,0 +1,18 @@
+DESCRIPTION = "dbus forwarding daemon"
+LICENSE = "GPL"
+DEPENDS = "dbus dbus-glib"
+SRCREV = "1226a0a1374628ff191f6d8a56000be5e53e7608"
+PV = "0.0.0+gitr${SRCPV}"
+
+SRC_URI = "git://git.collabora.co.uk/git/user/alban/dbus-daemon-proxy;protocol=git"
+S = "${WORKDIR}/git"
+
+do_compile() {
+ ${CC} `pkg-config --cflags --libs dbus-glib-1` -o dbus-daemon-proxy dbus-daemon-proxy.c
+}
+
+do_install() {
+ install -d ${D}${bindir}
+ install -m 0755 dbus-daemon-proxy ${D}${bindir}
+}
+