aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/dcron/dcron-2.3.3
diff options
context:
space:
mode:
authorDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
committerDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
commit709c4d66e0b107ca606941b988bad717c0b45d9b (patch)
tree37ee08b1eb308f3b2b6426d5793545c38396b838 /recipes/dcron/dcron-2.3.3
parentfa6cd5a3b993f16c27de4ff82b42684516d433ba (diff)
downloadopenembedded-709c4d66e0b107ca606941b988bad717c0b45d9b.tar.gz
rename packages/ to recipes/ per earlier agreement
See links below for more details: http://thread.gmane.org/gmane.comp.handhelds.openembedded/21326 http://thread.gmane.org/gmane.comp.handhelds.openembedded/21816 Signed-off-by: Denys Dmytriyenko <denis@denix.org> Acked-by: Mike Westerhof <mwester@dls.net> Acked-by: Philip Balister <philip@balister.org> Acked-by: Khem Raj <raj.khem@gmail.com> Acked-by: Marcin Juszkiewicz <hrw@openembedded.org> Acked-by: Koen Kooi <koen@openembedded.org> Acked-by: Frans Meulenbroeks <fransmeulenbroeks@gmail.com>
Diffstat (limited to 'recipes/dcron/dcron-2.3.3')
-rw-r--r--recipes/dcron/dcron-2.3.3/compile.patch29
-rw-r--r--recipes/dcron/dcron-2.3.3/strip.patch16
2 files changed, 45 insertions, 0 deletions
diff --git a/recipes/dcron/dcron-2.3.3/compile.patch b/recipes/dcron/dcron-2.3.3/compile.patch
new file mode 100644
index 0000000000..2787facb22
--- /dev/null
+++ b/recipes/dcron/dcron-2.3.3/compile.patch
@@ -0,0 +1,29 @@
+
+#
+# Patch managed by http://www.mn-logistik.de/unsupported/pxa250/patcher
+#
+
+--- dcron-2.3.3/subs.c~compile
++++ dcron-2.3.3/subs.c
+@@ -15,7 +15,6 @@
+ Prototype int ChangeUser(const char *user, short dochdir);
+ Prototype void vlog(int level, int fd, const char *ctl, va_list va);
+ Prototype int slog(char *buf, size_t sz, const char *ctl, va_list va, short useDate);
+-Prototype char *strdup(const char *);
+
+ void
+ log9(const char *ctl, ...)
+@@ -131,6 +130,7 @@
+ return(pas->pw_uid);
+ }
+
++#if 0
+ char *
+ strdup(const char *str)
+ {
+@@ -140,4 +140,4 @@
+ strcpy(ptr, str);
+ return(ptr);
+ }
+-
++#endif
diff --git a/recipes/dcron/dcron-2.3.3/strip.patch b/recipes/dcron/dcron-2.3.3/strip.patch
new file mode 100644
index 0000000000..51aef07f2d
--- /dev/null
+++ b/recipes/dcron/dcron-2.3.3/strip.patch
@@ -0,0 +1,16 @@
+Index: dcron-2.3.3/Makefile
+===================================================================
+--- dcron-2.3.3.orig/Makefile 2006-06-19 15:47:35.774568368 +0200
++++ dcron-2.3.3/Makefile 2006-06-19 15:47:43.713361488 +0200
+@@ -14,11 +14,9 @@
+
+ crond: ${OBJS}
+ ${CC} ${CFLAGS} -o crond ${OBJS} ${LIB}
+- strip crond
+
+ crontab: ${D_OBJS}
+ ${CC} ${CFLAGS} -o crontab ${D_OBJS}
+- strip crontab
+
+ protos.h: ${SRCS} ${D_SRCS}
+ fgrep -h Prototype ${SRCS} ${D_SRCS} >protos.h