aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/ddclient/ddclient_3.6.3.bb
diff options
context:
space:
mode:
authorDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
committerDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
commit709c4d66e0b107ca606941b988bad717c0b45d9b (patch)
tree37ee08b1eb308f3b2b6426d5793545c38396b838 /recipes/ddclient/ddclient_3.6.3.bb
parentfa6cd5a3b993f16c27de4ff82b42684516d433ba (diff)
downloadopenembedded-709c4d66e0b107ca606941b988bad717c0b45d9b.tar.gz
rename packages/ to recipes/ per earlier agreement
See links below for more details: http://thread.gmane.org/gmane.comp.handhelds.openembedded/21326 http://thread.gmane.org/gmane.comp.handhelds.openembedded/21816 Signed-off-by: Denys Dmytriyenko <denis@denix.org> Acked-by: Mike Westerhof <mwester@dls.net> Acked-by: Philip Balister <philip@balister.org> Acked-by: Khem Raj <raj.khem@gmail.com> Acked-by: Marcin Juszkiewicz <hrw@openembedded.org> Acked-by: Koen Kooi <koen@openembedded.org> Acked-by: Frans Meulenbroeks <fransmeulenbroeks@gmail.com>
Diffstat (limited to 'recipes/ddclient/ddclient_3.6.3.bb')
-rw-r--r--recipes/ddclient/ddclient_3.6.3.bb23
1 files changed, 23 insertions, 0 deletions
diff --git a/recipes/ddclient/ddclient_3.6.3.bb b/recipes/ddclient/ddclient_3.6.3.bb
new file mode 100644
index 0000000000..5a15548bc9
--- /dev/null
+++ b/recipes/ddclient/ddclient_3.6.3.bb
@@ -0,0 +1,23 @@
+SECTION = "console/network"
+DESCRIPTION = "Ddclient is a Perl client used to update dynamic DNS entries for accounts on Dynamic DNS Network Services"
+HOMEPAGE = "http://ddclient.sourceforge.net/"
+LICENSE = "GPL"
+
+SRC_URI = "${SOURCEFORGE_MIRROR}/ddclient/ddclient-${PV}.tar.bz2 \
+ file://ip-up"
+
+RDEPENDS = "perl perl-module-strict perl-module-getopt-long perl-module-vars perl-module-warnings-register perl-module-warnings perl-module-carp perl-module-exporter perl-module-constant perl-module-exporter-heavy perl-module-sys-hostname perl-module-xsloader perl-module-autoloader perl-module-io-socket perl-module-io-handle perl-module-symbol perl-module-selectsaver perl-module-io perl-module-socket perl-module-errno perl-module-config perl-module-io-socket-inet perl-module-io-socket-unix perl-module-integer"
+
+do_install() {
+ install -d ${D}${sbindir} ${D}${sysconfdir} ${D}${sysconfdir}/init.d
+ install -d ${D}${sysconfdir}/ppp/ip-up.d/ install -d ${D}${docdir}/ddclient
+ install -m 755 ${S}/ddclient ${D}${sbindir}
+ install ${S}/sample-etc_ddclient.conf ${D}${sysconfdir}/ddclient.conf
+ install -m 755 ${WORKDIR}/ip-up ${D}${sysconfdir}/ppp/ip-up.d/ddclient
+ install -m 755 ${S}/sample-etc_rc.d_init.d_ddclient ${D}${sysconfdir}/init.d/ddclient
+ install ${S}/README* ${D}${docdir}/ddclient
+ install ${S}/COPY* ${D}${docdir}/ddclient
+ install ${S}/sample* ${D}${docdir}/ddclient
+}
+
+CONFFILES_${PN}_nylon = "${sysconfdir}/ddclient.conf"