aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/debianutils
diff options
context:
space:
mode:
authorTom Rini <tom_rini@mentor.com>2010-08-20 15:13:43 -0700
committerTom Rini <tom_rini@mentor.com>2010-08-20 15:24:10 -0700
commit280a17bc1d8132f97cf6a89b8bc08a32380fa357 (patch)
treeec4f9235fec551ad7b9e2c092e6769007ad85456 /recipes/debianutils
parentdd9969cbacabd8dba6c8c197a67d8409fb78988e (diff)
downloadopenembedded-280a17bc1d8132f97cf6a89b8bc08a32380fa357.tar.gz
debianutils: Move run-parts and tempfile to ${base_bindir}, use INC_PR
We move run-parts to match busybox and usage and tempfile to match normal usage (and upstream). Run oe-stylize.py while in here. Signed-off-by: Tom Rini <tom_rini@mentor.com>
Diffstat (limited to 'recipes/debianutils')
-rw-r--r--recipes/debianutils/debianutils.inc32
-rw-r--r--recipes/debianutils/debianutils_2.17.3.bb2
-rw-r--r--recipes/debianutils/debianutils_2.19.bb3
-rw-r--r--recipes/debianutils/debianutils_2.30.bb3
4 files changed, 23 insertions, 17 deletions
diff --git a/recipes/debianutils/debianutils.inc b/recipes/debianutils/debianutils.inc
index 35ef03d14f..9d326060c2 100644
--- a/recipes/debianutils/debianutils.inc
+++ b/recipes/debianutils/debianutils.inc
@@ -1,35 +1,37 @@
+DESCRIPTION = "Miscellaneous utilities specific to Debian"
SECTION = "base"
LICENSE = "GPL BSD BSD SMAIL"
-DESCRIPTION = "Miscellaneous utilities specific to Debian"
+INC_PR = "r2"
SRC_URI = "${DEBIAN_MIRROR}/main/d/${PN}/${PN}_${PV}.tar.gz"
-inherit autotools
+inherit autotools
do_install_append() {
- for app in ${D}/${sbindir}/* ${D}/${bindir}/*; do
+ for app in ${D}${sbindir}/* ${D}${bindir}/*; do
mv $app $app.${PN}
done
+ # Debian places some utils into ${base_bindir} as does busybox
+ install -d ${D}${base_bindir}
+ for app in run-parts.${PN} tempfile.${PN}; do
+ mv ${D}${bindir}/$app ${D}${base_bindir}/$app
+ done
}
+pkg_prerm_${PN} () {
+for app in add-shell installkernel mkboot remove-shell run-parts savelog sensible-browser sensible-editor sensible-pager tempfile which ; do
+ update-alternatives --remove $app $app.${PN}
+done
+}
pkg_postinst_${PN} () {
#!/bin/sh
for app in add-shell installkernel mkboot remove-shell ; do
update-alternatives --install ${sbindir}/$app $app $app.${PN} 100
done
-
-for app in run-parts savelog sensible-browser sensible-editor sensible-pager tempfile which ; do
+for app in savelog sensible-browser sensible-editor sensible-pager which ; do
update-alternatives --install ${bindir}/$app $app $app.${PN} 100
done
-}
-
-pkg_prerm_${PN} () {
- #!/bin/sh
-
-for app in add-shell installkernel mkboot remove-shell run-parts savelog sensible-browser sensible-editor sensible-pager tempfile which ; do
- update-alternatives --remove $app $app.${PN}
+for app in run-parts tempfile ; do
+ update-alternatives --install ${base_bindir}/$app $app $app.${PN} 100
done
}
-
-
-
diff --git a/recipes/debianutils/debianutils_2.17.3.bb b/recipes/debianutils/debianutils_2.17.3.bb
index 8ea7e497df..012c3757bf 100644
--- a/recipes/debianutils/debianutils_2.17.3.bb
+++ b/recipes/debianutils/debianutils_2.17.3.bb
@@ -1,4 +1,6 @@
require debianutils.inc
+PR = "${INC_PR}"
+
SRC_URI[md5sum] = "cc768faa584f6c31cc1e0a959a3b8c0c"
SRC_URI[sha256sum] = "46c0991b71d1991aa2f90d6816d9efb737fc9f9b99713174fcdf8d323727a11c"
diff --git a/recipes/debianutils/debianutils_2.19.bb b/recipes/debianutils/debianutils_2.19.bb
index 7569797f93..d81c4a76ac 100644
--- a/recipes/debianutils/debianutils_2.19.bb
+++ b/recipes/debianutils/debianutils_2.19.bb
@@ -2,4 +2,5 @@
# Released under the MIT license (see packages/COPYING)
require debianutils.inc
-PR ="r0"
+
+PR = "${INC_PR}"
diff --git a/recipes/debianutils/debianutils_2.30.bb b/recipes/debianutils/debianutils_2.30.bb
index 65bf10e1d7..8a3a751d44 100644
--- a/recipes/debianutils/debianutils_2.30.bb
+++ b/recipes/debianutils/debianutils_2.30.bb
@@ -2,7 +2,8 @@
# Released under the MIT license (see packages/COPYING)
require debianutils.inc
-PR="r1"
+
+PR = "${INC_PR}"
do_configure_prepend() {
sed -i -e 's:tempfile.1 which.1:which.1:g' Makefile.am