aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/debianutils
diff options
context:
space:
mode:
authorDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
committerDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
commit709c4d66e0b107ca606941b988bad717c0b45d9b (patch)
tree37ee08b1eb308f3b2b6426d5793545c38396b838 /recipes/debianutils
parentfa6cd5a3b993f16c27de4ff82b42684516d433ba (diff)
downloadopenembedded-709c4d66e0b107ca606941b988bad717c0b45d9b.tar.gz
rename packages/ to recipes/ per earlier agreement
See links below for more details: http://thread.gmane.org/gmane.comp.handhelds.openembedded/21326 http://thread.gmane.org/gmane.comp.handhelds.openembedded/21816 Signed-off-by: Denys Dmytriyenko <denis@denix.org> Acked-by: Mike Westerhof <mwester@dls.net> Acked-by: Philip Balister <philip@balister.org> Acked-by: Khem Raj <raj.khem@gmail.com> Acked-by: Marcin Juszkiewicz <hrw@openembedded.org> Acked-by: Koen Kooi <koen@openembedded.org> Acked-by: Frans Meulenbroeks <fransmeulenbroeks@gmail.com>
Diffstat (limited to 'recipes/debianutils')
-rw-r--r--recipes/debianutils/debianutils.inc35
-rw-r--r--recipes/debianutils/debianutils_2.17.3.bb1
-rw-r--r--recipes/debianutils/debianutils_2.19.bb5
-rw-r--r--recipes/debianutils/debianutils_2.30.bb5
4 files changed, 46 insertions, 0 deletions
diff --git a/recipes/debianutils/debianutils.inc b/recipes/debianutils/debianutils.inc
new file mode 100644
index 0000000000..35ef03d14f
--- /dev/null
+++ b/recipes/debianutils/debianutils.inc
@@ -0,0 +1,35 @@
+SECTION = "base"
+LICENSE = "GPL BSD BSD SMAIL"
+DESCRIPTION = "Miscellaneous utilities specific to Debian"
+
+SRC_URI = "${DEBIAN_MIRROR}/main/d/${PN}/${PN}_${PV}.tar.gz"
+
+inherit autotools
+
+do_install_append() {
+ for app in ${D}/${sbindir}/* ${D}/${bindir}/*; do
+ mv $app $app.${PN}
+ done
+}
+
+pkg_postinst_${PN} () {
+#!/bin/sh
+for app in add-shell installkernel mkboot remove-shell ; do
+ update-alternatives --install ${sbindir}/$app $app $app.${PN} 100
+done
+
+for app in run-parts savelog sensible-browser sensible-editor sensible-pager tempfile which ; do
+ update-alternatives --install ${bindir}/$app $app $app.${PN} 100
+done
+}
+
+pkg_prerm_${PN} () {
+ #!/bin/sh
+
+for app in add-shell installkernel mkboot remove-shell run-parts savelog sensible-browser sensible-editor sensible-pager tempfile which ; do
+ update-alternatives --remove $app $app.${PN}
+done
+}
+
+
+
diff --git a/recipes/debianutils/debianutils_2.17.3.bb b/recipes/debianutils/debianutils_2.17.3.bb
new file mode 100644
index 0000000000..90dc5116b5
--- /dev/null
+++ b/recipes/debianutils/debianutils_2.17.3.bb
@@ -0,0 +1 @@
+require debianutils.inc
diff --git a/recipes/debianutils/debianutils_2.19.bb b/recipes/debianutils/debianutils_2.19.bb
new file mode 100644
index 0000000000..7569797f93
--- /dev/null
+++ b/recipes/debianutils/debianutils_2.19.bb
@@ -0,0 +1,5 @@
+# Copyright (C) 2007, Stelios Koroneos - Digital OPSiS, All Rights Reserved
+# Released under the MIT license (see packages/COPYING)
+
+require debianutils.inc
+PR ="r0"
diff --git a/recipes/debianutils/debianutils_2.30.bb b/recipes/debianutils/debianutils_2.30.bb
new file mode 100644
index 0000000000..a15c8079b5
--- /dev/null
+++ b/recipes/debianutils/debianutils_2.30.bb
@@ -0,0 +1,5 @@
+# Copyright (C) 2007, Stelios Koroneos - Digital OPSiS, All Rights Reserved
+# Released under the MIT license (see packages/COPYING)
+
+require debianutils.inc
+PR="r1"