aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/device-mapper
diff options
context:
space:
mode:
authorKoen Kooi <koen@openembedded.org>2009-05-21 15:02:17 +0200
committerKoen Kooi <koen@openembedded.org>2009-05-21 15:02:17 +0200
commitd543c80be652f118cbbfa94250bd2aca9bb9aea4 (patch)
tree9e8baa653c9fbb9ce76417b8295f22b3bb6da323 /recipes/device-mapper
parent18c5ea8f84b34f8c949b1fed23ad8f1e884b7507 (diff)
downloadopenembedded-d543c80be652f118cbbfa94250bd2aca9bb9aea4.tar.gz
devicemapper: fix QA problems, add 1.02.28
Diffstat (limited to 'recipes/device-mapper')
-rw-r--r--recipes/device-mapper/device-mapper-1.02.28/devmap-mknod-busybox.patch9
-rw-r--r--recipes/device-mapper/device-mapper-1.02.28/remove_insanity.patch42
-rw-r--r--recipes/device-mapper/device-mapper_1.01.05.bb4
-rw-r--r--recipes/device-mapper/device-mapper_1.02.28.bb37
4 files changed, 91 insertions, 1 deletions
diff --git a/recipes/device-mapper/device-mapper-1.02.28/devmap-mknod-busybox.patch b/recipes/device-mapper/device-mapper-1.02.28/devmap-mknod-busybox.patch
new file mode 100644
index 0000000000..8b24f143dd
--- /dev/null
+++ b/recipes/device-mapper/device-mapper-1.02.28/devmap-mknod-busybox.patch
@@ -0,0 +1,9 @@
+--- device-mapper.1.01.05/scripts/devmap_mknod.sh 2002-07-23 05:50:13.000000000 -0700
++++ device-mapper.1.01.05/scripts/devmap_mknod.sh~ 2005-08-25 14:51:13.000000000 -0700
+@@ -37,5 +37,5 @@
+ test -e $CONTROL && rm -f $CONTROL
+
+ echo "Creating $CONTROL character device with major:$MAJOR minor:$MINOR."
+-mknod --mode=600 $CONTROL c $MAJOR $MINOR
++mknod -m 600 $CONTROL c $MAJOR $MINOR
+
diff --git a/recipes/device-mapper/device-mapper-1.02.28/remove_insanity.patch b/recipes/device-mapper/device-mapper-1.02.28/remove_insanity.patch
new file mode 100644
index 0000000000..f78c341c14
--- /dev/null
+++ b/recipes/device-mapper/device-mapper-1.02.28/remove_insanity.patch
@@ -0,0 +1,42 @@
+--- /tmp/Makefile.in 2009-05-21 13:45:20.000000000 +0200
++++ device-mapper.1.02.28/dmsetup/Makefile.in 2009-05-21 14:09:43.000000000 +0200
+@@ -31,12 +31,10 @@
+ include ../make.tmpl
+
+ dmsetup: $(OBJECTS) $(interfacedir)/libdevmapper.$(LIB_SUFFIX)
+- $(CC) -o $@ $(OBJECTS) $(CFLAGS) $(LDFLAGS) \
+- -L$(interfacedir) -L$(DESTDIR)/lib -ldevmapper $(LIBS)
++ $(CC) -o $@ $(OBJECTS) -L$(interfacedir) -ldevmapper $(LIBS) $(CFLAGS) $(LDFLAGS)
+
+ dmsetup.static: $(OBJECTS) $(interfacedir)/libdevmapper.a
+- $(CC) -o $@ $(OBJECTS) $(CFLAGS) $(LDFLAGS) -static \
+- -L$(interfacedir) -L$(DESTDIR)/lib -ldevmapper $(LIBS) \
++ $(CC) -o $@ $(OBJECTS) -L$(interfacedir) -ldevmapper $(LIBS) $(CFLAGS) $(LDFLAGS) -static \
+ $(LIB_PTHREAD)
+
+ install: $(INSTALL_TYPE)
+--- /tmp/make.tmpl.in 2009-05-21 14:24:02.000000000 +0200
++++ device-mapper.1.02.28/make.tmpl.in 2009-05-21 14:29:20.000000000 +0200
+@@ -151,19 +151,19 @@
+ $(TARGETS): $(OBJECTS)
+
+ %.o: %.c
+- $(CC) -c $(INCLUDES) $(DEFS) $(CFLAGS) $< -o $@
++ $(CC) -c $(INCLUDES) $(DEFS) $(CFLAGS) ${LDFLAGS} $< -o $@
+
+ %.pot: %.c Makefile
+ $(CC) -E $(INCLUDES) -include $(top_srcdir)/include/pogen.h \
+ $(DEFS) $(CFLAGS) $< > $@
+
+ %.so: %.o
+- $(CC) -c $(INCLUDES) $(DEFS) $(CFLAGS) $< -o $@
++ $(CC) -c $(INCLUDES) $(DEFS) $(CFLAGS) ${LDFLAGS} $< -o $@
+
+ ifeq ("@LIB_SUFFIX@","so")
+ $(LIB_SHARED): $(OBJECTS) $(LDDEPS)
+ $(CC) -shared -Wl,-soname,$(notdir $@).$(LIB_VERSION) \
+- $(CFLAGS) $(CLDFLAGS) $(OBJECTS) $(LIBS) -o $@
++ $(CFLAGS) $(CLDFLAGS) ${LDFLAGS} $(OBJECTS) $(LIBS) -o $@
+ endif
+
+ ifeq ("@LIB_SUFFIX@","dylib")
diff --git a/recipes/device-mapper/device-mapper_1.01.05.bb b/recipes/device-mapper/device-mapper_1.01.05.bb
index bc02e6a71f..2af9990839 100644
--- a/recipes/device-mapper/device-mapper_1.01.05.bb
+++ b/recipes/device-mapper/device-mapper_1.01.05.bb
@@ -3,7 +3,7 @@ DESCRIPTION = "The Device-mapper is a new component of the linux kernel \
that supports logical volume management. It is required by LVM2 and EVMS. \
The original LVM (included in stock 2.4 kernels) does not use it."
LICENSE = "GPL"
-PR = "r3"
+PR = "r4"
S = "${WORKDIR}/${PN}.${PV}"
@@ -15,6 +15,8 @@ inherit autotools update-rc.d
# The install-script will fail without this.
EXTRA_OECONF="--with-user= --with-group= "
+TARGET_CC_ARCH += "${LDFLAGS}"
+
INITSCRIPT_NAME = "devmap_mknod.sh"
INITSCRIPT_PARAMS = "defaults"
diff --git a/recipes/device-mapper/device-mapper_1.02.28.bb b/recipes/device-mapper/device-mapper_1.02.28.bb
new file mode 100644
index 0000000000..bd97d15848
--- /dev/null
+++ b/recipes/device-mapper/device-mapper_1.02.28.bb
@@ -0,0 +1,37 @@
+SECTION = "libs"
+DESCRIPTION = "The Device-mapper is a new component of the linux kernel \
+that supports logical volume management. It is required by LVM2 and EVMS. \
+The original LVM (included in stock 2.4 kernels) does not use it."
+LICENSE = "GPL"
+
+S = "${WORKDIR}/${PN}.${PV}"
+
+SRC_URI = "ftp://sources.redhat.com/pub/dm/device-mapper.${PV}.tgz \
+ file://devmap-mknod-busybox.patch;patch=1 \
+ file://remove_insanity.patch;patch=1 "
+
+inherit autotools_stage update-rc.d
+AUTOTOOLS_STAGE_PKGCONFIG = "1"
+
+# The install-script will fail without this.
+EXTRA_OECONF="--with-user= --with-group= "
+
+INITSCRIPT_NAME = "devmap_mknod.sh"
+INITSCRIPT_PARAMS = "defaults"
+
+do_install_append() {
+ install -d ${D}/${libdir}/ioctl
+ install -m 755 ${S}/lib/ioctl/libdevmapper.a ${D}/${libdir}/ioctl/
+ install -D -m 755 ${S}/scripts/${INITSCRIPT_NAME} ${D}${sysconfdir}/init.d/${INITSCRIPT_NAME}
+}
+
+FILES_${PN}-dev += "${libdir}/ioctl/*.a"
+
+do_stage_append() {
+ install -d ${STAGING_LIBDIR}/pkgconfig/
+ for pc in ${S}/*/*.pc ; do
+ cp $pc ${STAGING_LIBDIR}/pkgconfig/
+ cp $pc ${STAGING_LIBDIR}/pkgconfig/$(echo $(basename $pc) | sed s:lib::g)
+ done
+}
+