aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/device-mapper
diff options
context:
space:
mode:
authorDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
committerDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
commit709c4d66e0b107ca606941b988bad717c0b45d9b (patch)
tree37ee08b1eb308f3b2b6426d5793545c38396b838 /recipes/device-mapper
parentfa6cd5a3b993f16c27de4ff82b42684516d433ba (diff)
downloadopenembedded-709c4d66e0b107ca606941b988bad717c0b45d9b.tar.gz
rename packages/ to recipes/ per earlier agreement
See links below for more details: http://thread.gmane.org/gmane.comp.handhelds.openembedded/21326 http://thread.gmane.org/gmane.comp.handhelds.openembedded/21816 Signed-off-by: Denys Dmytriyenko <denis@denix.org> Acked-by: Mike Westerhof <mwester@dls.net> Acked-by: Philip Balister <philip@balister.org> Acked-by: Khem Raj <raj.khem@gmail.com> Acked-by: Marcin Juszkiewicz <hrw@openembedded.org> Acked-by: Koen Kooi <koen@openembedded.org> Acked-by: Frans Meulenbroeks <fransmeulenbroeks@gmail.com>
Diffstat (limited to 'recipes/device-mapper')
-rw-r--r--recipes/device-mapper/device-mapper-1.01.04/devmap-mknod-busybox.patch9
-rw-r--r--recipes/device-mapper/device-mapper-1.01.05/devmap-mknod-busybox.patch9
-rw-r--r--recipes/device-mapper/device-mapper-1.01.05/remove_insanity.patch33
-rw-r--r--recipes/device-mapper/device-mapper_1.01.04.bb27
-rw-r--r--recipes/device-mapper/device-mapper_1.01.05.bb33
5 files changed, 111 insertions, 0 deletions
diff --git a/recipes/device-mapper/device-mapper-1.01.04/devmap-mknod-busybox.patch b/recipes/device-mapper/device-mapper-1.01.04/devmap-mknod-busybox.patch
new file mode 100644
index 0000000000..70a2658930
--- /dev/null
+++ b/recipes/device-mapper/device-mapper-1.01.04/devmap-mknod-busybox.patch
@@ -0,0 +1,9 @@
+--- device-mapper.1.01.04/scripts/devmap_mknod.sh 2002-07-23 05:50:13.000000000 -0700
++++ device-mapper.1.01.04/scripts/devmap_mknod.sh~ 2005-08-25 14:51:13.000000000 -0700
+@@ -37,5 +37,5 @@
+ test -e $CONTROL && rm -f $CONTROL
+
+ echo "Creating $CONTROL character device with major:$MAJOR minor:$MINOR."
+-mknod --mode=600 $CONTROL c $MAJOR $MINOR
++mknod -m 600 $CONTROL c $MAJOR $MINOR
+
diff --git a/recipes/device-mapper/device-mapper-1.01.05/devmap-mknod-busybox.patch b/recipes/device-mapper/device-mapper-1.01.05/devmap-mknod-busybox.patch
new file mode 100644
index 0000000000..8b24f143dd
--- /dev/null
+++ b/recipes/device-mapper/device-mapper-1.01.05/devmap-mknod-busybox.patch
@@ -0,0 +1,9 @@
+--- device-mapper.1.01.05/scripts/devmap_mknod.sh 2002-07-23 05:50:13.000000000 -0700
++++ device-mapper.1.01.05/scripts/devmap_mknod.sh~ 2005-08-25 14:51:13.000000000 -0700
+@@ -37,5 +37,5 @@
+ test -e $CONTROL && rm -f $CONTROL
+
+ echo "Creating $CONTROL character device with major:$MAJOR minor:$MINOR."
+-mknod --mode=600 $CONTROL c $MAJOR $MINOR
++mknod -m 600 $CONTROL c $MAJOR $MINOR
+
diff --git a/recipes/device-mapper/device-mapper-1.01.05/remove_insanity.patch b/recipes/device-mapper/device-mapper-1.01.05/remove_insanity.patch
new file mode 100644
index 0000000000..1bc846e625
--- /dev/null
+++ b/recipes/device-mapper/device-mapper-1.01.05/remove_insanity.patch
@@ -0,0 +1,33 @@
+Index: device-mapper.1.01.05/dmsetup/Makefile.in
+===================================================================
+--- device-mapper.1.01.05.orig/dmsetup/Makefile.in 2008-03-26 09:17:23.000000000 +0000
++++ device-mapper.1.01.05/dmsetup/Makefile.in 2008-03-26 09:18:01.000000000 +0000
+@@ -31,11 +31,11 @@
+
+ dmsetup: $(OBJECTS) $(interfacedir)/libdevmapper.$(LIB_SUFFIX)
+ $(CC) -o $@ $(OBJECTS) $(LDFLAGS) \
+- -L$(interfacedir) -L$(DESTDIR)/lib -ldevmapper $(LIBS)
++ -L$(interfacedir) -ldevmapper $(LIBS)
+
+ dmsetup.static: $(OBJECTS) $(interfacedir)/libdevmapper.a
+ $(CC) -o $@ $(OBJECTS) $(LDFLAGS) -static \
+- -L$(interfacedir) -L$(DESTDIR)/lib -ldevmapper $(LIBS)
++ -L$(interfacedir) -ldevmapper $(LIBS)
+
+ install: $(INSTALL_TYPE)
+
+Index: device-mapper.1.01.05/make.tmpl.in
+===================================================================
+--- device-mapper.1.01.05.orig/make.tmpl.in 2008-03-26 09:18:44.000000000 +0000
++++ device-mapper.1.01.05/make.tmpl.in 2008-03-26 09:19:10.000000000 +0000
+@@ -91,10 +91,6 @@
+
+ INCLUDES += -I. -I$(top_srcdir)/include
+
+-ifdef DESTDIR
+- INCLUDES += -I$(DESTDIR)/usr/include
+-endif
+-
+ ifneq ("@missingkernel@", "yes")
+ INCLUDES += -I$(kerneldir)/include
+ endif
diff --git a/recipes/device-mapper/device-mapper_1.01.04.bb b/recipes/device-mapper/device-mapper_1.01.04.bb
new file mode 100644
index 0000000000..2e1da9feaa
--- /dev/null
+++ b/recipes/device-mapper/device-mapper_1.01.04.bb
@@ -0,0 +1,27 @@
+SECTION = "libs"
+DESCRIPTION = "The Device-mapper is a new component of the linux kernel \
+that supports logical volume management. It is required by LVM2 and EVMS. \
+The original LVM (included in stock 2.4 kernels) does not use it."
+LICENSE = "GPL"
+PR = "r2"
+
+S = "${WORKDIR}/${PN}.${PV}"
+
+SRC_URI = "ftp://sources.redhat.com/pub/dm/device-mapper.${PV}.tgz \
+ file://devmap-mknod-busybox.patch;patch=1"
+
+inherit autotools update-rc.d
+
+INITSCRIPT_NAME = "devmap_mknod.sh"
+INITSCRIPT_PARAMS = "defaults"
+
+do_stage () {
+ install -m 0644 lib/libdevmapper.h ${STAGING_INCDIR} || die "failed to install libdevmapper.h"
+ oe_libinstall -a -so -C lib/ioctl libdevmapper ${STAGING_LIBDIR}
+}
+
+do_install() {
+ autotools_do_install
+ oe_runmake install_static_lib
+ install -D -m 755 ${S}/scripts/${INITSCRIPT_NAME} ${D}${sysconfdir}/init.d/${INITSCRIPT_NAME}
+}
diff --git a/recipes/device-mapper/device-mapper_1.01.05.bb b/recipes/device-mapper/device-mapper_1.01.05.bb
new file mode 100644
index 0000000000..bc02e6a71f
--- /dev/null
+++ b/recipes/device-mapper/device-mapper_1.01.05.bb
@@ -0,0 +1,33 @@
+SECTION = "libs"
+DESCRIPTION = "The Device-mapper is a new component of the linux kernel \
+that supports logical volume management. It is required by LVM2 and EVMS. \
+The original LVM (included in stock 2.4 kernels) does not use it."
+LICENSE = "GPL"
+PR = "r3"
+
+S = "${WORKDIR}/${PN}.${PV}"
+
+SRC_URI = "ftp://sources.redhat.com/pub/dm/device-mapper.${PV}.tgz \
+ file://devmap-mknod-busybox.patch;patch=1 \
+ file://remove_insanity.patch;patch=1 "
+
+inherit autotools update-rc.d
+
+# The install-script will fail without this.
+EXTRA_OECONF="--with-user= --with-group= "
+
+INITSCRIPT_NAME = "devmap_mknod.sh"
+INITSCRIPT_PARAMS = "defaults"
+
+do_stage () {
+ install -m 0644 ${S}/lib/libdevmapper.h ${STAGING_INCDIR} || die "failed to install libdevmapper.h"
+ oe_libinstall -a -so -C lib/ioctl libdevmapper ${STAGING_LIBDIR}
+}
+
+do_install() {
+ autotools_do_install
+# oe_runmake install_static_lib
+ install -d ${D}/${libdir}/ioctl
+ install -m 755 ${S}/lib/ioctl/libdevmapper.a ${D}/${libdir}/ioctl/
+ install -D -m 755 ${S}/scripts/${INITSCRIPT_NAME} ${D}${sysconfdir}/init.d/${INITSCRIPT_NAME}
+}