summaryrefslogtreecommitdiffstats
path: root/recipes/devicekit/devicekit-power_009.bb
diff options
context:
space:
mode:
authorDavid-John Willis <John.Willis@Distant-earth.com>2009-10-27 21:34:32 +0000
committerKoen Kooi <koen@openembedded.org>2009-10-28 10:16:29 +0100
commit9c5d1cb40bcb1d9412112bf73d7c7f4732989e89 (patch)
tree8e978f9236981953e5ab1446d1050e9c9c33b07d /recipes/devicekit/devicekit-power_009.bb
parent6d81ef0477dea8936fb97f70c90509dca99f9365 (diff)
downloadopenembedded-9c5d1cb40bcb1d9412112bf73d7c7f4732989e89.tar.gz
devicekit: Update to remove host dependency on Docbook XSLT files.
* Bump PR * Update recipe to sed out the -nonet in the documentation XSLT conversion removing the reliance of the Docbook XSLT templates being installed on the host system (it will grab them from the net however). * Note: Another (maybe better) fix would be to package up docbook-xsl but that is overkill for these two recipes.
Diffstat (limited to 'recipes/devicekit/devicekit-power_009.bb')
-rw-r--r--recipes/devicekit/devicekit-power_009.bb4
1 files changed, 4 insertions, 0 deletions
diff --git a/recipes/devicekit/devicekit-power_009.bb b/recipes/devicekit/devicekit-power_009.bb
index 58f638cbf2..0622d4aa7c 100644
--- a/recipes/devicekit/devicekit-power_009.bb
+++ b/recipes/devicekit/devicekit-power_009.bb
@@ -7,6 +7,10 @@ S = "${WORKDIR}/DeviceKit-power-${PV}"
inherit autotools pkgconfig
+do_configure_prepend() {
+ sed -i -e s:-nonet:\:g ${S}/doc/man/Makefile.am
+}
+
do_stage() {
autotools_stage_all
}