aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/devmem2
diff options
context:
space:
mode:
authorChris Larson <chris_larson@mentor.com>2011-01-12 09:14:53 -0700
committerChris Larson <chris_larson@mentor.com>2011-01-12 09:14:53 -0700
commit435e8eebb38e4ef051671560e92167b619264a81 (patch)
tree0b505f340d673dce74cb48fe8f3a200e9c71259d /recipes/devmem2
parent3d96044bd188ca012f715b26fa9c3929b851e84a (diff)
downloadopenembedded-435e8eebb38e4ef051671560e92167b619264a81.tar.gz
devmem2: remove comment of word write from fsl patch
Signed-off-by: Chris Larson <chris_larson@mentor.com>
Diffstat (limited to 'recipes/devmem2')
-rw-r--r--recipes/devmem2/devmem2.bb2
-rw-r--r--recipes/devmem2/devmem2/devmem2-fixups-2.patch2
2 files changed, 2 insertions, 2 deletions
diff --git a/recipes/devmem2/devmem2.bb b/recipes/devmem2/devmem2.bb
index 48936870ac..4f92586a88 100644
--- a/recipes/devmem2/devmem2.bb
+++ b/recipes/devmem2/devmem2.bb
@@ -1,6 +1,6 @@
DESCRIPTION = "Simple program to read/write from/to any location in memory."
LICENSE = "GPLv2"
-PR = "r4"
+PR = "r5"
SRC_URI = "http://www.lartmaker.nl/lartware/port/devmem2.c \
file://devmem2-fixups-2.patch"
diff --git a/recipes/devmem2/devmem2/devmem2-fixups-2.patch b/recipes/devmem2/devmem2/devmem2-fixups-2.patch
index fe66605477..05dde4167f 100644
--- a/recipes/devmem2/devmem2/devmem2-fixups-2.patch
+++ b/recipes/devmem2/devmem2/devmem2-fixups-2.patch
@@ -153,7 +153,7 @@
+ break;
+ case 'w':
+ virt_addr = fixup_addr(virt_addr, sizeof(unsigned long));
-+// *((unsigned long *)virt_addr) = write_val;
++ *((unsigned long *)virt_addr) = write_val;
+ read_result = *((unsigned long *)virt_addr);
+ break;
}