aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/dhcdbd/dhcdbd_2.0.bb
diff options
context:
space:
mode:
authorDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
committerDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
commit709c4d66e0b107ca606941b988bad717c0b45d9b (patch)
tree37ee08b1eb308f3b2b6426d5793545c38396b838 /recipes/dhcdbd/dhcdbd_2.0.bb
parentfa6cd5a3b993f16c27de4ff82b42684516d433ba (diff)
downloadopenembedded-709c4d66e0b107ca606941b988bad717c0b45d9b.tar.gz
rename packages/ to recipes/ per earlier agreement
See links below for more details: http://thread.gmane.org/gmane.comp.handhelds.openembedded/21326 http://thread.gmane.org/gmane.comp.handhelds.openembedded/21816 Signed-off-by: Denys Dmytriyenko <denis@denix.org> Acked-by: Mike Westerhof <mwester@dls.net> Acked-by: Philip Balister <philip@balister.org> Acked-by: Khem Raj <raj.khem@gmail.com> Acked-by: Marcin Juszkiewicz <hrw@openembedded.org> Acked-by: Koen Kooi <koen@openembedded.org> Acked-by: Frans Meulenbroeks <fransmeulenbroeks@gmail.com>
Diffstat (limited to 'recipes/dhcdbd/dhcdbd_2.0.bb')
-rw-r--r--recipes/dhcdbd/dhcdbd_2.0.bb28
1 files changed, 28 insertions, 0 deletions
diff --git a/recipes/dhcdbd/dhcdbd_2.0.bb b/recipes/dhcdbd/dhcdbd_2.0.bb
new file mode 100644
index 0000000000..eedfe51d9a
--- /dev/null
+++ b/recipes/dhcdbd/dhcdbd_2.0.bb
@@ -0,0 +1,28 @@
+DESCRIPTION = "DBus-enabled dhcp client"
+SECTION = "net"
+LICENSE = "GPL"
+DEPENDS = "dbus"
+RDEPENDS = "dhcp-client"
+PR = "r1"
+
+SRC_URI = "https://fedorahosted.org/releases/d/h/dhcdbd/dhcdbd-${PV}.tar.bz2 \
+ file://dbus_connection_unref.patch;patch=1 \
+ file://paths.patch;patch=1 \
+ file://no-ext-options.patch;patch=1 \
+ file://dhcdbd"
+
+inherit update-rc.d
+
+do_compile() {
+ CC=${TARGET_SYS}-gcc DESTDIR=${prefix} make
+}
+
+do_install() {
+ DESTDIR=${D} make install
+ install -d ${D}/etc/init.d
+ install -m 0755 ${WORKDIR}/dhcdbd ${D}/etc/init.d/
+}
+
+INITSCRIPT_NAME = dhcdbd
+INITSCRIPT_PARAMS = "start 30 2 3 4 5 . stop 30 0 1 6 ."
+FILES_${PN} += "${sysconfdir} ${datadir}/dbus-1 ${base_sbindir}/*"