aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/dhcdbd/files/dhcdbd-1.14-pkgconfig_dbus.patch
diff options
context:
space:
mode:
authorDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
committerDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
commit709c4d66e0b107ca606941b988bad717c0b45d9b (patch)
tree37ee08b1eb308f3b2b6426d5793545c38396b838 /recipes/dhcdbd/files/dhcdbd-1.14-pkgconfig_dbus.patch
parentfa6cd5a3b993f16c27de4ff82b42684516d433ba (diff)
downloadopenembedded-709c4d66e0b107ca606941b988bad717c0b45d9b.tar.gz
rename packages/ to recipes/ per earlier agreement
See links below for more details: http://thread.gmane.org/gmane.comp.handhelds.openembedded/21326 http://thread.gmane.org/gmane.comp.handhelds.openembedded/21816 Signed-off-by: Denys Dmytriyenko <denis@denix.org> Acked-by: Mike Westerhof <mwester@dls.net> Acked-by: Philip Balister <philip@balister.org> Acked-by: Khem Raj <raj.khem@gmail.com> Acked-by: Marcin Juszkiewicz <hrw@openembedded.org> Acked-by: Koen Kooi <koen@openembedded.org> Acked-by: Frans Meulenbroeks <fransmeulenbroeks@gmail.com>
Diffstat (limited to 'recipes/dhcdbd/files/dhcdbd-1.14-pkgconfig_dbus.patch')
-rw-r--r--recipes/dhcdbd/files/dhcdbd-1.14-pkgconfig_dbus.patch26
1 files changed, 26 insertions, 0 deletions
diff --git a/recipes/dhcdbd/files/dhcdbd-1.14-pkgconfig_dbus.patch b/recipes/dhcdbd/files/dhcdbd-1.14-pkgconfig_dbus.patch
new file mode 100644
index 0000000000..c2e2151d17
--- /dev/null
+++ b/recipes/dhcdbd/files/dhcdbd-1.14-pkgconfig_dbus.patch
@@ -0,0 +1,26 @@
+diff -Naur dhcdbd-1.14/Makefile dhcdbd-1.14-mod/Makefile
+--- dhcdbd-1.14/Makefile 2006-01-17 22:23:51.000000000 +0100
++++ dhcdbd-1.14-mod/Makefile 2006-08-02 18:02:42.000000000 +0200
+@@ -7,8 +7,8 @@
+ LDFLAGS ?= -g
+ DESTDIR ?= /
+ LIBDIR ?= lib
+-DBUS_INCLUDES ?= -I/usr/$(LIBDIR)/dbus-1.0/include -I/usr/include/dbus-1.0
+-DBUS_LIBS ?= -ldbus-1
++DBUS_INCLUDES ?= `pkg-config dbus-1 --cflags`
++DBUS_LIBS ?= `pkg-config dbus-1 --libs`
+ OBJS = dbus_service.o dhcdbd.o dhcp_options.o main.o
+ SRCS = dbus_service.c dhcdbd.c dhcp_options.c main.c
+ INCS = dbus_service.h dhcdbd.h dhcp_options.h includes.h
+diff -Naur dhcdbd-1.14/tests/Makefile dhcdbd-1.14-mod/tests/Makefile
+--- dhcdbd-1.14/tests/Makefile 2006-01-17 22:23:51.000000000 +0100
++++ dhcdbd-1.14-mod/tests/Makefile 2006-08-02 18:11:43.000000000 +0200
+@@ -2,7 +2,7 @@
+ LD = ${CC}
+ CFLAGS ?= -g -Wall
+ LDFLAGS ?= -g
+-DBUS_LIBS ?= -ldbus-1
++DBUS_LIBS ?= `pkg-config dbus-1 --libs`
+
+ all: test_dhcp_options test_dhcdbd_state test_subscriber test_subscriber_dbus test_prospective_subscriber
+