summaryrefslogtreecommitdiffstats
path: root/recipes/dhclient
diff options
context:
space:
mode:
authorDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
committerDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
commit709c4d66e0b107ca606941b988bad717c0b45d9b (patch)
tree37ee08b1eb308f3b2b6426d5793545c38396b838 /recipes/dhclient
parentfa6cd5a3b993f16c27de4ff82b42684516d433ba (diff)
downloadopenembedded-709c4d66e0b107ca606941b988bad717c0b45d9b.tar.gz
rename packages/ to recipes/ per earlier agreement
See links below for more details: http://thread.gmane.org/gmane.comp.handhelds.openembedded/21326 http://thread.gmane.org/gmane.comp.handhelds.openembedded/21816 Signed-off-by: Denys Dmytriyenko <denis@denix.org> Acked-by: Mike Westerhof <mwester@dls.net> Acked-by: Philip Balister <philip@balister.org> Acked-by: Khem Raj <raj.khem@gmail.com> Acked-by: Marcin Juszkiewicz <hrw@openembedded.org> Acked-by: Koen Kooi <koen@openembedded.org> Acked-by: Frans Meulenbroeks <fransmeulenbroeks@gmail.com>
Diffstat (limited to 'recipes/dhclient')
-rw-r--r--recipes/dhclient/README3
-rw-r--r--recipes/dhclient/dhclient-2.0pl5/make.patch38
-rw-r--r--recipes/dhclient/dhclient_2.0pl5.bb17
3 files changed, 58 insertions, 0 deletions
diff --git a/recipes/dhclient/README b/recipes/dhclient/README
new file mode 100644
index 0000000000..9482c5fe18
--- /dev/null
+++ b/recipes/dhclient/README
@@ -0,0 +1,3 @@
+Note:
+ This version of dhclient is a very old one.
+ It is advised to use the dhclient that comes with the package dhcp
diff --git a/recipes/dhclient/dhclient-2.0pl5/make.patch b/recipes/dhclient/dhclient-2.0pl5/make.patch
new file mode 100644
index 0000000000..2052cca190
--- /dev/null
+++ b/recipes/dhclient/dhclient-2.0pl5/make.patch
@@ -0,0 +1,38 @@
+diff -ur dhcp-2.0pl5/common/Makefile.dist dhcp-2.0pl5-z/common/Makefile.dist
+--- dhcp-2.0pl5/common/Makefile.dist 1999-05-27 13:44:51.000000000 -0400
++++ dhcp-2.0pl5-z/common/Makefile.dist 2003-01-24 20:09:33.000000000 -0500
+@@ -50,8 +50,8 @@
+
+ libdhcp.a: $(OBJ)
+ rm -f libdhcp.a
+- ar cruv libdhcp.a $(OBJ)
+- ranlib libdhcp.a
++ $(AR) cruv libdhcp.a $(OBJ)
++ $(RANLIB) libdhcp.a
+
+ install: all
+ for dir in $(FFMANDIR); do \
+diff -ur dhcp-2.0pl5/Makefile.conf dhcp-2.0pl5-z/Makefile.conf
+--- dhcp-2.0pl5/Makefile.conf 2000-07-20 01:06:34.000000000 -0400
++++ dhcp-2.0pl5-z/Makefile.conf 2003-01-24 20:09:52.000000000 -0500
+@@ -254,6 +254,20 @@
+ #SCRIPT=linux
+ ##--linux-2.2--
+
++## Linux ARM
++##--linux-arm--
++#COPTS = -DLINUX_MAJOR=$(MAJORVERSION) -DLINUX_MINOR=$(MINORVERSION) $(CLAGS)
++#CF = cf/linux.h
++#ADMMANDIR = /usr/man/man8
++#ADMMANEXT = .8
++#FFMANDIR = /usr/share/man/man5
++#FFMANEXT = .5
++#MANCAT = man
++#VARRUN = /var/run
++#VARDB = /var/state/dhcp # see rationale in includes/cf/linux.h
++#SCRIPT=linux
++##--linux-arm--
++
+ ## SCO
+ ##--sco--
+ #CF = cf/sco.h
diff --git a/recipes/dhclient/dhclient_2.0pl5.bb b/recipes/dhclient/dhclient_2.0pl5.bb
new file mode 100644
index 0000000000..20b0dfc440
--- /dev/null
+++ b/recipes/dhclient/dhclient_2.0pl5.bb
@@ -0,0 +1,17 @@
+SECTION = "console/network"
+DESCRIPTION = "ISC DHCP Distribution (client and server)."
+LICENSE = "BSD"
+
+SRC_URI = "ftp://ftp.isc.org/isc/dhcp/dhcp-2.0-history/dhcp-${PV}.tar.gz \
+ file://make.patch;patch=1"
+S = "${WORKDIR}/dhcp-${PV}"
+
+export BINDIR = "${sbindir}"
+
+do_configure () {
+ ./configure ${TARGET_SYS}
+}
+
+do_install () {
+ oe_runmake "DESTDIR=${D}" install
+}