aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/dhcp-forwarder
diff options
context:
space:
mode:
authorDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
committerDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
commit709c4d66e0b107ca606941b988bad717c0b45d9b (patch)
tree37ee08b1eb308f3b2b6426d5793545c38396b838 /recipes/dhcp-forwarder
parentfa6cd5a3b993f16c27de4ff82b42684516d433ba (diff)
downloadopenembedded-709c4d66e0b107ca606941b988bad717c0b45d9b.tar.gz
rename packages/ to recipes/ per earlier agreement
See links below for more details: http://thread.gmane.org/gmane.comp.handhelds.openembedded/21326 http://thread.gmane.org/gmane.comp.handhelds.openembedded/21816 Signed-off-by: Denys Dmytriyenko <denis@denix.org> Acked-by: Mike Westerhof <mwester@dls.net> Acked-by: Philip Balister <philip@balister.org> Acked-by: Khem Raj <raj.khem@gmail.com> Acked-by: Marcin Juszkiewicz <hrw@openembedded.org> Acked-by: Koen Kooi <koen@openembedded.org> Acked-by: Frans Meulenbroeks <fransmeulenbroeks@gmail.com>
Diffstat (limited to 'recipes/dhcp-forwarder')
-rw-r--r--recipes/dhcp-forwarder/dhcp-forwarder_0.6.bb26
-rw-r--r--recipes/dhcp-forwarder/dhcp-forwarder_0.7.bb26
-rw-r--r--recipes/dhcp-forwarder/files/dhcp-fwd.cfg3
-rw-r--r--recipes/dhcp-forwarder/files/init25
4 files changed, 80 insertions, 0 deletions
diff --git a/recipes/dhcp-forwarder/dhcp-forwarder_0.6.bb b/recipes/dhcp-forwarder/dhcp-forwarder_0.6.bb
new file mode 100644
index 0000000000..8cf060e287
--- /dev/null
+++ b/recipes/dhcp-forwarder/dhcp-forwarder_0.6.bb
@@ -0,0 +1,26 @@
+SECTION = "console/network"
+DESCRIPTION = "This program is used to forward DHCP and BOOTP messages between two \
+ networks with different broadcast domains. \
+ It works better with ppp - and especially with ipsec over ppp - than \
+ dhcp-relay from ISC and has a smaller foot print."
+HOMEPAGE = "http://www.nongnu.org/dhcp-fwd/"
+LICENSE = "GPLv2"
+
+SRC_URI = "http://savannah.nongnu.org/download/dhcp-fwd/dhcp-forwarder-${PV}.tar.bz2 \
+ file://init \
+ file://dhcp-fwd.cfg"
+
+inherit autotools update-rc.d
+
+EXTRA_OECONF="--disable-dietlibc"
+
+INITSCRIPT_NAME="dhcp-forwarder"
+INITSCRIPT_PARAMS="defaults"
+
+do_install_append() {
+ install -d ${D}${sysconfdir}/init.d
+ install -m 0755 ${WORKDIR}/init ${D}${sysconfdir}/init.d/dhcp-forwarder
+ install -m 0644 ${WORKDIR}/dhcp-fwd.cfg ${D}${sysconfdir}
+}
+
+CONFFILES_${PN}_nylon = "${sysconfdir}/dhcp-fwd.cfg"
diff --git a/recipes/dhcp-forwarder/dhcp-forwarder_0.7.bb b/recipes/dhcp-forwarder/dhcp-forwarder_0.7.bb
new file mode 100644
index 0000000000..8cf060e287
--- /dev/null
+++ b/recipes/dhcp-forwarder/dhcp-forwarder_0.7.bb
@@ -0,0 +1,26 @@
+SECTION = "console/network"
+DESCRIPTION = "This program is used to forward DHCP and BOOTP messages between two \
+ networks with different broadcast domains. \
+ It works better with ppp - and especially with ipsec over ppp - than \
+ dhcp-relay from ISC and has a smaller foot print."
+HOMEPAGE = "http://www.nongnu.org/dhcp-fwd/"
+LICENSE = "GPLv2"
+
+SRC_URI = "http://savannah.nongnu.org/download/dhcp-fwd/dhcp-forwarder-${PV}.tar.bz2 \
+ file://init \
+ file://dhcp-fwd.cfg"
+
+inherit autotools update-rc.d
+
+EXTRA_OECONF="--disable-dietlibc"
+
+INITSCRIPT_NAME="dhcp-forwarder"
+INITSCRIPT_PARAMS="defaults"
+
+do_install_append() {
+ install -d ${D}${sysconfdir}/init.d
+ install -m 0755 ${WORKDIR}/init ${D}${sysconfdir}/init.d/dhcp-forwarder
+ install -m 0644 ${WORKDIR}/dhcp-fwd.cfg ${D}${sysconfdir}
+}
+
+CONFFILES_${PN}_nylon = "${sysconfdir}/dhcp-fwd.cfg"
diff --git a/recipes/dhcp-forwarder/files/dhcp-fwd.cfg b/recipes/dhcp-forwarder/files/dhcp-fwd.cfg
new file mode 100644
index 0000000000..5977542cd4
--- /dev/null
+++ b/recipes/dhcp-forwarder/files/dhcp-fwd.cfg
@@ -0,0 +1,3 @@
+chroot /
+logfile /var/log/dhcp-fwd.log
+pidfile /var/run/dhcp-fwd.pid
diff --git a/recipes/dhcp-forwarder/files/init b/recipes/dhcp-forwarder/files/init
new file mode 100644
index 0000000000..ca3b4568c0
--- /dev/null
+++ b/recipes/dhcp-forwarder/files/init
@@ -0,0 +1,25 @@
+#!/bin/bash
+
+#$Header: /data/cvs/mtx/system/dhcp-forwarder/ipkg/etc/init.d/dhcp-fwd,v 1.1 2004/04/21 08:42:05 ml Exp $
+
+CONFFILE=/etc/dhcp-fwd.cfg
+DAEMON=/usr/sbin/dhcp-fwd
+
+case "$1" in
+ start)
+ start-stop-daemon -S -x $DAEMON -- -c $CONFFILE
+ ;;
+ stop)
+ start-stop-daemon -K -x $DAEMON
+ ;;
+ restart | force-reload)
+ $0 stop
+ sleep 2
+ $0 start
+ ;;
+ *)
+ echo "Usage: $0 {start|stop|restart|force-reload}"
+ exit 1
+esac
+
+exit 0