aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/diethotplug
diff options
context:
space:
mode:
authorDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
committerDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
commit709c4d66e0b107ca606941b988bad717c0b45d9b (patch)
tree37ee08b1eb308f3b2b6426d5793545c38396b838 /recipes/diethotplug
parentfa6cd5a3b993f16c27de4ff82b42684516d433ba (diff)
downloadopenembedded-709c4d66e0b107ca606941b988bad717c0b45d9b.tar.gz
rename packages/ to recipes/ per earlier agreement
See links below for more details: http://thread.gmane.org/gmane.comp.handhelds.openembedded/21326 http://thread.gmane.org/gmane.comp.handhelds.openembedded/21816 Signed-off-by: Denys Dmytriyenko <denis@denix.org> Acked-by: Mike Westerhof <mwester@dls.net> Acked-by: Philip Balister <philip@balister.org> Acked-by: Khem Raj <raj.khem@gmail.com> Acked-by: Marcin Juszkiewicz <hrw@openembedded.org> Acked-by: Koen Kooi <koen@openembedded.org> Acked-by: Frans Meulenbroeks <fransmeulenbroeks@gmail.com>
Diffstat (limited to 'recipes/diethotplug')
-rw-r--r--recipes/diethotplug/diethotplug-0.4/modules.ieee1394map6
-rw-r--r--recipes/diethotplug/diethotplug-0.4/modules.pcimap1
-rw-r--r--recipes/diethotplug/diethotplug-0.4/modules.usbmap1
-rw-r--r--recipes/diethotplug/diethotplug_0.4.bb22
4 files changed, 30 insertions, 0 deletions
diff --git a/recipes/diethotplug/diethotplug-0.4/modules.ieee1394map b/recipes/diethotplug/diethotplug-0.4/modules.ieee1394map
new file mode 100644
index 0000000000..544e0a1e8d
--- /dev/null
+++ b/recipes/diethotplug/diethotplug-0.4/modules.ieee1394map
@@ -0,0 +1,6 @@
+# ieee1394 module match_flags vendor_id model_id specifier_id version
+dv1394 0x0000000c 0x000000 0x000000 0x00a02d 0x010001
+raw1394 0x0000000c 0x000000 0x000000 0x00a02d 0x010001
+raw1394 0x0000000c 0x000000 0x000000 0x00a02d 0x000100
+sbp2 0x0000000c 0x000000 0x000000 0x00609e 0x010483
+video1394 0x0000000c 0x000000 0x000000 0x00a02d 0x000100
diff --git a/recipes/diethotplug/diethotplug-0.4/modules.pcimap b/recipes/diethotplug/diethotplug-0.4/modules.pcimap
new file mode 100644
index 0000000000..3fd01ca286
--- /dev/null
+++ b/recipes/diethotplug/diethotplug-0.4/modules.pcimap
@@ -0,0 +1 @@
+# pci module vendor device subvendor subdevice class class_mask driver_data
diff --git a/recipes/diethotplug/diethotplug-0.4/modules.usbmap b/recipes/diethotplug/diethotplug-0.4/modules.usbmap
new file mode 100644
index 0000000000..50eb1c8bfa
--- /dev/null
+++ b/recipes/diethotplug/diethotplug-0.4/modules.usbmap
@@ -0,0 +1 @@
+# usb module match_flags idVendor idProduct bcdDevice_lo bcdDevice_hi bDeviceClass bDeviceSubClass bDeviceProtocol bInterfaceClass bInterfaceSubClass bInterfaceProtocol driver_info
diff --git a/recipes/diethotplug/diethotplug_0.4.bb b/recipes/diethotplug/diethotplug_0.4.bb
new file mode 100644
index 0000000000..150b442962
--- /dev/null
+++ b/recipes/diethotplug/diethotplug_0.4.bb
@@ -0,0 +1,22 @@
+SECTION = "base"
+LICENSE = "GPL"
+DESCRIPTION = "A small, C implementation of hotplug."
+
+SRC_URI = "${KERNELORG_MIRROR}/pub/linux/utils/kernel/hotplug/diethotplug-${PV}.tar.gz \
+ file://modules.usbmap \
+ file://modules.pcimap \
+ file://modules.ieee1394map"
+
+export KLIBC = ""
+
+do_compile () {
+ perl convert_usb.pl ${WORKDIR}/modules.usbmap > usb_modules.h
+ perl convert_pci.pl ${WORKDIR}/modules.pcimap > pci_modules.h
+ perl convert_ieee1394.pl ${WORKDIR}/modules.ieee1394map > ieee1394_modules.h
+ oe_runmake
+}
+
+do_install () {
+ install -d ${D}${sbindir}
+ install -m 0755 hotplug ${D}${sbindir}/
+}