aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/dietlibc
diff options
context:
space:
mode:
authorDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
committerDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
commit709c4d66e0b107ca606941b988bad717c0b45d9b (patch)
tree37ee08b1eb308f3b2b6426d5793545c38396b838 /recipes/dietlibc
parentfa6cd5a3b993f16c27de4ff82b42684516d433ba (diff)
downloadopenembedded-709c4d66e0b107ca606941b988bad717c0b45d9b.tar.gz
rename packages/ to recipes/ per earlier agreement
See links below for more details: http://thread.gmane.org/gmane.comp.handhelds.openembedded/21326 http://thread.gmane.org/gmane.comp.handhelds.openembedded/21816 Signed-off-by: Denys Dmytriyenko <denis@denix.org> Acked-by: Mike Westerhof <mwester@dls.net> Acked-by: Philip Balister <philip@balister.org> Acked-by: Khem Raj <raj.khem@gmail.com> Acked-by: Marcin Juszkiewicz <hrw@openembedded.org> Acked-by: Koen Kooi <koen@openembedded.org> Acked-by: Frans Meulenbroeks <fransmeulenbroeks@gmail.com>
Diffstat (limited to 'recipes/dietlibc')
-rw-r--r--recipes/dietlibc/dietlibc_0.31.bb47
-rw-r--r--recipes/dietlibc/files/ai_addrconfig.patch13
-rw-r--r--recipes/dietlibc/files/ccache.patch74
-rw-r--r--recipes/dietlibc/files/ceil.patch97
4 files changed, 231 insertions, 0 deletions
diff --git a/recipes/dietlibc/dietlibc_0.31.bb b/recipes/dietlibc/dietlibc_0.31.bb
new file mode 100644
index 0000000000..7720588b60
--- /dev/null
+++ b/recipes/dietlibc/dietlibc_0.31.bb
@@ -0,0 +1,47 @@
+SECTION = "libs"
+DESCRIPTION = "The diet libc is a libc that is optimized for small size. \
+It can be used to create small statically linked binaries"
+LICENSE = "GPLv2"
+
+SRC_URI = "${KERNELORG_MIRROR}/pub/linux/libs/dietlibc/dietlibc-${PV}.tar.bz2 \
+ file://ccache.patch;patch=1 \
+ file://ceil.patch;patch=1 \
+ file://ai_addrconfig.patch;patch=1 \
+ "
+
+#otherwise the whole run scripts got broken
+do_configure () {
+ echo "moo" > /dev/null 2>&1
+}
+
+do_compile () {
+ oe_runmake all CC="${BUILD_CC}" CFLAGS="${BUILD_CFLAGS}" prefix=${STAGING_DIR_TARGET}/lib/dietlibc
+ oe_runmake all ARCH="${TARGET_ARCH}" CROSS=" " prefix=${STAGING_DIR_TARGET}/lib/dietlibc
+}
+
+#no packages needed, all binaries will be compiled with -static
+PACKAGES = " "
+
+#otherwise the whole run scripts got broken
+do_install () {
+ echo "moo" > /dev/null 2>&1
+}
+
+do_stage () {
+ DIETLIBC_BUILD_ARCH=`echo ${BUILD_ARCH} | sed -e s'/.86/386/'`
+ DIETLIBC_TARGET_ARCH=`echo ${TARGET_ARCH} | sed -e s'/.86/386/'`
+ rm -rf ${STAGING_DIR_TARGET}/lib/dietlibc || true
+ rm ${CROSS_DIR}/bin/diet || true
+ install -d ${STAGING_DIR_TARGET}/lib/dietlibc/lib-${DIETLIBC_TARGET_ARCH}
+ install -d ${STAGING_DIR_TARGET}/lib/dietlibc/include
+ for i in `find include -name \*.h`; do install -m 644 -D $i ${STAGING_DIR_TARGET}/lib/dietlibc/$i; done
+
+ install -m755 bin-${DIETLIBC_BUILD_ARCH}/diet-i ${CROSS_DIR}/bin/diet
+
+ cd bin-${DIETLIBC_TARGET_ARCH}
+ install -m 644 start.o libm.a libpthread.a librpc.a \
+ liblatin1.a libcompat.a libcrypt.a \
+ ${STAGING_DIR_TARGET}/lib/dietlibc/lib-${DIETLIBC_TARGET_ARCH}
+ install -m 644 dietlibc.a ${STAGING_DIR_TARGET}/lib/dietlibc/lib-${DIETLIBC_TARGET_ARCH}/libc.a
+}
+
diff --git a/recipes/dietlibc/files/ai_addrconfig.patch b/recipes/dietlibc/files/ai_addrconfig.patch
new file mode 100644
index 0000000000..5687e9f0f4
--- /dev/null
+++ b/recipes/dietlibc/files/ai_addrconfig.patch
@@ -0,0 +1,13 @@
+Index: dietlibc-0.31/include/sys/socket.h
+===================================================================
+--- dietlibc-0.31.orig/include/sys/socket.h 2009-02-03 13:39:38.475445568 +0100
++++ dietlibc-0.31/include/sys/socket.h 2009-02-03 13:39:55.742105983 +0100
+@@ -439,6 +439,8 @@
+ #define EAI_AGAIN -10
+ #define EAI_SYSTEM -11
+
++#define AI_ADDRCONFIG 0
++
+ #define AI_NUMERICHOST 1
+ #define AI_CANONNAME 2
+ #define AI_PASSIVE 4
diff --git a/recipes/dietlibc/files/ccache.patch b/recipes/dietlibc/files/ccache.patch
new file mode 100644
index 0000000000..839b5b99a0
--- /dev/null
+++ b/recipes/dietlibc/files/ccache.patch
@@ -0,0 +1,74 @@
+Index: dietlibc-0.31/diet.c
+===================================================================
+--- dietlibc-0.31.orig/diet.c 2006-08-27 15:49:00.000000000 +0200
++++ dietlibc-0.31/diet.c 2009-01-31 22:56:06.828080683 +0100
+@@ -127,7 +127,12 @@
+ }
+ }
+ {
+- char *cc=argv[1];
++ char *cc;
++ if (!strcmp(argv[1],"ccache")) {
++ cc=argv[2];
++ } else {
++ cc=argv[1];
++ }
+ char *tmp=strchr(cc,0)-2;
+ char *tmp2,*tmp3;
+ if (tmp<cc) goto donttouch;
+@@ -139,7 +144,7 @@
+ if (tmp3<tmp2) tmp2=tmp3;
+ if (tmp2-cc>90) error("platform name too long!\n");
+ shortplatform=platform+len;
+- memmove(shortplatform,argv[1],(size_t)(tmp2-cc));
++ memmove(shortplatform,cc,(size_t)(tmp2-cc));
+ platform[tmp2-cc+len]=0;
+ if (shortplatform[0]=='i' && shortplatform[2]=='8' && shortplatform[3]=='6') shortplatform[1]='3';
+ } else {
+@@ -285,6 +290,9 @@
+
+ dest=newargv;
+ *dest++=argv[1];
++ if (strcmp(argv[1],"ccache") == 0) {
++ *dest++=argv[2];
++ }
+ if (argv[2]) {
+ if (!strcmp(argv[2],"-V")) {
+ *dest++=argv[2];
+@@ -294,9 +302,9 @@
+ } else if (!memcmp(argv[2],"-V",2)) {
+ *dest++=argv[2];
+ ++argv;
+- --argc;
+ }
+ }
++
+ #ifndef __DYN_LIB
+ if (_link) { *dest++=(char*)nostdlib; *dest++=dashstatic; *dest++=dashL; }
+ #else
+@@ -314,7 +322,15 @@
+ #ifdef WANT_DYNAMIC
+ if (_link) { *dest++=d; }
+ #endif
+- for (i=2; i<argc; ++i) {
++ if (strcmp(argv[1],"ccache") == 0) {
++ i=3;
++ } else {
++ i=2;
++ }
++ for (i; i<argc; ++i) {
++ if (strstr(argv[i],"isystem") != NULL) {
++ continue;
++ }
+ if (mangleopts)
+ if (argv[i][0]=='-' && (argv[i][1]=='O' || argv[i][1]=='f' ||
+ (argv[i][1]=='m' && argv[i][2]!='3' && argv[i][2]!='6'))) {
+@@ -322,6 +338,8 @@
+ continue;
+ }
+ *dest++=argv[i];
++ *dest--;
++ *dest++;
+ }
+ #ifndef __DYN_LIB
+ if (compile || _link) {
diff --git a/recipes/dietlibc/files/ceil.patch b/recipes/dietlibc/files/ceil.patch
new file mode 100644
index 0000000000..e2295d27fa
--- /dev/null
+++ b/recipes/dietlibc/files/ceil.patch
@@ -0,0 +1,97 @@
+Index: dietlibc-0.31/libm/ceil.c
+===================================================================
+--- /dev/null 1970-01-01 00:00:00.000000000 +0000
++++ dietlibc-0.31/libm/ceil.c 2009-02-01 02:54:28.533109301 +0100
+@@ -0,0 +1,92 @@
++/* @(#)s_ceil.c 5.1 93/09/24 */
++/*
++ * ====================================================
++ * Copyright (C) 1993 by Sun Microsystems, Inc. All rights reserved.
++ *
++ * Developed at SunPro, a Sun Microsystems, Inc. business.
++ * Permission to use, copy, modify, and distribute this
++ * software is freely granted, provided that this notice
++ * is preserved.
++ * ====================================================
++ */
++
++/*
++ * ceil(x)
++ * Return x rounded toward -inf to integral value
++ * Method:
++ * Bit twiddling.
++ * Exception:
++ * Inexact flag raised if x not equal to ceil(x).
++ */
++
++#include <math.h>
++
++typedef union {
++ double value;
++ struct {
++ unsigned int lsw;
++ unsigned int msw;
++ } parts;
++} ieee_double_shape_type;
++
++/* Get two 32 bit ints from a double. */
++
++#define EXTRACT_WORDS(ix0,ix1,d) \
++do { \
++ ieee_double_shape_type ew_u; \
++ ew_u.value = (d); \
++ (ix0) = ew_u.parts.msw; \
++ (ix1) = ew_u.parts.lsw; \
++} while (0)
++
++#define INSERT_WORDS(d,ix0,ix1) \
++do { \
++ ieee_double_shape_type iw_u; \
++ iw_u.parts.msw = (ix0); \
++ iw_u.parts.lsw = (ix1); \
++ (d) = iw_u.value; \
++} while (0)
++
++static const double huge = 1.0e300;
++
++double ceil(double x)
++{
++ int i0,i1,j0;
++ unsigned int i,j;
++ EXTRACT_WORDS(i0,i1,x);
++ j0 = ((i0>>20)&0x7ff)-0x3ff;
++ if(j0<20) {
++ if(j0<0) { /* raise inexact if x != 0 */
++ if(huge+x>0.0) {/* return 0*sign(x) if |x|<1 */
++ if(i0<0) {i0=0x80000000;i1=0;}
++ else if((i0|i1)!=0) { i0=0x3ff00000;i1=0;}
++ }
++ } else {
++ i = (0x000fffff)>>j0;
++ if(((i0&i)|i1)==0) return x; /* x is integral */
++ if(huge+x>0.0) { /* raise inexact flag */
++ if(i0>0) i0 += (0x00100000)>>j0;
++ i0 &= (~i); i1=0;
++ }
++ }
++ } else if (j0>51) {
++ if(j0==0x400) return x+x; /* inf or NaN */
++ else return x; /* x is integral */
++ } else {
++ i = ((unsigned int)(0xffffffff))>>(j0-20);
++ if((i1&i)==0) return x; /* x is integral */
++ if(huge+x>0.0) { /* raise inexact flag */
++ if(i0>0) {
++ if(j0==20) i0+=1;
++ else {
++ j = i1 + (1<<(52-j0));
++ if(j<i1) i0+=1; /* got a carry */
++ i1 = j;
++ }
++ }
++ i1 &= (~i);
++ }
++ }
++ INSERT_WORDS(x,i0,i1);
++ return x;
++}