aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/disko
diff options
context:
space:
mode:
authorHenning Heinold <heinold@inf.fu-berlin.de>2009-11-17 18:50:26 +0100
committerHenning Heinold <heinold@inf.fu-berlin.de>2009-11-17 21:34:21 +0100
commitd177641f4438910b3c946615c89b3099df5e65f0 (patch)
tree8ffb24132b25149cd26cf441f3d0d859dd65fc34 /recipes/disko
parentf001d149f39f7ef6384cb8f11ded39e3534e7e61 (diff)
downloadopenembedded-d177641f4438910b3c946615c89b3099df5e65f0.tar.gz
disko: update git and make recipe for version 1.6.0
* remove linkpath.patch not needed anymore * convert disko_git to new style and add sanesrcvrev into the right file * license now LGPL
Diffstat (limited to 'recipes/disko')
-rw-r--r--recipes/disko/disko_1.6.0.bb16
-rw-r--r--recipes/disko/disko_git.bb9
-rw-r--r--recipes/disko/files/linkpath.patch15
-rw-r--r--recipes/disko/files/pkgconfig.patch28
4 files changed, 34 insertions, 34 deletions
diff --git a/recipes/disko/disko_1.6.0.bb b/recipes/disko/disko_1.6.0.bb
new file mode 100644
index 0000000000..f8741e9c1c
--- /dev/null
+++ b/recipes/disko/disko_1.6.0.bb
@@ -0,0 +1,16 @@
+DESCRIPTION = "Disko is an application framework, that can be used to develop GUI applications for embedded devices. It is closely connected to the DirectFB"
+LICENSE = "LGPL"
+PR = "r0"
+
+require disko.inc
+
+DEPENDS += "taglib directfb virtual/libx11 hal libxv libxxf86vm"
+
+SRC_URI = "http://www.diskohq.org/downloads/${PN}-${PV}.tar.gz \
+ file://pkgconfig.patch;patch=1 \
+ "
+
+do_compile() {
+ ${STAGING_BINDIR_NATIVE}/scons ${PARALLEL_MAKE} graphics=all prefix=${prefix}/ || \
+ oefatal "scons build execution failed."
+}
diff --git a/recipes/disko/disko_git.bb b/recipes/disko/disko_git.bb
index 9aa378ee5c..738496e78e 100644
--- a/recipes/disko/disko_git.bb
+++ b/recipes/disko/disko_git.bb
@@ -1,22 +1,21 @@
DESCRIPTION = "Disko is an application framework, that can be used to develop GUI applications for embedded devices. It is closely connected to the DirectFB"
LICENSE = "GPL"
-PV = "1.6.0+gitr${SRCREV}"
+PV = "1.6.1+${SRCPV}"
PR = "r0"
+DEFAULT_PREFERENCE = "-1"
+
require disko.inc
DEPENDS += "taglib directfb virtual/libx11 hal libxv libxxf86vm"
SRC_URI = "git://www.diskohq.org/disko.git;protocol=git \
- file://linkpath.patch;patch=1 \
file://pkgconfig.patch;patch=1 \
"
-SRCREV = "2aa9912fc32fcf24574e5053201e967dd59bceca"
-
S = "${WORKDIR}/git"
do_compile() {
- ${STAGING_BINDIR_NATIVE}/scons ${PARALLEL_MAKE} graphics=all PREFIX=${prefix} prefix=${prefix} || \
+ ${STAGING_BINDIR_NATIVE}/scons ${PARALLEL_MAKE} graphics=all prefix=${prefix}/ || \
oefatal "scons build execution failed."
}
diff --git a/recipes/disko/files/linkpath.patch b/recipes/disko/files/linkpath.patch
deleted file mode 100644
index e38b0748c4..0000000000
--- a/recipes/disko/files/linkpath.patch
+++ /dev/null
@@ -1,15 +0,0 @@
-Index: git/SConstruct
-===================================================================
---- git.orig/SConstruct 2009-09-11 01:44:37.000000000 +0200
-+++ git/SConstruct 2009-09-11 01:52:26.265319426 +0200
-@@ -161,8 +161,8 @@
- idir_inc = idir_prefix + '/include/disko'
- idir_data = idir_prefix + '/share/disko'
-
--# link with -rpath
--# env['LINKFLAGS'].extend(['-Wl,-rpath=' + env['prefix'] + '/lib/disko'])
-+# link with -rpath-link
-+# env['LINKFLAGS'].extend(['-Wl,-rpath-link==' + env['prefix'] + '/lib/disko'])
-
- # extra flags
- if env['messages']:
diff --git a/recipes/disko/files/pkgconfig.patch b/recipes/disko/files/pkgconfig.patch
index 3e4a84bfe8..c405f0200e 100644
--- a/recipes/disko/files/pkgconfig.patch
+++ b/recipes/disko/files/pkgconfig.patch
@@ -1,8 +1,8 @@
-Index: git/SConstruct
+Index: disko-1.6.0/SConstruct
===================================================================
---- git.orig/SConstruct 2009-09-11 01:53:54.000000000 +0200
-+++ git/SConstruct 2009-09-11 02:08:12.789878911 +0200
-@@ -585,6 +585,7 @@
+--- disko-1.6.0.orig/SConstruct 2009-10-14 12:54:36.000000000 +0200
++++ disko-1.6.0/SConstruct 2009-11-17 18:22:49.656165471 +0100
+@@ -580,6 +580,7 @@
#######################################################################
# TODO: handle disko_pc_libs #
if 'install' in BUILD_TARGETS:
@@ -10,7 +10,7 @@ Index: git/SConstruct
disko_pc = open('disko.pc', 'w')
disko_pc_requires = 'libxml-2.0 >= 2.6, sigc++-2.0, libpng >= 1.2, freetype2'
if env['LIBPATH']:
-@@ -610,30 +611,43 @@
+@@ -602,50 +603,76 @@
if env.has_key('libdl'):
disko_pc_libs += ' -ldl'
@@ -54,17 +54,17 @@ Index: git/SConstruct
if env['enable_sip']:
disko_pc_requires += ', libpj'
-@@ -641,18 +655,32 @@
+ if not env['big_lib'] and not env['static_lib']:
disko_pc_libs += ' -lmmssip'
++ PKG_CCFLAGS += '-D__HAVE_MMSSIP__ '
if('uuid' in env['LIBS']):
disko_pc_requires += ', uuid'
-+ PKG_CCFLAGS += '-D__HAVE_MMSSIP__ '
if env['enable_mail']:
disko_pc_requires += ', vmime'
+ PKG_CCFLAGS += '-D__HAVE_VMIME__ '
- if env['mmscrypt']:
+ if env['enable_crypt']:
disko_pc_requires += ', openssl'
+ PKG_CCFLAGS += '-D__HAVE_MMSCRYPT__ '
@@ -74,20 +74,20 @@ Index: git/SConstruct
if 'mysql' in env['database']:
disko_pc_requires += ', mysql'
-+ PKG_CCFLAGS += '-D__ENABLE_MYSQL__ '
-+
+
+ if 'odbc' in env['database']:
+ PKG_CCFLAGS += '-D__ENABLE_FREETDS__ '
+
+ if env['messages']:
-+ PKG_CCFLAGS += '-D__ENABLE_LOG__ '
++ PKG_CCFLAGS += '-D__ENABLE_LOG__ '
+
+ if env['debug']:
-+ PKG_CCFLAGS += '-D__ENABLE_DEBUG__ '
-
++ PKG_CCFLAGS += '-D__ENABLE_DEBUG__ '
++
disko_pc.write('prefix=' + env['prefix'] + '\n')
disko_pc.write('exec_prefix=${prefix}\n')
-@@ -664,13 +692,7 @@
+ disko_pc.write('libdir=${exec_prefix}/lib/disko\n')
+@@ -656,13 +683,7 @@
disko_pc.write('Requires: ' + disko_pc_requires + '\n')
disko_pc.write('Libs: -L${libdir} ' + disko_pc_libs + '\n')
disko_pc.write('Cflags: -I${includedir}/ ')