summaryrefslogtreecommitdiffstats
path: root/recipes/distcc
diff options
context:
space:
mode:
authorKoen Kooi <koen@openembedded.org>2009-06-02 20:11:21 +0200
committerKoen Kooi <koen@Powerbook-3.local>2009-06-05 17:48:06 +0200
commit903a2a4beb8d1661408ac1665f74b84d71a88ad6 (patch)
tree558fb7fe18d0c4504cf9ee8777a1277a1df4b772 /recipes/distcc
parent347db9f615e3de5f00441ad983985bc9995c66bc (diff)
downloadopenembedded-903a2a4beb8d1661408ac1665f74b84d71a88ad6.tar.gz
distcc: fix startup by creating 'distcc' user
Diffstat (limited to 'recipes/distcc')
-rw-r--r--recipes/distcc/distcc_3.1.bb17
1 files changed, 17 insertions, 0 deletions
diff --git a/recipes/distcc/distcc_3.1.bb b/recipes/distcc/distcc_3.1.bb
index 879f676519..16e7184c61 100644
--- a/recipes/distcc/distcc_3.1.bb
+++ b/recipes/distcc/distcc_3.1.bb
@@ -3,6 +3,8 @@ compilation of C/C++/ObjC code across machines on a network."
SECTION = "devel"
LICENSE = "GPLv2"
+PR = "r1"
+
DEPENDS = "avahi gtk+"
RRECOMMENDS = "avahi-daemon"
@@ -44,3 +46,18 @@ CONFFILES_${PN} += "${sysconfdir}/default/distcc \
FILES_distcc-distmon-gnome = " ${bindir}/distccmon-gnome \
${datadir}/distcc"
+
+
+pkg_postinst_${PN} () {
+ # can't do this offline
+ if [ "x$D" != "x" ]; then
+ exit 1
+ fi
+ grep "^distcc:" /etc/group > /dev/null || addgroup distcc
+ grep "^distcc:" /etc/passwd > /dev/null || adduser --disabled-password --system --home /var/lib/distcc distcc --ingroup distcc -g "distcc daemon"
+}
+
+pkg_postrm_${PN} () {
+ deluser distcc || true
+ delgroup distcc || true
+}