aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/dmalloc/dmalloc_5.5.2.bb
diff options
context:
space:
mode:
authorDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
committerDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
commit709c4d66e0b107ca606941b988bad717c0b45d9b (patch)
tree37ee08b1eb308f3b2b6426d5793545c38396b838 /recipes/dmalloc/dmalloc_5.5.2.bb
parentfa6cd5a3b993f16c27de4ff82b42684516d433ba (diff)
downloadopenembedded-709c4d66e0b107ca606941b988bad717c0b45d9b.tar.gz
rename packages/ to recipes/ per earlier agreement
See links below for more details: http://thread.gmane.org/gmane.comp.handhelds.openembedded/21326 http://thread.gmane.org/gmane.comp.handhelds.openembedded/21816 Signed-off-by: Denys Dmytriyenko <denis@denix.org> Acked-by: Mike Westerhof <mwester@dls.net> Acked-by: Philip Balister <philip@balister.org> Acked-by: Khem Raj <raj.khem@gmail.com> Acked-by: Marcin Juszkiewicz <hrw@openembedded.org> Acked-by: Koen Kooi <koen@openembedded.org> Acked-by: Frans Meulenbroeks <fransmeulenbroeks@gmail.com>
Diffstat (limited to 'recipes/dmalloc/dmalloc_5.5.2.bb')
-rw-r--r--recipes/dmalloc/dmalloc_5.5.2.bb25
1 files changed, 25 insertions, 0 deletions
diff --git a/recipes/dmalloc/dmalloc_5.5.2.bb b/recipes/dmalloc/dmalloc_5.5.2.bb
new file mode 100644
index 0000000000..c91152b537
--- /dev/null
+++ b/recipes/dmalloc/dmalloc_5.5.2.bb
@@ -0,0 +1,25 @@
+DESCRIPTION = "Debug Malloc Library"
+SECTION = "libs/devel"
+HOMEPAGE = "http://dmalloc.com"
+LICENSE = "CCSA"
+
+SRC_URI = "\
+ http://dmalloc.com/releases/dmalloc-${PV}.tgz \
+ file://configure-pagesize-HACK.patch;patch=1 \
+# HACK we ship a preconfigured conf.h since otherwise it misses a whole lot of stuff and compilation fails.
+# TODO find out why and get rid of it
+ file://conf.h \
+"
+inherit autotools pkgconfig
+
+do_configure_append() {
+ install -m 0644 ${WORKDIR}/conf.h ${S}
+}
+
+do_stage() {
+ oe_libinstall -a libdmalloc ${STAGING_LIBDIR}
+}
+
+do_install() {
+ :
+}