aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/docbook-dsssl-stylesheets
diff options
context:
space:
mode:
authorFahad Usman <fahad_usman@mentor.com>2010-09-06 23:27:41 +0000
committerKhem Raj <raj.khem@gmail.com>2010-09-30 13:17:06 -0700
commitf72df9c6e969a622ea8829d0ce3467fa6c0cb8e8 (patch)
tree945e3eefeab80775e3b9f949fbc52b0efd9c687b /recipes/docbook-dsssl-stylesheets
parentb98c234bf7907ff4e956f131023437d01e57c910 (diff)
downloadopenembedded-f72df9c6e969a622ea8829d0ce3467fa6c0cb8e8.tar.gz
docbook-dsssl-stylesheets-native_1.79.bb: converted to new style staging
* Converted do_stage to do_install. * Moved the catalog files from ${sysconfdir}/sgml to ${D}${sysconfdir}/sgml so that they get included in the package file resulting with the new style staging. * Added a function docbook_dssl_stylesheets_native_mangle, to correct the path in .cat file and added it to SYSROOT_PREPROCESS_FUNCS. * Added PR = "r1" Signed-off-by: Fahad Usman <fahad_usman@mentor.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'recipes/docbook-dsssl-stylesheets')
-rw-r--r--recipes/docbook-dsssl-stylesheets/docbook-dsssl-stylesheets-native_1.79.bb41
1 files changed, 29 insertions, 12 deletions
diff --git a/recipes/docbook-dsssl-stylesheets/docbook-dsssl-stylesheets-native_1.79.bb b/recipes/docbook-dsssl-stylesheets/docbook-dsssl-stylesheets-native_1.79.bb
index cd4e56cfe3..234606f712 100644
--- a/recipes/docbook-dsssl-stylesheets/docbook-dsssl-stylesheets-native_1.79.bb
+++ b/recipes/docbook-dsssl-stylesheets/docbook-dsssl-stylesheets-native_1.79.bb
@@ -9,30 +9,47 @@ SRC_URI = "${SOURCEFORGE_MIRROR}/docbook/docbook-dsssl-${PV}.tar.bz2"
S = "${WORKDIR}/docbook-dsssl-${PV}"
+PR = "r1"
+
+SYSROOT_PREPROCESS_FUNCS += "docbook_dssl_stylesheets_native_mangle"
+
inherit native
-do_stage () {
+do_install () {
# Refer to http://www.linuxfromscratch.org/blfs/view/stable/pst/docbook-dsssl.html
# for details.
- install -d ${STAGING_BINDIR_NATIVE}
- install -m 0755 bin/collateindex.pl ${STAGING_BINDIR_NATIVE}
-
- install -d ${STAGING_DATADIR}/sgml/docbook/dsssl-stylesheets-${PV}
- install -m 0644 catalog ${STAGING_DATADIR}/sgml/docbook/dsssl-stylesheets-${PV}
- cp -dpr common ${STAGING_DATADIR}/sgml/docbook/dsssl-stylesheets-${PV}
-
+ install -d ${D}${bindir}
+ install -m 0755 bin/collateindex.pl ${D}${bindir}
+
+ install -d ${D}${datadir}/sgml/docbook/dsssl-stylesheets-${PV}
+ install -m 0644 catalog ${D}${datadir}/sgml/docbook/dsssl-stylesheets-${PV}
+ cp -dpr common ${D}${datadir}/sgml/docbook/dsssl-stylesheets-${PV}
+
install-catalog --add ${sysconfdir}/sgml/dsssl-docbook-stylesheets.cat \
- ${STAGING_DATADIR}/sgml/docbook/dsssl-stylesheets-${PV}/catalog
-
+ ${D}${datadir}/sgml/docbook/dsssl-stylesheets-${PV}/catalog
+
install-catalog --add ${sysconfdir}/sgml/dsssl-docbook-stylesheets.cat \
- ${STAGING_DATADIR}/sgml/docbook/dsssl-stylesheets-${PV}/common/catalog
+ ${D}${datadir}/sgml/docbook/dsssl-stylesheets-${PV}/common/catalog
install-catalog --add ${sysconfdir}/sgml/sgml-docbook.cat \
${sysconfdir}/sgml/dsssl-docbook-stylesheets.cat
-
+
+ # Moving them to image directory so that they get included in the .ipk file
+ # generated by new style staging.
+ install -d ${D}${sysconfdir}/sgml
+ cp ${sysconfdir}/sgml/dsssl-docbook-stylesheets.cat ${D}${sysconfdir}/sgml/
+ cp ${sysconfdir}/sgml/sgml-docbook.cat ${D}${sysconfdir}/sgml/
+ cp ${sysconfdir}/sgml/catalog ${D}${sysconfdir}/sgml/
}
PACKAGES = ""
+docbook_dssl_stylesheets_native_mangle () {
+ # Removing the image directory path (${D}) from the .cat file.
+ sed -i -e "s|${D}||g" ${SYSROOT_DESTDIR}${sysconfdir}/sgml/dsssl-docbook-stylesheets.cat
+}
+
SRC_URI[md5sum] = "bc192d23266b9a664ca0aba4a7794c7c"
SRC_URI[sha256sum] = "2f329e120bee9ef42fbdd74ddd60e05e49786c5a7953a0ff4c680ae6bdf0e2bc"
+
+NATIVE_INSTALL_WORKS = "1"