aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/docbook-utils/docbook-utils-native_0.6.14.bb
diff options
context:
space:
mode:
authorDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
committerDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
commit709c4d66e0b107ca606941b988bad717c0b45d9b (patch)
tree37ee08b1eb308f3b2b6426d5793545c38396b838 /recipes/docbook-utils/docbook-utils-native_0.6.14.bb
parentfa6cd5a3b993f16c27de4ff82b42684516d433ba (diff)
downloadopenembedded-709c4d66e0b107ca606941b988bad717c0b45d9b.tar.gz
rename packages/ to recipes/ per earlier agreement
See links below for more details: http://thread.gmane.org/gmane.comp.handhelds.openembedded/21326 http://thread.gmane.org/gmane.comp.handhelds.openembedded/21816 Signed-off-by: Denys Dmytriyenko <denis@denix.org> Acked-by: Mike Westerhof <mwester@dls.net> Acked-by: Philip Balister <philip@balister.org> Acked-by: Khem Raj <raj.khem@gmail.com> Acked-by: Marcin Juszkiewicz <hrw@openembedded.org> Acked-by: Koen Kooi <koen@openembedded.org> Acked-by: Frans Meulenbroeks <fransmeulenbroeks@gmail.com>
Diffstat (limited to 'recipes/docbook-utils/docbook-utils-native_0.6.14.bb')
-rw-r--r--recipes/docbook-utils/docbook-utils-native_0.6.14.bb42
1 files changed, 42 insertions, 0 deletions
diff --git a/recipes/docbook-utils/docbook-utils-native_0.6.14.bb b/recipes/docbook-utils/docbook-utils-native_0.6.14.bb
new file mode 100644
index 0000000000..eef3f9e0fb
--- /dev/null
+++ b/recipes/docbook-utils/docbook-utils-native_0.6.14.bb
@@ -0,0 +1,42 @@
+SECTION = "console/utils"
+LICENSE = "GPL"
+
+PR = "r2"
+
+DEPENDS = "openjade-native sgmlspl-native docbook-dsssl-stylesheets-native docbook-sgml-dtd-3.1-native"
+
+SRC_URI = "ftp://sources.redhat.com/pub/docbook-tools/new-trials/SOURCES/docbook-utils-${PV}.tar.gz"
+S = "${WORKDIR}/docbook-utils-${PV}"
+
+inherit autotools native
+
+do_configure_prepend() {
+ # Prevents the jw script to search on the build system.
+ sed -i -e "s|/etc/sgml|${sysconfdir}/sgml|g" bin/jw.in
+
+ sed -i -e "s|/etc/sgml|${sysconfdir}/sgml|g" doc/man/Makefile.am
+ sed -i -e "s|/etc/sgml|${sysconfdir}/sgml|g" doc/HTML/Makefile.am
+}
+
+do_stage () {
+ install -d ${STAGING_BINDIR_NATIVE}/
+
+ # Installs the binaries and a bunch of other commonly used names for them.
+ for doctype in html ps dvi man pdf rtf tex texi txt
+ do
+ install -m 0755 ${S}/bin/docbook2$doctype ${STAGING_BINDIR_NATIVE}/
+ ln -sf docbook2x-$doctype ${STAGING_BINDIR_NATIVE}/db2$doctype
+ ln -sf docbook2$doctype ${STAGING_BINDIR_NATIVE}/db2$doctype
+ ln -sf docbook2$doctype ${STAGING_BINDIR_NATIVE}/docbook-to-$doctype
+ done
+ install -m 0755 ${S}/bin/jw ${STAGING_BINDIR_NATIVE}/
+
+ for i in backends/dvi backends/html backends/man \
+ backends/pdf backends/ps backends/rtf backends/tex \
+ backends/texi backends/txt frontends/docbook \
+ helpers/docbook2man-spec.pl helpers/docbook2texi-spec.pl \
+ docbook-utils.dsl; do
+ install -d ${STAGING_DATADIR}/sgml/docbook/utils-${PV}/`dirname $i`
+ install ${S}/$i ${STAGING_DATADIR}/sgml/docbook/utils-${PV}/$i
+ done
+}