aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/dri
diff options
context:
space:
mode:
authorDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
committerDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
commit709c4d66e0b107ca606941b988bad717c0b45d9b (patch)
tree37ee08b1eb308f3b2b6426d5793545c38396b838 /recipes/dri
parentfa6cd5a3b993f16c27de4ff82b42684516d433ba (diff)
downloadopenembedded-709c4d66e0b107ca606941b988bad717c0b45d9b.tar.gz
rename packages/ to recipes/ per earlier agreement
See links below for more details: http://thread.gmane.org/gmane.comp.handhelds.openembedded/21326 http://thread.gmane.org/gmane.comp.handhelds.openembedded/21816 Signed-off-by: Denys Dmytriyenko <denis@denix.org> Acked-by: Mike Westerhof <mwester@dls.net> Acked-by: Philip Balister <philip@balister.org> Acked-by: Khem Raj <raj.khem@gmail.com> Acked-by: Marcin Juszkiewicz <hrw@openembedded.org> Acked-by: Koen Kooi <koen@openembedded.org> Acked-by: Frans Meulenbroeks <fransmeulenbroeks@gmail.com>
Diffstat (limited to 'recipes/dri')
-rw-r--r--recipes/dri/drm-kernel/make.patch20
-rw-r--r--recipes/dri/drm-kernel_cvs.bb36
-rw-r--r--recipes/dri/libdrm_2.3.0.bb10
-rw-r--r--recipes/dri/libdrm_2.3.1.bb10
4 files changed, 76 insertions, 0 deletions
diff --git a/recipes/dri/drm-kernel/make.patch b/recipes/dri/drm-kernel/make.patch
new file mode 100644
index 0000000000..f0dabecd5e
--- /dev/null
+++ b/recipes/dri/drm-kernel/make.patch
@@ -0,0 +1,20 @@
+--- drm/linux-core/Makefile 2005-06-03 21:02:54.000000000 +0100
++++ drm/linux-core/Makefile 2005-06-17 21:40:34.000000000 +0100
+@@ -173,7 +173,7 @@
+ all: modules
+
+ modules: includes
+- make -C $(LINUXDIR) $(GETCONFIG) SUBDIRS=`pwd` DRMSRCDIR=`pwd` modules
++ $(MAKE) -C $(LINUXDIR) $(GETCONFIG) SUBDIRS=`pwd` DRMSRCDIR=`pwd` modules
+
+ ifeq ($(HEADERFROMBOOT),1)
+
+@@ -243,7 +243,7 @@
+ rm -rf $(CLEANFILES)
+
+ $(MODULE_LIST)::
+- make DRM_MODULES=$@ modules
++ $(MAKE) DRM_MODULES=$@ modules
+
+ # Build test utilities
+
diff --git a/recipes/dri/drm-kernel_cvs.bb b/recipes/dri/drm-kernel_cvs.bb
new file mode 100644
index 0000000000..9e04cc4d7e
--- /dev/null
+++ b/recipes/dri/drm-kernel_cvs.bb
@@ -0,0 +1,36 @@
+# FIXME, consider using kernel staging directory instead of KERNEL_SOURCE which is
+# located in the work directory. see modules.bbclass
+
+SECTION = "x11/base"
+PR = "r3"
+LICENSE = "MIT"
+
+SRC_URI = "${FREEDESKTOP_CVS}/dri;module=drm;method=pserver \
+ file://make.patch;patch=1"
+
+inherit module-base
+
+PV = "0.0+cvs${SRCDATE}"
+S = "${WORKDIR}/drm"
+
+do_compile() {
+ unset CFLAGS CPPFLAGS CXXFLAGS LDFLAGS
+ oe_runmake -C linux-core LINUXDIR="${KERNEL_SOURCE}" MAKE="make -e" CC="${KERNEL_CC}" LD="${KERNEL_LD}"
+}
+
+do_install() {
+ install -d ${D}${base_libdir}/modules/${KERNEL_VERSION}/drm
+ cd linux-core
+ for i in *.ko; do install -m 0644 $i ${D}${base_libdir}/modules/${KERNEL_VERSION}/drm/; done
+}
+
+PACKAGES_DYNAMIC = "drm-module-*"
+
+python populate_packages_prepend () {
+ root = bb.data.expand('/lib/modules/${KERNEL_VERSION}/drm', d)
+
+ do_split_packages(d, root, '^(.*)\.ko$',
+ output_pattern='drm-module-%s',
+ description='DRM driver module for %s',
+ extra_depends='')
+}
diff --git a/recipes/dri/libdrm_2.3.0.bb b/recipes/dri/libdrm_2.3.0.bb
new file mode 100644
index 0000000000..9caf9b4bea
--- /dev/null
+++ b/recipes/dri/libdrm_2.3.0.bb
@@ -0,0 +1,10 @@
+SECTION = "x11/base"
+LICENSE = "MIT"
+SRC_URI = "http://dri.freedesktop.org/libdrm/libdrm-${PV}.tar.bz2"
+PROVIDES = "drm"
+
+inherit autotools pkgconfig
+
+do_stage() {
+ autotools_stage_all
+}
diff --git a/recipes/dri/libdrm_2.3.1.bb b/recipes/dri/libdrm_2.3.1.bb
new file mode 100644
index 0000000000..9caf9b4bea
--- /dev/null
+++ b/recipes/dri/libdrm_2.3.1.bb
@@ -0,0 +1,10 @@
+SECTION = "x11/base"
+LICENSE = "MIT"
+SRC_URI = "http://dri.freedesktop.org/libdrm/libdrm-${PV}.tar.bz2"
+PROVIDES = "drm"
+
+inherit autotools pkgconfig
+
+do_stage() {
+ autotools_stage_all
+}