aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/dri
diff options
context:
space:
mode:
authorGraham Gower <graham.gower@gmail.com>2010-11-29 16:21:37 +1030
committerEric Bénard <eric@eukrea.com>2010-11-29 11:31:58 +0100
commit76847710c47025b24b522a4570e74f48924b70f0 (patch)
tree61d51cfbd6f14da6bef9f730a1e16b712b224ff4 /recipes/dri
parent2ca2dffe47eb88ac014921f4e4d7479d953f9d57 (diff)
downloadopenembedded-76847710c47025b24b522a4570e74f48924b70f0.tar.gz
libdrm_2.4.22.bb: Fix build for uclibc when DISTRO_FEATURES lacks largefile.
CC intel.lo In file included from /mnt/oe/tmp/sysroots/mipsel-oe-linux-uclibc/include/errno.h:29:0, from intel.c:32: /mnt/oe/tmp/sysroots/mipsel-oe-linux-uclibc/include/features.h:216:5: error: #error It appears you have defined _FILE_OFFSET_BITS=64. Unfortunately, uClibc was built without large file support enabled. In file included from /mnt/oe/tmp/sysroots/mipsel-oe-linux-uclibc/include/stdio.h:72:0, from intel.c:33: /mnt/oe/tmp/sysroots/mipsel-oe-linux-uclibc/include/bits/uClibc_stdio.h:61:2: error: #error Sorry... uClibc was built without large file support! In file included from intel.c:33:0: /mnt/oe/tmp/sysroots/mipsel-oe-linux-uclibc/include/stdio.h:83:26: error: expected '=', ',', ';', 'asm' or '__attribute__' before 'fpos_t' In file included from intel.c:33:0: /mnt/oe/tmp/sysroots/mipsel-oe-linux-uclibc/include/stdio.h:719:12: error: expected declaration specifiers or '...' before 'fpos_t' /mnt/oe/tmp/sysroots/mipsel-oe-linux-uclibc/include/stdio.h:721:12: error: expected ';', ',' or ')' before '*' token make[2]: *** [intel.lo] Error 1 Signed-off-by: Graham Gower <graham.gower@gmail.com> Signed-off-by: Eric Bénard <eric@eukrea.com>
Diffstat (limited to 'recipes/dri')
-rw-r--r--recipes/dri/libdrm_2.4.22.bb6
1 files changed, 6 insertions, 0 deletions
diff --git a/recipes/dri/libdrm_2.4.22.bb b/recipes/dri/libdrm_2.4.22.bb
index 107e8b8f51..fb94e4cc6d 100644
--- a/recipes/dri/libdrm_2.4.22.bb
+++ b/recipes/dri/libdrm_2.4.22.bb
@@ -17,3 +17,9 @@ EXTRA_OECONF_append_angstrom = " --disable-radeon "
PACKAGES =+ "${@base_contains('MACHINE_FEATURES', 'x86', '${PN}-intel', '',d)}"
FILES_${PN}-intel = "${libdir}/libdrm_intel.so.*"
+
+do_compile_prepend_libc-uclibc() {
+ eval "${@base_contains('DISTRO_FEATURES', 'largefile', '', 'sed -i -e "/_FILE_OFFSET_BITS/d" ${S}/libkms/intel.c', d)}"
+ eval "${@base_contains('DISTRO_FEATURES', 'largefile', '', 'sed -i -e "/_FILE_OFFSET_BITS/d" ${S}/libkms/vmwgfx.c', d)}"
+ eval "${@base_contains('DISTRO_FEATURES', 'largefile', '', 'sed -i -e "/_FILE_OFFSET_BITS/d" ${S}/libkms/nouveau.c', d)}"
+}