summaryrefslogtreecommitdiffstats
path: root/recipes/driftnet/driftnet_0.1.6.bb
diff options
context:
space:
mode:
authorDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
committerDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
commit709c4d66e0b107ca606941b988bad717c0b45d9b (patch)
tree37ee08b1eb308f3b2b6426d5793545c38396b838 /recipes/driftnet/driftnet_0.1.6.bb
parentfa6cd5a3b993f16c27de4ff82b42684516d433ba (diff)
downloadopenembedded-709c4d66e0b107ca606941b988bad717c0b45d9b.tar.gz
rename packages/ to recipes/ per earlier agreement
See links below for more details: http://thread.gmane.org/gmane.comp.handhelds.openembedded/21326 http://thread.gmane.org/gmane.comp.handhelds.openembedded/21816 Signed-off-by: Denys Dmytriyenko <denis@denix.org> Acked-by: Mike Westerhof <mwester@dls.net> Acked-by: Philip Balister <philip@balister.org> Acked-by: Khem Raj <raj.khem@gmail.com> Acked-by: Marcin Juszkiewicz <hrw@openembedded.org> Acked-by: Koen Kooi <koen@openembedded.org> Acked-by: Frans Meulenbroeks <fransmeulenbroeks@gmail.com>
Diffstat (limited to 'recipes/driftnet/driftnet_0.1.6.bb')
-rw-r--r--recipes/driftnet/driftnet_0.1.6.bb25
1 files changed, 25 insertions, 0 deletions
diff --git a/recipes/driftnet/driftnet_0.1.6.bb b/recipes/driftnet/driftnet_0.1.6.bb
new file mode 100644
index 0000000000..8a272792a0
--- /dev/null
+++ b/recipes/driftnet/driftnet_0.1.6.bb
@@ -0,0 +1,25 @@
+DESCRIPTION = "Driftnet watches network traffic, and picks out and displays JPEG and GIF \
+images for display. It is an horrific invasion of privacy and shouldn't be used \
+by anyone anywhere. It can also extract MPEG audio data from the network and \
+play it."
+SECTION = "net"
+PRIORITY = "optional"
+
+DEPENDS = "libpcap jpeg libungif gtk+ libgpewidget"
+PV = "0.1.6"
+
+SRC_URI = "http://www.ex-parrot.com/~chris/driftnet/${PN}-${PV}.tar.gz \
+ file://arm.patch;patch=1"
+
+S = "${WORKDIR}/driftnet-${PV}"
+
+inherit autotools
+
+do_compile() {
+ oe_runmake STAGING_INCDIR="${STAGING_INCDIR}"
+}
+
+do_install() {
+ install -d ${D}/${bindir}
+ install -m 0744 driftnet ${D}/${bindir}/
+}