aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/dsplink/gstreamer-ti_svn.bb
diff options
context:
space:
mode:
authorDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
committerDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
commit709c4d66e0b107ca606941b988bad717c0b45d9b (patch)
tree37ee08b1eb308f3b2b6426d5793545c38396b838 /recipes/dsplink/gstreamer-ti_svn.bb
parentfa6cd5a3b993f16c27de4ff82b42684516d433ba (diff)
downloadopenembedded-709c4d66e0b107ca606941b988bad717c0b45d9b.tar.gz
rename packages/ to recipes/ per earlier agreement
See links below for more details: http://thread.gmane.org/gmane.comp.handhelds.openembedded/21326 http://thread.gmane.org/gmane.comp.handhelds.openembedded/21816 Signed-off-by: Denys Dmytriyenko <denis@denix.org> Acked-by: Mike Westerhof <mwester@dls.net> Acked-by: Philip Balister <philip@balister.org> Acked-by: Khem Raj <raj.khem@gmail.com> Acked-by: Marcin Juszkiewicz <hrw@openembedded.org> Acked-by: Koen Kooi <koen@openembedded.org> Acked-by: Frans Meulenbroeks <fransmeulenbroeks@gmail.com>
Diffstat (limited to 'recipes/dsplink/gstreamer-ti_svn.bb')
-rw-r--r--recipes/dsplink/gstreamer-ti_svn.bb49
1 files changed, 49 insertions, 0 deletions
diff --git a/recipes/dsplink/gstreamer-ti_svn.bb b/recipes/dsplink/gstreamer-ti_svn.bb
new file mode 100644
index 0000000000..bcfaa3458b
--- /dev/null
+++ b/recipes/dsplink/gstreamer-ti_svn.bb
@@ -0,0 +1,49 @@
+DEPENDS = "ti-codec-engine ti-dmai gstreamer gst-plugins-base gst-plugins-good gst-plugins-ugly libid3tag liboil libmad"
+
+SRC_URI = "svn://gforge.ti.com/svn/gstreamer_ti/trunk;module=gstreamer_ti;proto=https;user=anonymous;pswd='' \
+ file://gst-buffsize.diff;patch=1"
+SRCREV = "127"
+
+PR = "r5"
+
+# Again, no '.' in PWD allowed :(
+PV = "0+svnr${SRCREV}"
+
+S = "${WORKDIR}/gstreamer_ti/ti_build/ticodecplugin"
+
+inherit autotools
+
+require ti-paths.inc
+
+export DMAI_INSTALL_DIR = "${STAGING_DIR}/${MULTIMACH_TARGET_SYS}/ti-dmai"
+export CE_INSTALL_DIR="${STAGING_DIR}/${MULTIMACH_TARGET_SYS}/ti-codec-engine"
+export FC_INSTALL_DIR="${STAGING_DIR}/${MULTIMACH_TARGET_SYS}/ti-codec-engine/cetools"
+export CODEC_INSTALL_DIR="${STAGING_DIR}/${MULTIMACH_TARGET_SYS}/ti-codec-combos"
+
+export XDC_TARGET = "gnu.targets.arm.GCArmv5T"
+
+XDC_PLATFORM = "foo"
+# Assume every TI armv7a cpu is a 3530
+XDC_PLATFORM_armv7a = "ti.platforms.evm3530"
+export XDC_PLATFORM
+
+# We need to add this to config.bld:
+#GCArmv5T.cc.$unseal("opts");
+#GCArmv5T.cc.opts = "SEDME_CCARCH";
+#GCArmv5T.cc.$seal("opts");
+
+do_compile_prepend() {
+ for i in $(find ${S} -name "config.bld") ; do
+ sed -i -e s:SEDME_CCARCH:'${TARGET_CCARCH}': $i
+ done
+}
+
+CPPFLAGS_append = " -DPlatform_${PLATFORM}"
+
+PACKAGE_ARCH = "${MACHINE_ARCH}"
+
+RDEPENDS_${PN} = "ti-dmai"
+FILES_${PN} += "${libdir}/gstreamer-0.10/*.so"
+FILES_${PN}-dev += "${libdir}/gstreamer-0.10/*.a ${libdir}/gstreamer-0.10/*.la"
+FILES_${PN}-dbg += "${libdir}/gstreamer-0.10/.debug"
+