aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/dtc
diff options
context:
space:
mode:
authorDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
committerDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
commit709c4d66e0b107ca606941b988bad717c0b45d9b (patch)
tree37ee08b1eb308f3b2b6426d5793545c38396b838 /recipes/dtc
parentfa6cd5a3b993f16c27de4ff82b42684516d433ba (diff)
downloadopenembedded-709c4d66e0b107ca606941b988bad717c0b45d9b.tar.gz
rename packages/ to recipes/ per earlier agreement
See links below for more details: http://thread.gmane.org/gmane.comp.handhelds.openembedded/21326 http://thread.gmane.org/gmane.comp.handhelds.openembedded/21816 Signed-off-by: Denys Dmytriyenko <denis@denix.org> Acked-by: Mike Westerhof <mwester@dls.net> Acked-by: Philip Balister <philip@balister.org> Acked-by: Khem Raj <raj.khem@gmail.com> Acked-by: Marcin Juszkiewicz <hrw@openembedded.org> Acked-by: Koen Kooi <koen@openembedded.org> Acked-by: Frans Meulenbroeks <fransmeulenbroeks@gmail.com>
Diffstat (limited to 'recipes/dtc')
-rw-r--r--recipes/dtc/dtc-native.inc8
-rw-r--r--recipes/dtc/dtc-native_1.1.0.bb6
-rw-r--r--recipes/dtc/dtc-native_1.2.0.bb8
-rw-r--r--recipes/dtc/dtc-native_20070216.bb6
-rw-r--r--recipes/dtc/dtc-native_git.bb6
-rw-r--r--recipes/dtc/dtc.inc12
-rw-r--r--recipes/dtc/dtc_1.1.0.bb8
-rw-r--r--recipes/dtc/dtc_1.2.0.bb10
-rw-r--r--recipes/dtc/dtc_20070216.bb8
-rw-r--r--recipes/dtc/dtc_git.bb8
10 files changed, 80 insertions, 0 deletions
diff --git a/recipes/dtc/dtc-native.inc b/recipes/dtc/dtc-native.inc
new file mode 100644
index 0000000000..838845864d
--- /dev/null
+++ b/recipes/dtc/dtc-native.inc
@@ -0,0 +1,8 @@
+require dtc.inc
+
+inherit native
+
+do_stage() {
+ install -m 755 dtc ${STAGING_BINDIR}/dtc
+}
+
diff --git a/recipes/dtc/dtc-native_1.1.0.bb b/recipes/dtc/dtc-native_1.1.0.bb
new file mode 100644
index 0000000000..650ba2c9f1
--- /dev/null
+++ b/recipes/dtc/dtc-native_1.1.0.bb
@@ -0,0 +1,6 @@
+require dtc-native.inc
+
+SRC_URI = "http://www.jdl.com/software/dtc-v${PV}.tgz"
+
+S = "${WORKDIR}/dtc-v${PV}"
+
diff --git a/recipes/dtc/dtc-native_1.2.0.bb b/recipes/dtc/dtc-native_1.2.0.bb
new file mode 100644
index 0000000000..7d90b2670b
--- /dev/null
+++ b/recipes/dtc/dtc-native_1.2.0.bb
@@ -0,0 +1,8 @@
+require dtc-native.inc
+
+DEFAULT_PREFERENCE = "1"
+
+SRC_URI = "http://www.jdl.com/software/dtc-v${PV}.tgz"
+
+S = "${WORKDIR}/dtc-v${PV}"
+
diff --git a/recipes/dtc/dtc-native_20070216.bb b/recipes/dtc/dtc-native_20070216.bb
new file mode 100644
index 0000000000..7087444823
--- /dev/null
+++ b/recipes/dtc/dtc-native_20070216.bb
@@ -0,0 +1,6 @@
+require dtc-native.inc
+
+SRC_URI = "http://www.jdl.com/pub/software/dtc-${PV}.tgz"
+
+S = "${WORKDIR}/dtc"
+
diff --git a/recipes/dtc/dtc-native_git.bb b/recipes/dtc/dtc-native_git.bb
new file mode 100644
index 0000000000..9c93a4a1fa
--- /dev/null
+++ b/recipes/dtc/dtc-native_git.bb
@@ -0,0 +1,6 @@
+require dtc-native.inc
+
+SRC_URI = "git://www.jdl.com/software/dtc.git;protocol=git"
+
+S = "${WORKDIR}/git"
+
diff --git a/recipes/dtc/dtc.inc b/recipes/dtc/dtc.inc
new file mode 100644
index 0000000000..4bf1bc8ed1
--- /dev/null
+++ b/recipes/dtc/dtc.inc
@@ -0,0 +1,12 @@
+DESCRIPTION = "The Device Tree Compiler is a tool used to manipulate the Open-Firmware-like device tree used by PowerPC kernels."
+SECTION = "bootloader"
+PRIORITY = "optional"
+LICENSE = "GPL"
+
+inherit autotools
+
+do_install() {
+ install -m 0755 -d ${D}${bindir}
+ install -m 755 dtc ${D}${bindir}/dtc
+}
+
diff --git a/recipes/dtc/dtc_1.1.0.bb b/recipes/dtc/dtc_1.1.0.bb
new file mode 100644
index 0000000000..7cdccec066
--- /dev/null
+++ b/recipes/dtc/dtc_1.1.0.bb
@@ -0,0 +1,8 @@
+require dtc.inc
+
+PR = "r1"
+
+SRC_URI = "http://www.jdl.com/software/dtc-v${PV}.tgz"
+
+S = "${WORKDIR}/dtc-v${PV}"
+
diff --git a/recipes/dtc/dtc_1.2.0.bb b/recipes/dtc/dtc_1.2.0.bb
new file mode 100644
index 0000000000..a1feeb75be
--- /dev/null
+++ b/recipes/dtc/dtc_1.2.0.bb
@@ -0,0 +1,10 @@
+require dtc.inc
+
+PR = "r0"
+
+DEFAULT_PREFERENCE = "1"
+
+SRC_URI = "http://www.jdl.com/software/dtc-v${PV}.tgz"
+
+S = "${WORKDIR}/dtc-v${PV}"
+
diff --git a/recipes/dtc/dtc_20070216.bb b/recipes/dtc/dtc_20070216.bb
new file mode 100644
index 0000000000..8e66b4fc54
--- /dev/null
+++ b/recipes/dtc/dtc_20070216.bb
@@ -0,0 +1,8 @@
+require dtc.inc
+
+PR = "r1"
+
+SRC_URI = "http://www.jdl.com/pub/software/dtc-${PV}.tgz"
+
+S = "${WORKDIR}/dtc"
+
diff --git a/recipes/dtc/dtc_git.bb b/recipes/dtc/dtc_git.bb
new file mode 100644
index 0000000000..638d472898
--- /dev/null
+++ b/recipes/dtc/dtc_git.bb
@@ -0,0 +1,8 @@
+require dtc.inc
+
+PR = "r1"
+
+SRC_URI = "git://www.jdl.com/software/dtc.git;protocol=git"
+
+S = "${WORKDIR}/git"
+