aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/dtnrg/dtn_2.5.0.bb
diff options
context:
space:
mode:
authorDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
committerDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
commit709c4d66e0b107ca606941b988bad717c0b45d9b (patch)
tree37ee08b1eb308f3b2b6426d5793545c38396b838 /recipes/dtnrg/dtn_2.5.0.bb
parentfa6cd5a3b993f16c27de4ff82b42684516d433ba (diff)
downloadopenembedded-709c4d66e0b107ca606941b988bad717c0b45d9b.tar.gz
rename packages/ to recipes/ per earlier agreement
See links below for more details: http://thread.gmane.org/gmane.comp.handhelds.openembedded/21326 http://thread.gmane.org/gmane.comp.handhelds.openembedded/21816 Signed-off-by: Denys Dmytriyenko <denis@denix.org> Acked-by: Mike Westerhof <mwester@dls.net> Acked-by: Philip Balister <philip@balister.org> Acked-by: Khem Raj <raj.khem@gmail.com> Acked-by: Marcin Juszkiewicz <hrw@openembedded.org> Acked-by: Koen Kooi <koen@openembedded.org> Acked-by: Frans Meulenbroeks <fransmeulenbroeks@gmail.com>
Diffstat (limited to 'recipes/dtnrg/dtn_2.5.0.bb')
-rw-r--r--recipes/dtnrg/dtn_2.5.0.bb67
1 files changed, 67 insertions, 0 deletions
diff --git a/recipes/dtnrg/dtn_2.5.0.bb b/recipes/dtnrg/dtn_2.5.0.bb
new file mode 100644
index 0000000000..7dc6fc5af8
--- /dev/null
+++ b/recipes/dtnrg/dtn_2.5.0.bb
@@ -0,0 +1,67 @@
+DESCRIPTION = "Delay Tolerant Networking Package"
+HOMEPAGE = "http://www.dtnrg.org/wiki"
+SECTION = "libs"
+DEPENDS = "db openssl python-native xerces-c"
+LICENSE = "Apache"
+PR = "r5"
+
+# thread code atomic ops do not play with thumb
+ARM_INSTRUCTION_SET = "arm"
+
+SRC_URI = "\
+ http://www.dtnrg.org/docs/code/dtn_${PV}.tgz \
+ file://configure_fix.patch;patch=1 \
+"
+
+inherit autotools distutils-base
+
+EXTRA_OECONF = "\
+ --with-python=${STAGING_BINDIR_NATIVE}/python \
+ --with-db=${STAGING_DIR_HOST}${layout_exec_prefix} \
+ --with-tcl=${STAGING_DIR_HOST}${layout_exec_prefix} \
+ --without-google-perftools \
+ --without-bluez \
+ --without-bonjour \
+ --with-expat=${STAGING_DIR_HOST}${layout_exec_prefix} \
+ --with-xerces-c=${STAGING_DIR_HOST}${layout_exec_prefix} \
+ --without-tclreadline \
+ --with-zlib=${STAGING_DIR_HOST}${layout_exec_prefix} \
+ --without-xsd-tool \
+ --with-db=${STAGING_DIR_HOST}${layout_exec_prefix} \
+ --enable-ecl \
+ --enable-edp \
+ --without-mysql \
+ --without-postgres \
+ --with-openssl=${STAGING_DIR_HOST}${layout_exec_prefix} \
+"
+
+export BUILD_SYS
+export HOST_SYS
+
+do_configure_prepend() {
+ for i in aclocal/*.ac oasys/aclocal/*.ac; do
+ install -m 0644 $i ${STAGING_DATADIR}/aclocal/`basename $i`.m4
+ done
+ autotools_do_configure
+}
+
+do_install_append() {
+ cd applib/python
+ INCDIR=../.. LIBDIR=.. VERSION=${PV} python setup.py install --prefix=${D}/${prefix} --install-data=${D}/${datadir}
+}
+
+PACKAGES =+ "${PN}-lib"
+FILES_${PN}-lib = "${libdir}/*.so*"
+PACKAGES += "python-dtn"
+DESCRIPTION_python-dtn = "Python bindings to the DTN API"
+PR_python-dtn = "ml4"
+FILES_python-dtn = "${libdir}/${PYTHON_DIR}"
+RDEPENDS_python-dtn = "python-core dtn-lib"
+
+FILES_${PN}-dbg += "\
+ ${libdir}/${PYTHON_DIR}/site-packages/.debug \
+ ${libdir}/.debug \
+ ${bindir}/.debug \
+"
+
+FILES_${PN} += "${sysconfdir}"