aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/e17
diff options
context:
space:
mode:
authorMartin Jansa <Martin.Jansa@gmail.com>2011-01-12 10:04:08 +0100
committerMartin Jansa <Martin.Jansa@gmail.com>2011-01-12 10:11:55 +0100
commit5511dc1939be3264f9d3f5c7bda0accaa85c6e29 (patch)
tree504c8ac328d2991c3f826ef2124aa967d74aa5f7 /recipes/e17
parentf578c96b877da0ba557921ccc510f50b4e0a334e (diff)
downloadopenembedded-5511dc1939be3264f9d3f5c7bda0accaa85c6e29.tar.gz
elmdentica: add patch for azy api change from r56034
Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'recipes/e17')
-rw-r--r--recipes/e17/elmdentica/elmdentica.azy.api.change.r56034.patch31
-rw-r--r--recipes/e17/elmdentica_svn.bb4
2 files changed, 34 insertions, 1 deletions
diff --git a/recipes/e17/elmdentica/elmdentica.azy.api.change.r56034.patch b/recipes/e17/elmdentica/elmdentica.azy.api.change.r56034.patch
new file mode 100644
index 0000000000..6104119fad
--- /dev/null
+++ b/recipes/e17/elmdentica/elmdentica.azy.api.change.r56034.patch
@@ -0,0 +1,31 @@
+diff --git a/src/statusnet.c b/src/statusnet.c
+index 136e985..cdda89b 100644
+--- a/src/statusnet.c
++++ b/src/statusnet.c
+@@ -666,7 +666,7 @@ static void Array_statusnet_Status_free(Eina_List *array) {
+ Eina_Bool timeline_connected(void *data, int type, Azy_Client *cli) {
+ Azy_Client_Call_Id id;
+
+- id = azy_client_blank(cli, AZY_NET_TYPE_GET, NULL, (Azy_Content_Cb)azy_value_to_Array_statusnet_Status, NULL);
++ id = azy_client_blank(cli, AZY_NET_TYPE_GET, (Azy_Content_Cb)azy_value_to_Array_statusnet_Status, NULL);
+ azy_client_callback_free_set(cli, id, (Ecore_Cb)Array_statusnet_Status_free);
+
+ return(EINA_TRUE);
+@@ -927,7 +927,7 @@ Eina_Bool ed_statusnet_userget_returned(Azy_Client *cli, int type, Azy_Client *e
+ Eina_Bool ed_statusnet_userget_connected(Azy_Client *cli, int type, Azy_Client *ev) {
+ Azy_Client_Call_Id id;
+
+- id = azy_client_blank(ev, AZY_NET_TYPE_GET, NULL, (Azy_Content_Cb)ed_sn_userget_parse, NULL);
++ id = azy_client_blank(ev, AZY_NET_TYPE_GET, (Azy_Content_Cb)ed_sn_userget_parse, NULL);
+ if(!id) return(EINA_FALSE);
+
+ azy_client_callback_free_set(ev, id, (Ecore_Cb)ed_sn_single_user_free);
+@@ -1044,7 +1044,7 @@ Eina_Bool ed_statusnet_repeat_disconnected(Azy_Client *cli, int type, Azy_Client
+ Eina_Bool ed_statusnet_repeat_connected(Azy_Client *cli, int type, Azy_Client *ev) {
+ Azy_Client_Call_Id id;
+
+- id = azy_client_blank(ev, AZY_NET_TYPE_POST, NULL, (Azy_Content_Cb)azy_value_to_Array_statusnet_Status, NULL);
++ id = azy_client_blank(ev, AZY_NET_TYPE_POST, (Azy_Content_Cb)azy_value_to_Array_statusnet_Status, NULL);
+ if(!id) return(EINA_FALSE);
+
+ azy_client_callback_free_set(ev, id, (Ecore_Cb)ed_sn_single_status_free);
diff --git a/recipes/e17/elmdentica_svn.bb b/recipes/e17/elmdentica_svn.bb
index 84428d3f50..ec6a246e7b 100644
--- a/recipes/e17/elmdentica_svn.bb
+++ b/recipes/e17/elmdentica_svn.bb
@@ -9,8 +9,10 @@ inherit e gettext
EXTRA_OECONF = "--with-edje-cc=${STAGING_BINDIR_NATIVE}/edje_cc"
+SRC_URI += "file://elmdentica.azy.api.change.r56034.patch"
+
PV = "0.9.9+svnr${SRCPV}"
-PR = "r2"
+PR = "r3"
SRCREV = "${EFL_SRCREV}"
RDEPENDS_${PN} = "${PN}-themes"