aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/e17
diff options
context:
space:
mode:
authorMartin Jansa <Martin.Jansa@gmail.com>2011-01-28 09:58:11 +0100
committerMartin Jansa <Martin.Jansa@gmail.com>2011-01-29 18:56:31 +0100
commite9db428726e47c09da468c54b4b6a414e5927b01 (patch)
tree178fdd8420ed8edf24417eaa0202e735dcd800cb /recipes/e17
parent8b17aa1c0bb1cbcb25bd178e790b78fe37a306e9 (diff)
downloadopenembedded-e9db428726e47c09da468c54b4b6a414e5927b01.tar.gz
e-base: prepare for releases
* bump EFL_SRCREV a bit to current HEAD * introduce EFL_SRCREV_1.0.0 for recipes which don't need SRCREV change so often like stuff from OLD and BROKEN dirs and themes * move SRC_URI and S settings from bbclass to svn recipes * replace E_CVS and E_URI with E_SVN and E_MIRROR * PV/PR will be updated in following patches for individual recipes Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'recipes/e17')
-rw-r--r--recipes/e17/e-module.inc2
-rw-r--r--recipes/e17/e-wm-theme-illume-efenniht_svn.bb5
-rw-r--r--recipes/e17/e-wm_svn.bb3
-rw-r--r--recipes/e17/edje-viewer_svn.bb2
-rw-r--r--recipes/e17/elementary-alarm_svn.bb5
-rw-r--r--recipes/e17/elmdentica_svn.bb2
-rw-r--r--recipes/e17/emprint_svn.bb7
-rw-r--r--recipes/e17/enjoy_svn.bb3
-rw-r--r--recipes/e17/entrance_0.9.0.010.bb2
-rw-r--r--recipes/e17/eve_svn.bb2
-rw-r--r--recipes/e17/exalt_svn.bb2
-rw-r--r--recipes/e17/expedite_svn.bb2
-rw-r--r--recipes/e17/exquisite-theme-illume.bb5
-rw-r--r--recipes/e17/exquisite_svn.bb2
-rw-r--r--recipes/e17/rage_svn.bb2
-rw-r--r--recipes/e17/waker_svn.bb4
16 files changed, 35 insertions, 15 deletions
diff --git a/recipes/e17/e-module.inc b/recipes/e17/e-module.inc
index a620746b32..185c841b10 100644
--- a/recipes/e17/e-module.inc
+++ b/recipes/e17/e-module.inc
@@ -7,6 +7,8 @@ SRCREV = "${EFL_SRCREV}"
SRCNAME = "E-MODULES-EXTRA/${PN}"
inherit e
+SRC_URI = "${E_SVN}/trunk;module=${SRCNAME};proto=http;scmdata=keep"
+S = "${WORKDIR}/${SRCNAME}"
EXTRA_OECONF = "--with-edje-cc=${STAGING_BINDIR_NATIVE}/edje_cc"
diff --git a/recipes/e17/e-wm-theme-illume-efenniht_svn.bb b/recipes/e17/e-wm-theme-illume-efenniht_svn.bb
index 2e207841ec..60df58248d 100644
--- a/recipes/e17/e-wm-theme-illume-efenniht_svn.bb
+++ b/recipes/e17/e-wm-theme-illume-efenniht_svn.bb
@@ -7,13 +7,14 @@ RSUGGESTS_${PN} = "elementary-theme-efenniht"
PACKAGE_ARCH = "all"
LICENSE = "MIT/BSD"
-SRCREV = "${EFL_SRCREV}"
+SRCREV = "${EFL_SRCREV_1.0.0}"
PV = "0.0+svnr${SRCPV}"
inherit e-base
SRCNAME = "efenniht"
-SRC_URI = "svn://svn.enlightenment.org/svn/e/trunk/THEMES;module=${SRCNAME};proto=http"
+SRC_URI = "${E_SVN}/trunk/THEMES;module=${SRCNAME};proto=http"
+S = "${WORKDIR}/${SRCNAME}"
do_compile() {
${STAGING_BINDIR_NATIVE}/edje_cc -id ${S}/images ${S}/efenniht.edc -o ${S}/efenniht.edj
diff --git a/recipes/e17/e-wm_svn.bb b/recipes/e17/e-wm_svn.bb
index 397272d35f..9c9f0e11cb 100644
--- a/recipes/e17/e-wm_svn.bb
+++ b/recipes/e17/e-wm_svn.bb
@@ -8,7 +8,8 @@ SRCREV = "${EFL_SRCREV}"
inherit e update-alternatives
-SRC_URI += "\
+SRC_URI = "\
+ ${E_SVN}/trunk;module=${SRCNAME};proto=http \
file://enlightenment_start.oe \
file://applications.menu \
file://gsm-segfault-fix.patch;maxrev=37617 \
diff --git a/recipes/e17/edje-viewer_svn.bb b/recipes/e17/edje-viewer_svn.bb
index c57579606f..30565407d0 100644
--- a/recipes/e17/edje-viewer_svn.bb
+++ b/recipes/e17/edje-viewer_svn.bb
@@ -8,5 +8,7 @@ SRCREV = "${EFL_SRCREV}"
inherit e
SRCNAME = "edje_viewer"
+SRC_URI = "${E_SVN}/trunk;module=${SRCNAME};proto=http;scmdata=keep"
+S = "${WORKDIR}/${SRCNAME}"
FILES_${PN} += "${datadir}"
diff --git a/recipes/e17/elementary-alarm_svn.bb b/recipes/e17/elementary-alarm_svn.bb
index 24bbd60945..c930a0c145 100644
--- a/recipes/e17/elementary-alarm_svn.bb
+++ b/recipes/e17/elementary-alarm_svn.bb
@@ -7,9 +7,8 @@ PR = "r2"
SRCREV = "${EFL_SRCREV}"
inherit e
-
-SRC_URI = "svn://svn.enlightenment.org/svn/e/trunk/TMP/st;module=elementary-alarm;proto=http"
-S = "${WORKDIR}/elementary-alarm"
+SRC_URI = "${E_SVN}/trunk/TMP/st;module=${SRCNAME};proto=http;scmdata=keep"
+S = "${WORKDIR}/${SRCNAME}"
RDEPENDS_${PN} = "waker"
FILES_${PN} += "${bindir}/*"
diff --git a/recipes/e17/elmdentica_svn.bb b/recipes/e17/elmdentica_svn.bb
index 3657f7f222..013a7ded01 100644
--- a/recipes/e17/elmdentica_svn.bb
+++ b/recipes/e17/elmdentica_svn.bb
@@ -6,6 +6,8 @@ HOMEPAGE = "http://elmdentica.googlecode.com"
AUTHOR = "seabra"
inherit e gettext
+SRC_URI = "${E_SVN}/trunk;module=${SRCNAME};proto=http;scmdata=keep"
+S = "${WORKDIR}/${SRCNAME}"
EXTRA_OECONF = "--with-edje-cc=${STAGING_BINDIR_NATIVE}/edje_cc"
diff --git a/recipes/e17/emprint_svn.bb b/recipes/e17/emprint_svn.bb
index 7f63083400..31c744da2a 100644
--- a/recipes/e17/emprint_svn.bb
+++ b/recipes/e17/emprint_svn.bb
@@ -2,11 +2,10 @@ DESCRIPTION = "Emprint is a utility for taking screenshots of the entire screen,
LICENSE = "MIT BSD"
DEPENDS = "imlib2 virtual/libx11 ecore evas edje eina"
PV = "0.0.1+svnr${SRCPV}"
+SRCREV = "${EFL_SRCREV}"
inherit e
-
-SRCREV = "${EFL_SRCREV}"
-SRC_URI = "svn://svn.enlightenment.org/svn/e/trunk/;module=emprint;proto=http"
-S = "${WORKDIR}/emprint"
+SRC_URI = "${E_SVN}/trunk;module=${SRCNAME};proto=http;scmdata=keep"
+S = "${WORKDIR}/${SRCNAME}"
FILES_${PN}-dbg += "${libdir}/${PN}/modules/.debug"
diff --git a/recipes/e17/enjoy_svn.bb b/recipes/e17/enjoy_svn.bb
index 97b110c9f7..eab81b4c5a 100644
--- a/recipes/e17/enjoy_svn.bb
+++ b/recipes/e17/enjoy_svn.bb
@@ -21,7 +21,8 @@ RDEPENDS += "\
"
inherit e
-
+SRC_URI = "${E_SVN}/trunk;module=${SRCNAME};proto=http;scmdata=keep"
+S = "${WORKDIR}/${SRCNAME}"
EXTRA_OECONF = "\
--with-edje-cc=${STAGING_BINDIR_NATIVE}/edje_cc \
diff --git a/recipes/e17/entrance_0.9.0.010.bb b/recipes/e17/entrance_0.9.0.010.bb
index e72e4a6acc..605f0bffd1 100644
--- a/recipes/e17/entrance_0.9.0.010.bb
+++ b/recipes/e17/entrance_0.9.0.010.bb
@@ -9,6 +9,8 @@ PR = "r3"
SRCREV = "46589"
inherit e
+SRC_URI = "${E_SVN}/trunk;module=${SRCNAME};proto=http;scmdata=keep"
+S = "${WORKDIR}/${SRCNAME}"
SRC_URI += "\
file://rebased_config-db.patch \
diff --git a/recipes/e17/eve_svn.bb b/recipes/e17/eve_svn.bb
index 66e5add2a5..d7f93e9907 100644
--- a/recipes/e17/eve_svn.bb
+++ b/recipes/e17/eve_svn.bb
@@ -5,6 +5,8 @@ PV = "0.3.0.0+svnr${SRCPV}"
SRCREV = "${EFL_SRCREV}"
inherit e
+SRC_URI = "${E_SVN}/trunk;module=${SRCNAME};proto=http;scmdata=keep"
+S = "${WORKDIR}/${SRCNAME}"
SRC_URI += "file://eve-theme-for-smaller-screens.patch"
diff --git a/recipes/e17/exalt_svn.bb b/recipes/e17/exalt_svn.bb
index 4696b72175..712204fba6 100644
--- a/recipes/e17/exalt_svn.bb
+++ b/recipes/e17/exalt_svn.bb
@@ -10,6 +10,8 @@ SRCREV = "${EFL_SRCREV}"
PR = "r1"
inherit e
+SRC_URI = "${E_SVN}/trunk;module=${SRCNAME};proto=http;scmdata=keep"
+S = "${WORKDIR}/${SRCNAME}"
EXTRA_OECONF = " \
--with-wpa_supplicant=${sbindir}/wpa_supplicant \
diff --git a/recipes/e17/expedite_svn.bb b/recipes/e17/expedite_svn.bb
index efb11455a2..47b5f486d1 100644
--- a/recipes/e17/expedite_svn.bb
+++ b/recipes/e17/expedite_svn.bb
@@ -7,6 +7,8 @@ PR = "r5"
SRCREV = "${EFL_SRCREV}"
inherit e
+SRC_URI = "${E_SVN}/trunk;module=${SRCNAME};proto=http;scmdata=keep"
+S = "${WORKDIR}/${SRCNAME}"
EXTRA_OECONF = "\
--x-includes=${STAGING_INCDIR}/X11 \
diff --git a/recipes/e17/exquisite-theme-illume.bb b/recipes/e17/exquisite-theme-illume.bb
index b15a8b59b2..c12405b81b 100644
--- a/recipes/e17/exquisite-theme-illume.bb
+++ b/recipes/e17/exquisite-theme-illume.bb
@@ -4,7 +4,7 @@ SECTION = "x11"
DEPENDS = "edje-native"
PV = "1.0+svnr${SRCPV}"
PR = "r6"
-SRCREV = "${EFL_SRCREV}"
+SRCREV = "${EFL_SRCREV_1.0.0}"
inherit e-base update-alternatives
@@ -15,7 +15,8 @@ ALTERNATIVE_PRIORITY = "10"
SRCNAME = "b_and_w"
-SRC_URI = "svn://svn.enlightenment.org/svn/e/trunk/THEMES;module=${SRCNAME};proto=http"
+SRC_URI = "${E_SVN}/trunk/THEMES;module=${SRCNAME};proto=http"
+S = "${WORKDIR}/${SRCNAME}"
do_compile() {
${STAGING_BINDIR_NATIVE}/edje_cc exquisite.edc illume.edj
diff --git a/recipes/e17/exquisite_svn.bb b/recipes/e17/exquisite_svn.bb
index d323c12515..fcfb65cf8f 100644
--- a/recipes/e17/exquisite_svn.bb
+++ b/recipes/e17/exquisite_svn.bb
@@ -10,6 +10,8 @@ RCONFLICTS_${PN} = "psplash virtual-psplash"
SRCNAME = "exquisite"
inherit e
+SRC_URI = "${E_SVN}/trunk;module=${SRCNAME};proto=http;scmdata=keep"
+S = "${WORKDIR}/${SRCNAME}"
EXTRA_OECONF = "--with-edje-cc=${STAGING_BINDIR_NATIVE}/edje_cc"
diff --git a/recipes/e17/rage_svn.bb b/recipes/e17/rage_svn.bb
index edf6e699d1..28239876de 100644
--- a/recipes/e17/rage_svn.bb
+++ b/recipes/e17/rage_svn.bb
@@ -8,3 +8,5 @@ PV = "0.3.0.042+svnr${SRCPV}"
SRCREV = "${EFL_SRCREV}"
inherit e
+SRC_URI = "${E_SVN}/trunk;module=${SRCNAME};proto=http;scmdata=keep"
+S = "${WORKDIR}/${SRCNAME}"
diff --git a/recipes/e17/waker_svn.bb b/recipes/e17/waker_svn.bb
index b1707d4f98..73e7235218 100644
--- a/recipes/e17/waker_svn.bb
+++ b/recipes/e17/waker_svn.bb
@@ -8,8 +8,8 @@ SRCREV = "${EFL_SRCREV}"
inherit efl
-SRC_URI = "svn://svn.enlightenment.org/svn/e/trunk/TMP/st;module=waker;proto=http"
-S = "${WORKDIR}/waker"
+SRC_URI = "${E_SVN}/trunk/TMP/st;module=${SRCNAME};proto=http"
+S = "${WORKDIR}/${SRCNAME}"
FILES_${PN} += "${bindir}/* ${libdir}/lib*.so.*"
FILES_${PN} += "/etc/X11/Xsession.d/80x-enlightenment-wakerd"