aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/e17
diff options
context:
space:
mode:
authorMartin Jansa <Martin.Jansa@gmail.com>2010-06-02 15:04:25 +0200
committerMartin Jansa <Martin.Jansa@gmail.com>2010-06-03 07:33:27 +0200
commitd4276bed389b7db06db58c7acebb83f92bff86a5 (patch)
tree2386574b6ab0c36a58a314a24d31f6b5c9291a65 /recipes/e17
parent823aa270059259ca619e21a5d9b22e86afb12f3b (diff)
downloadopenembedded-d4276bed389b7db06db58c7acebb83f92bff86a5.tar.gz
recipes: conform to OE packaging guidelines with RDEPENDS/RRECOMMENDS
* there is probably very few cases when it's needed without _${PN}, if you find one in attached patch, please enlighten me * usually we want those only for ${PN} not for all ${PACKAGES} ie ${PN}-dev, ${PN)-doc etc * there is a check for this in recipe-sanity.bclass * there is maybe few possible fixes also in bbclasses cpan-base.bbclass:RDEPENDS += "${@["perl", ""][(bb.data.inherits_class('native', d))]}" distutils-base.bbclass:RDEPENDS += "python-core" gtk-icon-cache.bbclass:RDEPENDS += "hicolor-icon-theme" image.bbclass:RDEPENDS += "${IMAGE_INSTALL} ${IMAGE_BOOT}" module.bbclass:RDEPENDS += "kernel (${KERNEL_VERSION}) update-modules" ?opie_i18n.bbclass: rdepends = bb.data.getVar("RDEPENDS", d, 1) ?opie_i18n.bbclass: bb.data.setVar('RDEPENDS_%s' % x[0].lower(), pn, d) ?opie_i18n.bbclass: bb.data.setVar('RDEPENDS', rdepends, d) rubyextension.bbclass:RDEPENDS += "ruby" Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com> Acked-by: Koen Kooi <k-kooi@ti.com>
Diffstat (limited to 'recipes/e17')
-rw-r--r--recipes/e17/elementary-alarm_svn.bb2
-rw-r--r--recipes/e17/entrance_0.9.0.010.bb2
-rw-r--r--recipes/e17/exalt_svn.bb2
-rw-r--r--recipes/e17/expedite_svn.bb2
-rw-r--r--recipes/e17/exquisite_svn.bb2
5 files changed, 5 insertions, 5 deletions
diff --git a/recipes/e17/elementary-alarm_svn.bb b/recipes/e17/elementary-alarm_svn.bb
index 9fee65dc98..8635959075 100644
--- a/recipes/e17/elementary-alarm_svn.bb
+++ b/recipes/e17/elementary-alarm_svn.bb
@@ -11,7 +11,7 @@ inherit e
SRC_URI = "svn://svn.enlightenment.org/svn/e/trunk/TMP/st;module=elementary-alarm;proto=http"
S = "${WORKDIR}/elementary-alarm"
-RDEPENDS = "waker"
+RDEPENDS_${PN} = "waker"
FILES_${PN} += "${bindir}/*"
FILES_${PN} += "${datadir}/${PN}"
FILES_${PN} += "${datadir}/icons/*"
diff --git a/recipes/e17/entrance_0.9.0.010.bb b/recipes/e17/entrance_0.9.0.010.bb
index 92c235b23b..1ef9abe696 100644
--- a/recipes/e17/entrance_0.9.0.010.bb
+++ b/recipes/e17/entrance_0.9.0.010.bb
@@ -2,7 +2,7 @@ DESCRIPTION = "Entrance is the Enlightenment login manager"
LICENSE = "MIT BSD"
# can also use pam and crypt
DEPENDS = "evas ecore edje esmart bash keylaunch xserver-common login-manager"
-RDEPENDS += "glibc-gconv-iso8859-1 entrance-themes"
+RDEPENDS_${PN} += "glibc-gconv-iso8859-1 entrance-themes"
PR = "r2"
# entrance and estickies were removed in 46590 for rewrite, move back to EFL_SRCREV when they're back
diff --git a/recipes/e17/exalt_svn.bb b/recipes/e17/exalt_svn.bb
index 4e9f39f9cc..11175b70a5 100644
--- a/recipes/e17/exalt_svn.bb
+++ b/recipes/e17/exalt_svn.bb
@@ -3,7 +3,7 @@ HOMEPAGE = "http://watchwolf.fr/wiki/doku.php?id=exalt"
LICENSE = "LGPLv2"
DEPENDS = "elementary vpnc wpa-supplicant ecore eet edbus"
-RDEPENDS = "vpnc wpa-supplicant"
+RDEPENDS_${PN} = "vpnc wpa-supplicant"
PV = "0.9+svnr${SRCPV}"
SRCREV = "${EFL_SRCREV}"
diff --git a/recipes/e17/expedite_svn.bb b/recipes/e17/expedite_svn.bb
index f5c26e31a9..31b43cda1c 100644
--- a/recipes/e17/expedite_svn.bb
+++ b/recipes/e17/expedite_svn.bb
@@ -1,6 +1,6 @@
DESCRIPTION = "Expedite is a comprehensive benchmarking suite for Evas"
DEPENDS = "eet evas"
-RDEPENDS = "expedite-themes evas-engine-buffer evas-engine-fb evas-engine-software-generic evas-engine-software-x11 evas-loader-png"
+RDEPENDS_${PN} = "expedite-themes evas-engine-buffer evas-engine-fb evas-engine-software-generic evas-engine-software-x11 evas-loader-png"
LICENSE = "MIT BSD"
PV = "0.6.0+svnr${SRCPV}"
PR = "r3"
diff --git a/recipes/e17/exquisite_svn.bb b/recipes/e17/exquisite_svn.bb
index 256b5bde13..f9f55e577f 100644
--- a/recipes/e17/exquisite_svn.bb
+++ b/recipes/e17/exquisite_svn.bb
@@ -4,7 +4,7 @@ DEPENDS = "eet evas ecore embryo edje"
PV = "0.0.1+svnr${SRCPV}"
PR = "r9"
SRCREV = "${EFL_SRCREV}"
-RDEPENDS = "initscripts"
+RDEPENDS_${PN} = "initscripts"
RRECOMMENDS_${PN} = "exquisite-themes"
RCONFLICTS_${PN} = "psplash virtual-psplash"