aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/e17
diff options
context:
space:
mode:
authorCarsten Haitzler (Rasterman <raster@rasterman.com>2009-04-17 15:44:58 +1000
committerCarsten Haitzler (Rasterman) <raster@rasterman.com>2009-04-17 15:48:45 +1000
commit212e36417ae27e1be11147168b6f5cdfd1c5eda9 (patch)
tree00892cc3bca94534140f1e44ab98b4e58587410c /recipes/e17
parentd92391844e4454ba9ea3af5b4273721496511ebb (diff)
downloadopenembedded-212e36417ae27e1be11147168b6f5cdfd1c5eda9.tar.gz
angstrom, exquisite, psplash, opkg, angsrtom-images, sysvinit: abstract splash
this abstracts psplash to be generic. now as long as something provides a splashfuncs file that sysvinit (and other scripts) can source, and all the approproate init hooks to start the splash etc. you can use psplash, exquisitie, usplash or anything that tickles your fancy. this moves splash toa ${SPLASH} variable to include in your image (or override). the default in angstrom is psplash - unless you override it. opkg also runs a configure script that cna take forever - and so this speically sends off some splash commands (if there) to let you know the systme is alive and working (but just busy). this is one commit as if this breaks things you either want to fix the minor break or totally revert the whole patch. i hope it didn't break anything.
Diffstat (limited to 'recipes/e17')
-rw-r--r--recipes/e17/exquisite/exquisite-init10
-rw-r--r--recipes/e17/exquisite/splashfuncs29
-rw-r--r--recipes/e17/exquisite_svn.bb14
3 files changed, 44 insertions, 9 deletions
diff --git a/recipes/e17/exquisite/exquisite-init b/recipes/e17/exquisite/exquisite-init
index 1750184842..2de6774ffb 100644
--- a/recipes/e17/exquisite/exquisite-init
+++ b/recipes/e17/exquisite/exquisite-init
@@ -28,13 +28,13 @@ case `machine_id` in
esac
args=$args" $FPS $THEME"
-export EXDIR=/mnt/.exquisite
+export EXDIR=/mnt/.splash
export EXQUISITE_IPC=$EXDIR/exquisite
mount tmpfs -t tmpfs $EXDIR -o,size=40k
exquisite -fb -fs $args &
-exquisite-write -wait 40
+exquisite-write -wait 120
exquisite-write "PULSATE"
-
-# kill off exquisite in 300 seconds if its not gone yet
-(sleep 300; exquisite-write "QUIT")&
+setterm -blank 0
+setterm -powersave off
+setterm -powerdown 0
diff --git a/recipes/e17/exquisite/splashfuncs b/recipes/e17/exquisite/splashfuncs
new file mode 100644
index 0000000000..ada2a96dd4
--- /dev/null
+++ b/recipes/e17/exquisite/splashfuncs
@@ -0,0 +1,29 @@
+status() {
+ if type splash-write >/dev/null 2>&1; then
+ (TMPDIR="/mnt/.splash" EXQUISITE_IPC="$TMPDIR/exquisite" splash-write "$1" || true) &
+ fi
+}
+
+status_position() {
+ status "PROGRESS $1"
+}
+
+status_title() {
+ status "TITLE $1"
+}
+
+status_text() {
+ if test -n "$1"; then
+ status "MSG $1"
+ else
+ status "CLEAR"
+ fi
+}
+
+status_pulse() {
+ status "PULSATE"
+}
+
+status_tick() {
+ status "TICK"
+}
diff --git a/recipes/e17/exquisite_svn.bb b/recipes/e17/exquisite_svn.bb
index e303600d58..ac4c6b57d4 100644
--- a/recipes/e17/exquisite_svn.bb
+++ b/recipes/e17/exquisite_svn.bb
@@ -2,9 +2,10 @@ DESCRIPTION = "A psplash replacement for display"
LICENSE = "MIT BSD"
DEPENDS = "eet evas ecore embryo edje"
PV = "0.0.1+svnr${SRCREV}"
-PR = "r3"
+PR = "r8"
RDEPENDS = "initscripts"
RRECOMMENDS_${PN} = "exquisite-themes"
+RCONFLICTS_${PN} = "psplash virtual/psplash"
SRCNAME = "exquisite"
@@ -13,13 +14,18 @@ inherit e
EXTRA_OECONF = "--with-edje-cc=${STAGING_BINDIR_NATIVE}/edje_cc"
SRC_URI += "file://exquisite-init"
+SRC_URI += "file://splashfuncs"
inherit update-rc.d
do_install_prepend() {
- install -d ${D}/mnt/.exquisite/
- install -d ${D}${sysconfdir}/init.d/
+ install -d ${D}/mnt/.splash/
+ install -d ${D}${sysconfdir}/init.d
install -m 0755 ${WORKDIR}/exquisite-init ${D}${sysconfdir}/init.d/exquisite
+ install -d ${D}${sysconfdir}/default
+ install -m 0755 ${WORKDIR}/splashfuncs ${D}${sysconfdir}/default/splashfuncs
+ install -d ${D}${bindir}
+ ln -s exquisite-write ${D}${bindir}/splash-write
}
@@ -30,4 +36,4 @@ do_install_append() {
INITSCRIPT_NAME = "exquisite"
INITSCRIPT_PARAMS = "start 01 S . stop 20 0 1 6 ."
-FILES_${PN} += "/mnt/.exquisite/"
+FILES_${PN} += "/mnt/.splash/"