aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/e17
diff options
context:
space:
mode:
authorKoen Kooi <koen@openembedded.org>2009-04-08 08:54:50 +0200
committerKoen Kooi <koen@openembedded.org>2009-04-08 08:54:50 +0200
commitc528cdb0ba96927d94a4a3c8389dfbc0e825903a (patch)
tree6f3f4ceda3755e1a891a03f199cddc3cb63cb184 /recipes/e17
parentae48ce485442fa2c1a7d0552bf6b4ea10fe692cf (diff)
downloadopenembedded-c528cdb0ba96927d94a4a3c8389dfbc0e825903a.tar.gz
e-wm: fix profile selection in first-run wizard
Diffstat (limited to 'recipes/e17')
-rw-r--r--recipes/e17/e-wm/fix-profiles.diff10
-rw-r--r--recipes/e17/e-wm_svn.bb3
2 files changed, 12 insertions, 1 deletions
diff --git a/recipes/e17/e-wm/fix-profiles.diff b/recipes/e17/e-wm/fix-profiles.diff
new file mode 100644
index 0000000000..d6de73457e
--- /dev/null
+++ b/recipes/e17/e-wm/fix-profiles.diff
@@ -0,0 +1,10 @@
+===================================================================
+--- e/src/bin/e_config.c (revision 39880)
++++ e/src/bin/e_config.c (revision 39889)
+@@ -1134,5 +1134,5 @@
+ }
+ dir = e_prefix_data_get();
+- len = snprintf(buf, sizeof(buf), "%s/data/config", dir);
++ len = snprintf(buf, sizeof(buf), "%s/data/config/", dir);
+ if (len >= (int)sizeof(buf))
+ return NULL;
diff --git a/recipes/e17/e-wm_svn.bb b/recipes/e17/e-wm_svn.bb
index c9694fce80..e61bce88d3 100644
--- a/recipes/e17/e-wm_svn.bb
+++ b/recipes/e17/e-wm_svn.bb
@@ -2,7 +2,7 @@ DESCRIPTION = "The Enlightenment Window Manager Version 17"
DEPENDS = "eet evas ecore edje efreet edbus"
LICENSE = "MIT BSD"
PV = "0.16.999.050+svnr${SRCREV}"
-PR = "r4"
+PR = "r5"
inherit e update-alternatives
@@ -69,6 +69,7 @@ SRC_URI = "\
file://enlightenment_start.oe \
file://applications.menu \
file://gsm-segfault-fix.patch;patch=1;maxrev=37617 \
+ file://fix-profiles.diff;patch=1;maxrev=39889 \
"
SRC_URI_append_openmoko = " file://illume-disable-screensaver.patch;patch=1 "