aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/e17
diff options
context:
space:
mode:
authorMartin Jansa <Martin.Jansa@gmail.com>2011-01-30 00:30:52 +0100
committerMartin Jansa <Martin.Jansa@gmail.com>2011-01-30 00:32:50 +0100
commitc525dc894a3e6ba61c07901d776b30d65becde32 (patch)
treea3b3a84f752519abfaa4ae43509c3ed89733e976 /recipes/e17
parente341fb2ca67ea7670ca15379050992e81efa5697 (diff)
downloadopenembedded-c525dc894a3e6ba61c07901d776b30d65becde32.tar.gz
waker: fix build without ecore_string_init and ecore_string_shutdown
Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'recipes/e17')
-rw-r--r--recipes/e17/waker/0001-waker-remove-old-ecore_string_init-and-ecore_string_.patch54
-rw-r--r--recipes/e17/waker_svn.bb5
2 files changed, 58 insertions, 1 deletions
diff --git a/recipes/e17/waker/0001-waker-remove-old-ecore_string_init-and-ecore_string_.patch b/recipes/e17/waker/0001-waker-remove-old-ecore_string_init-and-ecore_string_.patch
new file mode 100644
index 0000000000..2e9d1046dd
--- /dev/null
+++ b/recipes/e17/waker/0001-waker-remove-old-ecore_string_init-and-ecore_string_.patch
@@ -0,0 +1,54 @@
+From b6296958d5516a735053ee4140e85e2b3a896182 Mon Sep 17 00:00:00 2001
+From: Martin Jansa <Martin.Jansa@gmail.com>
+Date: Sun, 30 Jan 2011 00:27:57 +0100
+Subject: [PATCH] waker: remove old ecore_string_init and ecore_string_shutdown
+
+Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
+---
+ src/bin/waker_main.c | 2 --
+ src/bin/waker_tool.c | 2 --
+ 2 files changed, 0 insertions(+), 4 deletions(-)
+
+diff --git a/src/bin/waker_main.c b/src/bin/waker_main.c
+index b229cf0..dd54b31 100644
+--- a/src/bin/waker_main.c
++++ b/src/bin/waker_main.c
+@@ -568,7 +568,6 @@ main(int argc, char **argv)
+ E_DBus_Connection *c;
+
+ ecore_init();
+- ecore_string_init();
+ ecore_app_args_set(argc, (const char **)argv);
+ e_dbus_init();
+
+@@ -586,7 +585,6 @@ main(int argc, char **argv)
+
+ e_dbus_connection_close(c);
+ e_dbus_shutdown();
+- ecore_string_shutdown();
+ ecore_shutdown();
+
+ return 0;
+diff --git a/src/bin/waker_tool.c b/src/bin/waker_tool.c
+index 3344fd2..52515c9 100644
+--- a/src/bin/waker_tool.c
++++ b/src/bin/waker_tool.c
+@@ -93,7 +93,6 @@ main(int argc, char **argv)
+ }
+
+ ecore_init();
+- ecore_string_init();
+ ecore_app_args_set(argc, (const char **)argv);
+ e_dbus_init();
+
+@@ -301,7 +300,6 @@ main(int argc, char **argv)
+
+ e_dbus_connection_close(c);
+ e_dbus_shutdown();
+- ecore_string_shutdown();
+ ecore_shutdown();
+
+ return 0;
+--
+1.7.4.rc3
+
diff --git a/recipes/e17/waker_svn.bb b/recipes/e17/waker_svn.bb
index 73e7235218..72ce92aafb 100644
--- a/recipes/e17/waker_svn.bb
+++ b/recipes/e17/waker_svn.bb
@@ -8,7 +8,10 @@ SRCREV = "${EFL_SRCREV}"
inherit efl
-SRC_URI = "${E_SVN}/trunk/TMP/st;module=${SRCNAME};proto=http"
+SRC_URI = "\
+ ${E_SVN}/trunk/TMP/st;module=${SRCNAME};proto=http \
+ file://0001-waker-remove-old-ecore_string_init-and-ecore_string_.patch \
+"
S = "${WORKDIR}/${SRCNAME}"
FILES_${PN} += "${bindir}/* ${libdir}/lib*.so.*"