aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/ebtables/ebtables-2.0.9-2/installnonroot.patch
diff options
context:
space:
mode:
authorRoman I Khimov <khimov@altell.ru>2010-05-25 14:19:55 +0400
committerRoman I Khimov <khimov@altell.ru>2010-06-10 23:03:21 +0400
commit6e65ca4068eb9a5a58050ceceaf8bd231c876c47 (patch)
tree5c515a710fb6c799924fe7c0da7c333e10446ef6 /recipes/ebtables/ebtables-2.0.9-2/installnonroot.patch
parent7f9cfe4fb94e97176bc6ba0ff8589a6f69813298 (diff)
downloadopenembedded-6e65ca4068eb9a5a58050ceceaf8bd231c876c47.tar.gz
ebtables: add version 2.0.9-2
* the ebtables package produced with this version is three times bigger than for version 2.0.6, thus not deleting version 2.0.6 * other than that, considered as safe upgrade with nice functional enhancements Signed-off-by: Roman I Khimov <khimov@altell.ru>
Diffstat (limited to 'recipes/ebtables/ebtables-2.0.9-2/installnonroot.patch')
-rw-r--r--recipes/ebtables/ebtables-2.0.9-2/installnonroot.patch45
1 files changed, 45 insertions, 0 deletions
diff --git a/recipes/ebtables/ebtables-2.0.9-2/installnonroot.patch b/recipes/ebtables/ebtables-2.0.9-2/installnonroot.patch
new file mode 100644
index 0000000000..4d42cc09ed
--- /dev/null
+++ b/recipes/ebtables/ebtables-2.0.9-2/installnonroot.patch
@@ -0,0 +1,45 @@
+
+#
+# Patch managed by http://www.mn-logistik.de/unsupported/pxa250/patcher
+#
+
+Index: ebtables-v2.0.9-2/Makefile
+===================================================================
+--- ebtables-v2.0.9-2.orig/Makefile 2010-02-04 00:17:45.000000000 +0300
++++ ebtables-v2.0.9-2/Makefile 2010-05-24 16:15:35.000000000 +0400
+@@ -154,28 +154,28 @@
+ .PHONY: scripts
+ scripts: ebtables-save ebtables.sysv ebtables-config
+ cat ebtables-save | sed 's/__EXEC_PATH__/$(tmp1)/g' > ebtables-save_
+- install -m 0755 -o root -g root ebtables-save_ $(DESTDIR)$(BINDIR)/ebtables-save
++ install -m 0755 ebtables-save_ $(DESTDIR)$(BINDIR)/ebtables-save
+ cat ebtables.sysv | sed 's/__EXEC_PATH__/$(tmp1)/g' | sed 's/__SYSCONFIG__/$(tmp2)/g' > ebtables.sysv_
+- install -m 0755 -o root -g root ebtables.sysv_ $(DESTDIR)$(INITDIR)/ebtables
++ install -m 0755 ebtables.sysv_ $(DESTDIR)$(INITDIR)/ebtables
+ cat ebtables-config | sed 's/__SYSCONFIG__/$(tmp2)/g' > ebtables-config_
+- install -m 0600 -o root -g root ebtables-config_ $(DESTDIR)$(SYSCONFIGDIR)/ebtables-config
++ install -m 0600 ebtables-config_ $(DESTDIR)$(SYSCONFIGDIR)/ebtables-config
+ rm -f ebtables-save_ ebtables.sysv_ ebtables-config_
+
+ $(MANDIR)/man8/ebtables.8: ebtables.8
+ mkdir -p $(DESTDIR)$(@D)
+ sed 's/$$(VERSION)/$(PROGVERSION)/' ebtables.8 | sed 's/$$(DATE)/$(PROGDATE)/' > ebtables.8_
+- install -m 0644 -o root -g root ebtables.8_ $(DESTDIR)$@
++ install -m 0644 ebtables.8_ $(DESTDIR)$@
+ rm -f ebtables.8_
+
+ $(ETHERTYPESFILE): ethertypes
+ mkdir -p $(DESTDIR)$(@D)
+- install -m 0644 -o root -g root $< $(DESTDIR)$@
++ install -m 0644 $< $(DESTDIR)$@
+
+ .PHONY: exec
+ exec: ebtables ebtables-restore
+ mkdir -p $(DESTDIR)$(BINDIR)
+- install -m 0755 -o root -g root $(PROGNAME) $(DESTDIR)$(BINDIR)/$(PROGNAME)
+- install -m 0755 -o root -g root ebtables-restore $(DESTDIR)$(BINDIR)/ebtables-restore
++ install -m 0755 $(PROGNAME) $(DESTDIR)$(BINDIR)/$(PROGNAME)
++ install -m 0755 ebtables-restore $(DESTDIR)$(BINDIR)/ebtables-restore
+
+ .PHONY: install
+ install: $(MANDIR)/man8/ebtables.8 $(ETHERTYPESFILE) exec scripts