aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/echinus/echinus_0.4.3.2.bb
diff options
context:
space:
mode:
authorAlex Ferguson <thoughtmonster@gmail.com>2010-10-30 21:42:20 +0300
committerKristoffer Ericson <kristoffer.ericson@gmail.com>2010-11-03 16:51:12 +0100
commit51a7e5bed344a8db9fc9f25a6662e35510e2dd92 (patch)
treefd737944d837c4eedb550c5cd1aa79a12ad3890c /recipes/echinus/echinus_0.4.3.2.bb
parentceb9dc2430fc4e0a4c2bd6bb0354f9a80be230c8 (diff)
downloadopenembedded-51a7e5bed344a8db9fc9f25a6662e35510e2dd92.tar.gz
echinus: Add recipes for echinus (a wm) and ourico (a panel for echinus).
* Added echinus-jlime.patch, which contains jlime-specific changes to the echinus window manager * Added ourico-jlime.patch, which contains jlime-specific changes to the ourico panel. * Added Makefiles for both echinus and ourico which add two additional defines, INCS and LIBS which are used for additional defines due to the way OE handles CFLAGS and LDFLAGS. Signed-off-by: Alex Ferguson <thoughtmonster@gmail.com> Signed-off-by: Kristoffer Ericson <kristoffer.ericson@gmail.com>
Diffstat (limited to 'recipes/echinus/echinus_0.4.3.2.bb')
-rw-r--r--recipes/echinus/echinus_0.4.3.2.bb36
1 files changed, 36 insertions, 0 deletions
diff --git a/recipes/echinus/echinus_0.4.3.2.bb b/recipes/echinus/echinus_0.4.3.2.bb
new file mode 100644
index 0000000000..aca8c1877b
--- /dev/null
+++ b/recipes/echinus/echinus_0.4.3.2.bb
@@ -0,0 +1,36 @@
+DESCRIPTION = "echinus is a simple and lightweight tiling and floating window manager for X11."
+SECTION = "x11/wm"
+LICENSE = "MIT"
+PR = "r0"
+
+DEPENDS = "virtual/libx11 libxft"
+
+SRC_URI = "http://plhk.ru/static/echinus/echinus-${PV}.tar.gz \
+ file://Makefile"
+
+SRC_URI_append_jlime = " file://echinus-jlime.patch "
+
+S = "${WORKDIR}/echinus-${PV}"
+
+CONFFILES_${PN} = "/etc/echinus/echinusrc"
+
+do_configure() {
+ mv ${WORKDIR}/Makefile ${S}/Makefile
+ cat <<EOF > config.mk
+VERSION = ${PV}
+
+PREFIX = /usr
+MANPREFIX = /usr/share/man
+CONF = /etc/echinus
+
+INCS = -I. `pkg-config --cflags xft` -Wall -DVERSION=\"${PV}\" -DSYSCONFPATH=\"${sysconfdir}/${PACKAGE}\"
+LIBS = -lc -lX11 `pkg-config --libs xft`
+EOF
+}
+
+do_install() {
+ oe_runmake install DESTDIR=${D}
+}
+
+SRC_URI[md5sum] = "465314d17e9cd63ff2b18ff8f0701305"
+SRC_URI[sha256sum] = "bf41fef15b1d68c91af8f3ad636156e146dd9837638acc174048f58fe9761f3e"