aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/eds
diff options
context:
space:
mode:
authorDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
committerDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
commit709c4d66e0b107ca606941b988bad717c0b45d9b (patch)
tree37ee08b1eb308f3b2b6426d5793545c38396b838 /recipes/eds
parentfa6cd5a3b993f16c27de4ff82b42684516d433ba (diff)
downloadopenembedded-709c4d66e0b107ca606941b988bad717c0b45d9b.tar.gz
rename packages/ to recipes/ per earlier agreement
See links below for more details: http://thread.gmane.org/gmane.comp.handhelds.openembedded/21326 http://thread.gmane.org/gmane.comp.handhelds.openembedded/21816 Signed-off-by: Denys Dmytriyenko <denis@denix.org> Acked-by: Mike Westerhof <mwester@dls.net> Acked-by: Philip Balister <philip@balister.org> Acked-by: Khem Raj <raj.khem@gmail.com> Acked-by: Marcin Juszkiewicz <hrw@openembedded.org> Acked-by: Koen Kooi <koen@openembedded.org> Acked-by: Frans Meulenbroeks <fransmeulenbroeks@gmail.com>
Diffstat (limited to 'recipes/eds')
-rw-r--r--recipes/eds/eds-dbus/disable_orbit.patch13
-rw-r--r--recipes/eds/eds-dbus/fix-bindig-tool.patch22
-rw-r--r--recipes/eds/eds-dbus/iconv-detect.h5
-rw-r--r--recipes/eds/eds-dbus/no_iconv_test.patch70
-rw-r--r--recipes/eds/eds-dbus/no_libdb.patch14
-rw-r--r--recipes/eds/eds-dbus/no_libedataserverui-20060126.patch13
-rw-r--r--recipes/eds/eds-dbus/no_libedataserverui.patch13
-rw-r--r--recipes/eds/eds-dbus/no_libgnome.patch45
-rw-r--r--recipes/eds/eds-dbus_svn.bb53
9 files changed, 248 insertions, 0 deletions
diff --git a/recipes/eds/eds-dbus/disable_orbit.patch b/recipes/eds/eds-dbus/disable_orbit.patch
new file mode 100644
index 0000000000..8757666e9d
--- /dev/null
+++ b/recipes/eds/eds-dbus/disable_orbit.patch
@@ -0,0 +1,13 @@
+Index: trunk/configure.in
+===================================================================
+--- trunk.orig/configure.in 2006-01-20 02:08:42.555073776 +0000
++++ trunk/configure.in 2006-01-20 10:19:13.631870024 +0000
+@@ -1114,7 +1114,7 @@
+ AC_MSG_RESULT($with_bug_buddy)
+
+ if test "x${with_dbus}" = "xno"; then
+- AM_PATH_ORBIT2(2.9.8)
++dnl AM_PATH_ORBIT2(2.9.8)
+
+ AC_MSG_CHECKING(for CORBA include paths)
+ IDL_INCLUDES="-I "`pkg-config --variable=idldir libbonobo-2.0`" -I "`pkg-config --variable=idldir bonobo-activation-2.0`
diff --git a/recipes/eds/eds-dbus/fix-bindig-tool.patch b/recipes/eds/eds-dbus/fix-bindig-tool.patch
new file mode 100644
index 0000000000..704df84f69
--- /dev/null
+++ b/recipes/eds/eds-dbus/fix-bindig-tool.patch
@@ -0,0 +1,22 @@
+--- /tmp/Makefile.am 2007-01-16 13:56:57.000000000 +0100
++++ trunk/calendar/libecal-dbus/Makefile.am 2007-01-16 13:57:40.045251000 +0100
+@@ -64,7 +64,7 @@
+ dbus-binding-tool --mode=glib-server --output=$@ --prefix=$(subst -,_,$*) $^
+
+ %-bindings.h: ../libedata-cal-dbus/%.xml
+- dbus-binding-tool --mode=glib-client --output=$@ $^
++ dbus-binding-tool --mode=glib-client --prefix= --output=$@ $^
+
+ BUILT_SOURCES = $(DBUS_GENERATED_H) $(MARSHAL_GENERATED)
+ CLEANFILES = $(BUILT_SOURCES)
+--- /tmp/Makefile.am 2007-01-16 14:05:49.000000000 +0100
++++ trunk/calendar/libedata-cal-dbus/Makefile.am 2007-01-16 14:06:15.865251000 +0100
+@@ -90,7 +90,7 @@
+ dbus-binding-tool --mode=glib-server --output=$@ --prefix=$(subst -,_,$*) $^
+
+ %-bindings.h: %.xml
+- dbus-binding-tool --mode=glib-client --output=$@ $^
++ dbus-binding-tool --mode=glib-client --prefix= --output=$@ $^
+
+
+ DBUS_BINDINGS = e-data-cal-factory-bindings.h e-data-cal-bindings.h e-data-cal-view-bindings.h
diff --git a/recipes/eds/eds-dbus/iconv-detect.h b/recipes/eds/eds-dbus/iconv-detect.h
new file mode 100644
index 0000000000..46f476d5bc
--- /dev/null
+++ b/recipes/eds/eds-dbus/iconv-detect.h
@@ -0,0 +1,5 @@
+/* This is an auto-generated header, DO NOT EDIT! */
+
+#define ICONV_ISO_D_FORMAT "iso-%d-%d"
+#define ICONV_ISO_S_FORMAT "iso-%d-%s"
+#define ICONV_10646 "iso-10646"
diff --git a/recipes/eds/eds-dbus/no_iconv_test.patch b/recipes/eds/eds-dbus/no_iconv_test.patch
new file mode 100644
index 0000000000..6e33c7889e
--- /dev/null
+++ b/recipes/eds/eds-dbus/no_iconv_test.patch
@@ -0,0 +1,70 @@
+Index: trunk/configure.in
+===================================================================
+--- trunk.orig/configure.in 2005-09-28 17:34:08.000000000 +0000
++++ trunk/configure.in 2005-09-28 19:13:22.000000000 +0000
+@@ -213,39 +213,6 @@
+ if test $ac_cv_libiconv = no; then
+ AC_CHECK_FUNCS(gnu_get_libc_version)
+ fi
+- AC_CACHE_CHECK([if iconv() handles UTF-8], ac_cv_libiconv_utf8, AC_TRY_RUN([
+-#include <iconv.h>
+-#include <stdlib.h>
+-#include <string.h>
+-#ifdef HAVE_GNU_GET_LIBC_VERSION
+-#include <gnu/libc-version.h>
+-#endif
+-
+-int main (int argc, char **argv)
+-{
+- const char *from = "Some Text \xA4";
+- const char *utf8 = "Some Text \xC2\xA4";
+- char *transbuf = malloc (20), *trans = transbuf;
+- iconv_t cd;
+- size_t from_len = strlen (from), utf8_len = 20;
+- size_t utf8_real_len = strlen (utf8);
+-
+-#ifdef HAVE_GNU_GET_LIBC_VERSION
+- /* glibc 2.1.2's iconv is broken in hard to test ways. */
+- if (!strcmp (gnu_get_libc_version (), "2.1.2"))
+- exit (1);
+-#endif
+-
+- cd = iconv_open ("UTF-8", "ISO_8859-1");
+- if (cd == (iconv_t) -1)
+- exit (1);
+- if (iconv (cd, &from, &from_len, &trans, &utf8_len) == -1 || from_len != 0)
+- exit (1);
+- if (memcmp (utf8, transbuf, utf8_real_len) != 0)
+- exit (1);
+-
+- exit (0);
+-}], ac_cv_libiconv_utf8=yes, [ac_cv_libiconv_utf8=no; have_iconv=no], [ac_cv_libiconv_utf8=no; have_iconv=no]))
+ fi
+
+ if test "$have_iconv" = no; then
+@@ -254,25 +221,6 @@
+ AC_SUBST(ICONV_CFLAGS)
+ AC_SUBST(ICONV_LIBS)
+
+-CFLAGS="$CFLAGS -I$srcdir"
+-
+-AC_MSG_CHECKING(preferred charset formats for system iconv)
+-AC_TRY_RUN([
+-#define CONFIGURE_IN
+-#include "iconv-detect.c"
+-],[
+- AC_MSG_RESULT(found)
+-],[
+- AC_MSG_RESULT(not found)
+- AC_WARN([
+- *** The iconv-detect program was unable to determine the
+- *** preferred charset formats recognized by your system
+- *** iconv library. It is suggested that you install a
+- *** working iconv library such as the one found at
+- *** ftp://ftp.gnu.org/pub/gnu/libiconv
+- ])
+-])
+-
+ CFLAGS="$save_CFLAGS"
+ LIBS="$save_LIBS"
+
diff --git a/recipes/eds/eds-dbus/no_libdb.patch b/recipes/eds/eds-dbus/no_libdb.patch
new file mode 100644
index 0000000000..ae9a66deac
--- /dev/null
+++ b/recipes/eds/eds-dbus/no_libdb.patch
@@ -0,0 +1,14 @@
+Index: configure.in
+===================================================================
+--- trunk/configure.in (revision 306)
++++ trunk/configure.in (working copy)
+@@ -1353,9 +1353,6 @@
+ if test $enable_calendar = yes; then
+ AC_CONFIG_SUBDIRS(calendar/libical)
+ fi
+-if test $dynamic_libdb = no; then
+- AC_CONFIG_SUBDIRS(libdb/dist)
+-fi
+
+ AC_OUTPUT([
+ Makefile
diff --git a/recipes/eds/eds-dbus/no_libedataserverui-20060126.patch b/recipes/eds/eds-dbus/no_libedataserverui-20060126.patch
new file mode 100644
index 0000000000..bb6f78d9f7
--- /dev/null
+++ b/recipes/eds/eds-dbus/no_libedataserverui-20060126.patch
@@ -0,0 +1,13 @@
+Index: Makefile.am
+===================================================================
+--- trunk/Makefile.am (revision 306)
++++ trunk/Makefile.am (working copy)
+@@ -16,7 +16,7 @@
+ endif
+
+ if ENABLE_DBUS
+-SUBDIRS = $(LIBDB) libedataserver $(CAMEL_DIR) addressbook $(CALENDAR_DIR) libedataserverui docs art po
++SUBDIRS = $(LIBDB) libedataserver $(CAMEL_DIR) addressbook $(CALENDAR_DIR) docs art po
+ else
+ SUBDIRS = $(LIBDB) libedataserver servers $(CAMEL_DIR) addressbook $(CALENDAR_DIR) libedataserverui src docs art po
+ endif
diff --git a/recipes/eds/eds-dbus/no_libedataserverui.patch b/recipes/eds/eds-dbus/no_libedataserverui.patch
new file mode 100644
index 0000000000..766c547a56
--- /dev/null
+++ b/recipes/eds/eds-dbus/no_libedataserverui.patch
@@ -0,0 +1,13 @@
+Index: Makefile.am
+===================================================================
+--- trunk/Makefile.am (revision 306)
++++ trunk/Makefile.am (working copy)
+@@ -16,7 +16,7 @@
+ endif
+
+ if ENABLE_DBUS
+-SUBDIRS = $(LIBDB) libedataserver camel addressbook $(CALENDAR_DIR) libedataserverui docs art po
++SUBDIRS = $(LIBDB) libedataserver camel addressbook $(CALENDAR_DIR) docs art po
+ else
+ SUBDIRS = $(LIBDB) libedataserver servers $(CAMEL_DIR) addressbook $(CALENDAR_DIR) libedataserverui src docs art po
+ endif
diff --git a/recipes/eds/eds-dbus/no_libgnome.patch b/recipes/eds/eds-dbus/no_libgnome.patch
new file mode 100644
index 0000000000..a8bae50d03
--- /dev/null
+++ b/recipes/eds/eds-dbus/no_libgnome.patch
@@ -0,0 +1,45 @@
+Index: trunk/configure.in
+===================================================================
+--- trunk.orig/configure.in 2005-09-28 20:01:02.000000000 +0000
++++ trunk/configure.in 2005-09-28 21:02:35.000000000 +0000
+@@ -1120,7 +1120,12 @@
+ AC_SUBST(E_DATA_SERVER_CFLAGS)
+ AC_SUBST(E_DATA_SERVER_LIBS)
+
+-E_DATA_SERVER_UI_DEPS="gtk+-2.0 libglade-2.0 gconf-2.0 libgnome-2.0"
++if test "x${with_libgnome}" != "xno"; then
++ E_DATA_SERVER_UI_DEPS="gtk+-2.0 libglade-2.0 gconf-2.0 libgnome-2.0"
++else
++ E_DATA_SERVER_UI_DEPS="gtk+-2.0 libglade-2.0 gconf-2.0"
++fi
++
+
+ EVO_SET_COMPILE_FLAGS(E_DATA_SERVER_UI, $E_DATA_SERVER_UI_DEPS, $THREADS_CFLAGS, $THREADS_LIBS)
+ AC_SUBST(E_DATA_SERVER_UI_CFLAGS)
+@@ -1128,7 +1133,7 @@
+
+ dnl --- evolution-addressbook flags
+
+-EVOLUTION_ADDRESSBOOK_DEPS="libxml-2.0 gobject-2.0 gconf-2.0 $IPC_DEPS gnome-vfs-2.0 "
++EVOLUTION_ADDRESSBOOK_DEPS="libxml-2.0 gobject-2.0 gconf-2.0 $IPC_DEPS "
+
+ EVO_SET_COMPILE_FLAGS(EVOLUTION_ADDRESSBOOK, $EVOLUTION_ADDRESSBOOK_DEPS)
+ AC_SUBST(EVOLUTION_ADDRESSBOOK_CFLAGS)
+@@ -1136,7 +1141,7 @@
+
+ dnl --- evolution-calendar flags
+
+-EVOLUTION_CALENDAR_DEPS="libxml-2.0 gobject-2.0 gconf-2.0 gnome-vfs-2.0 dbus-glib-1"
++EVOLUTION_CALENDAR_DEPS="libxml-2.0 gobject-2.0 gconf-2.0 dbus-glib-1"
+
+ EVO_SET_COMPILE_FLAGS(EVOLUTION_CALENDAR, $EVOLUTION_CALENDAR_DEPS)
+ AC_SUBST(EVOLUTION_CALENDAR_CFLAGS)
+@@ -1145,7 +1150,7 @@
+ if test "x${with_dbus}" = "xno"; then
+ dnl --- factory flags
+
+- E_FACTORY_DEPS="gobject-2.0 >= $GLIB_REQUIRED $IPC_DEPS gconf-2.0 gnome-vfs-2.0 libgnome-2.0 $mozilla_nspr"
++ E_FACTORY_DEPS="gobject-2.0 >= $GLIB_REQUIRED $IPC_DEPS gconf-2.0 $mozilla_nspr"
+
+ EVO_SET_COMPILE_FLAGS(E_FACTORY, $E_FACTORY_DEPS, $THREADS_CFLAGS $MANUAL_NSPR_CFLAGS, $THREADS_LIBS $MANUAL_NSPR_LIBS)
+ AC_SUBST(E_FACTORY_CFLAGS)
diff --git a/recipes/eds/eds-dbus_svn.bb b/recipes/eds/eds-dbus_svn.bb
new file mode 100644
index 0000000000..4e40528747
--- /dev/null
+++ b/recipes/eds/eds-dbus_svn.bb
@@ -0,0 +1,53 @@
+DESCRIPTION = "Evolution database backend server"
+HOMEPAGE = "http://projects.o-hand.com/eds"
+LICENSE = "LGPL"
+DEPENDS = "intltool-native libglade glib-2.0 gtk+ gconf dbus db gnome-common virtual/libiconv zlib intltool"
+
+PV = "1.4.0+svnr${SRCREV}"
+PR = "r7"
+
+SRC_URI = "svn://svn.o-hand.com/repos/${PN};module=trunk;proto=http \
+ file://no_libdb.patch;patch=1 \
+ file://no_iconv_test.patch;patch=1 \
+ file://no_libedataserverui.patch;patch=1 \
+ file://iconv-detect.h"
+
+S = "${WORKDIR}/trunk"
+
+inherit autotools pkgconfig
+
+# -ldb needs this on some platforms
+LDFLAGS += "-lpthread"
+
+do_configure_append = " cp ${WORKDIR}/iconv-detect.h ${S} "
+EXTRA_OECONF = "--without-openldap --with-dbus --without-bug-buddy --without-soup --with-libdb=${STAGING_DIR_HOST}${layout_prefix} --disable-smime --disable-nss --disable-nntp --disable-gtk-doc"
+
+PACKAGES =+ "libcamel-collateral libcamel libcamel-dev libebook libebook-dev libecal libecal-dev libedata-book libedata-book-dev libedata-cal libedata-cal-dev libedataserver libedataserver-dev"
+
+FILES_${PN}-dev =+ "${libdir}/pkgconfig/evolution-data-server-*.pc"
+FILES_${PN}-dbg =+ "${libdir}/evolution-data-server-*/camel-providers/.debug ${libdir}/evolution-data-server*/extensions/.debug/"
+
+FILES_libcamel = "${libdir}/libcamel-*.so.* ${libexecdir}/camel-*"
+FILES_libcamel-dev = "${libdir}/libcamel-*.so ${libdir}/libcamel-provider-*.so ${libdir}/pkgconfig/camel*pc ${includedir}/evolution-data-server*/camel"
+FILES_libcamel-collateral = "${libdir}/libcamel-provider-*.so.* ${libdir}/evolution-data-server-*/camel-providers/*.so ${libdir}/evolution-data-server-*/camel-providers/*.urls"
+
+FILES_libebook = "${libdir}/libebook-*.so.*"
+FILES_libebook-dev = "${libdir}/libebook-1.2.so ${libdir}/pkgconfig/libebook-*.pc ${includedir}/evolution-data-server*/libebook/*.h"
+RRECOMMENDS_libebook = "libedata-book"
+
+FILES_libecal = "${libdir}/libecal-*.so.* ${datadir}/evolution-data-server-1.4/zoneinfo"
+FILES_libecal-dev = "${libdir}/libecal-*.so ${libdir}/pkgconfig/libecal-*.pc ${includedir}/evolution-data-server*/libecal/*.h ${includedir}/evolution-data-server*/libical/*.h"
+RRECOMMENDS_libecal = "libedata-cal tzdata"
+
+FILES_libedata-book = "${libexecdir}/e-addressbook-factory ${datadir}/dbus-1/services/*.AddressBook.service ${libdir}/libedata-book-*.so.* ${libdir}/evolution-data-server-*/extensions/libebook*.so"
+FILES_libedata-book-dev = "${libdir}/libedata-book-*.so ${libdir}/pkgconfig/libedata-book-*.pc ${includedir}/evolution-data-server-*/libedata-book"
+
+FILES_libedata-cal = "${libexecdir}/e-calendar-factory ${datadir}/dbus-1/services/*.Calendar.service ${libdir}/libedata-cal-*.so.* ${libdir}/evolution-data-server-*/extensions/libecal*.so"
+FILES_libedata-cal-dev = "${libdir}/libedata-cal-*.so ${libdir}/pkgconfig/libedata-cal-*.pc ${includedir}/evolution-data-server-*/libedata-cal"
+
+FILES_libedataserver = "${libdir}/libedataserver-*.so.*"
+FILES_libedataserver-dev = "${libdir}/libedataserver-*.so ${libdir}/pkgconfig/libedataserver-*.pc ${includedir}/evolution-data-server-*/libedataserver/*.h"
+
+do_stage () {
+ autotools_stage_all
+}