aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/efl1
diff options
context:
space:
mode:
authorMichael 'Mickey' Lauer <mickey@vanille-media.de>2010-03-14 20:52:30 +0100
committerMichael 'Mickey' Lauer <mickey@vanille-media.de>2010-03-14 21:00:11 +0100
commit64eae2b3c9e74a84a3f27ed68bdd91e2da7a3b5b (patch)
tree44b9866b0ee18bf7da439e467bbeff6cd9d53241 /recipes/efl1
parentf86ca9a3415a7063e3d60d2d7810ac4928e8c9e6 (diff)
downloadopenembedded-64eae2b3c9e74a84a3f27ed68bdd91e2da7a3b5b.tar.gz
ecore: add patch that fixes the ecore-fb touchscreen initialization
With this patch, we have a working touchscreen in framebuffer mode again
Diffstat (limited to 'recipes/efl1')
-rw-r--r--recipes/efl1/ecore.inc6
-rw-r--r--recipes/efl1/ecore/fix-ecore-fb-initialization.patch29
-rw-r--r--recipes/efl1/ecore_svn.bb11
3 files changed, 38 insertions, 8 deletions
diff --git a/recipes/efl1/ecore.inc b/recipes/efl1/ecore.inc
index ef3ba55d55..69d3f7607c 100644
--- a/recipes/efl1/ecore.inc
+++ b/recipes/efl1/ecore.inc
@@ -5,10 +5,12 @@ DEPENDS = "gettext-native virtual/libiconv curl eet evas tslib glib-2.0 \
# optional
# DEPENDS += "directfb libsdl-x11 openssl virtual/libiconv"
PV = "0.9.9.060+svnr${SRCPV}"
-PR = "r3"
+PR = "r4"
inherit efl
+SRC_URI += "file://fix-ecore-fb-initialization.patch;patch=1"
+
do_configure_prepend() {
touch ${S}/po/Makefile.in.in || true
sed -i -e 's: po::g' ${S}/Makefile.am
@@ -71,5 +73,3 @@ FILES_${PN}-txt = "${libdir}/libecore_txt*.so.*"
FILES_${PN}-x = "${libdir}/libecore_x*.so.*"
FILES_${PN}-input = "${libdir}/libecore_input*.so.*"
-
-
diff --git a/recipes/efl1/ecore/fix-ecore-fb-initialization.patch b/recipes/efl1/ecore/fix-ecore-fb-initialization.patch
new file mode 100644
index 0000000000..2ac61ca63c
--- /dev/null
+++ b/recipes/efl1/ecore/fix-ecore-fb-initialization.patch
@@ -0,0 +1,29 @@
+#
+# The whole ecore-fb init logic is somewhat flawed; with this patch we
+# get at least a working touchscreen w/ tslib again.
+#
+# Signed-off-by: Michael 'Mickey' Lauer <mlauer@vanille-media.de>
+#
+
+Index: ecore/src/lib/ecore_fb/ecore_fb.c
+===================================================================
+--- ecore.orig/src/lib/ecore_fb/ecore_fb.c
++++ ecore/src/lib/ecore_fb/ecore_fb.c
+@@ -46,6 +46,9 @@
+
+ if (!ecore_fb_vt_init())
+ return --_ecore_fb_init_count;
++
++ if (!ecore_fb_ts_init())
++ return --_ecore_fb_init_count;
+
+ ECORE_FB_EVENT_KEY_DOWN = ecore_event_type_new();
+ ECORE_FB_EVENT_KEY_UP = ecore_event_type_new();
+@@ -70,6 +73,7 @@
+ if (--_ecore_fb_init_count != 0)
+ return _ecore_fb_init_count;
+
++ ecore_fb_ts_shutdown();
+ ecore_fb_vt_shutdown();
+
+ return _ecore_fb_init_count;
diff --git a/recipes/efl1/ecore_svn.bb b/recipes/efl1/ecore_svn.bb
index 2354673eb3..6fc4676214 100644
--- a/recipes/efl1/ecore_svn.bb
+++ b/recipes/efl1/ecore_svn.bb
@@ -1,10 +1,11 @@
require ecore.inc
-PR = "r7"
+PR = "r8"
-SRC_URI += "file://iconv.patch;patch=1;maxrev=43996 \
- file://exit_uclibc_dns.patch;patch=1;maxrev=47076 \
- file://exit_uclibc.patch;patch=1 \
- "
+SRC_URI += "\
+ file://iconv.patch;patch=1;maxrev=43996 \
+ file://exit_uclibc_dns.patch;patch=1;maxrev=47076 \
+ file://exit_uclibc.patch;patch=1 \
+"
EXTRA_OECONF = "\
--x-includes=${STAGING_INCDIR}/X11 \