aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/efl1
diff options
context:
space:
mode:
authorGraham Gower <graham.gower@gmail.com>2010-07-06 16:40:49 +0000
committerKhem Raj <raj.khem@gmail.com>2010-07-06 21:17:44 -0700
commit9247871d8e272b17b4746b69e006d3aa3889e373 (patch)
treeea43fec8e489bb2a0c22edd91419a65e0c8b4c95 /recipes/efl1
parent76e745add323ff2d25f164d31a415aff98feba6c (diff)
downloadopenembedded-9247871d8e272b17b4746b69e006d3aa3889e373.tar.gz
imlib2_svn.bb: Don't use host /usr/X11R6/include and /usr/X11R6/lib.
Fixes the following problem, where host asm cannot build for target. ccache mipsel-angstrom-linux-gcc -march=mips32 -DHAVE_CONFIG_H -I. -I../.. -I../lib -I../../src/lib -DPACKAGE_DATA_DIR=\"/usr/share/imlib2\" -I/home/grg/oe2/tmp/sysroots/mipsel-angstrom-linux/usr/include/freetype2 -I/home/grg/oe2/tmp/sysroots/mipsel-angstrom-linux/usr/include -I/usr/X11R6/include -isystem/home/grg/oe2/tmp/sysroots/mipsel-angstrom-linux/usr/include -std=gnu99 -isystem/home/grg/oe2/tmp/sysroots/mipsel-angstrom-linux/usr/include -fexpensive-optimizations -frename-registers -fomit-frame-pointer -O2 -ggdb3 -MT imlib2_view.o -MD -MP -MF .deps/imlib2_view.Tpo -c -o imlib2_view.o imlib2_view.c imlib2_view.c: In function 'main': imlib2_view.c:296: error: can't find a register in class 'COP3_REGS' while reloading 'asm' imlib2_view.c:296: error: 'asm' operand has impossible constraints Signed-off-by: Graham Gower <graham.gower@gmail.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'recipes/efl1')
-rw-r--r--recipes/efl1/imlib2_svn.bb6
1 files changed, 4 insertions, 2 deletions
diff --git a/recipes/efl1/imlib2_svn.bb b/recipes/efl1/imlib2_svn.bb
index 1db9e6009c..c0616be181 100644
--- a/recipes/efl1/imlib2_svn.bb
+++ b/recipes/efl1/imlib2_svn.bb
@@ -4,12 +4,14 @@ LICENSE = "BSD"
DEPENDS = "freetype libpng jpeg virtual/libx11 libxext"
PROVIDES = "virtual/imlib2"
PV = "1.4.2.001+svnr${SRCPV}"
-PR = "r1"
+PR = "r2"
SRCREV = "${EFL_SRCREV}"
inherit efl
-EXTRA_OECONF = "--with-x"
+EXTRA_OECONF = "--with-x \
+ --x-includes=${STAGING_INCDIR} \
+ --x-libraries=${STAGING_LIBDIR} "
# TODO: Use more fine granular version
#OE_LT_RPATH_ALLOW=":${libdir}/imlib2/loaders:${libdir}/imlib2/filters:"